Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029417
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-03-26 08:342015-03-31 00:07
ReporterumartirenaView Statuspublic 
Assigned Toumartirena 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionae0dfbc0396e
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029417: [Cost Adjustment] Adjustment amounts of more than 2 decimal precision are being created in costing background

DescriptionWhile running Costing Background process with the functionality of Cost Adjustments, in certain cases adjustment are being created of amount with more than two decimal precision, and this is wrong, as an amount always has to has at most two decimal precision. Two cases detected are while using orphan lines or negative amount shipments.
Steps To ReproduceIn live.builds

As System Admin:
 * Change costing precision and price precision to 4 for EUR Currency.

In F&B:
 * Enable "RM Allow Orphan Line" preference.
 * Have a valid average costing rule for F&B España org.
 * Create a Product
 * Add a Costing Record:
  - Org: F&B España
  - Cost: 5.5555
  - Cost Type: Average
  - Starting Date: 01/01/2014
  - Ending Date: 31/12/9999
 * Create a Goods Shipment:
  - Org: F&B España
  - Business Partner: Alimentos y Supermercados
  - Movement Date: 10/02/2015
 * Add a Line:
  - Product: The new product
  - Qty: 10.257
  - Storage Bin: RN 0-0-0
 * Complete it
 * Go to Return from Customer window
 * Create a Header:
  - Org: F&B España
  - Business Partner: Alimentos y Supermercados
  - Order Date: 05/02/2015
 * Click on "Insert Orphan Line":
  - Product: The new product
  - Returned: 5.236
  - Unit Price: 12.33
  - Tax: Arrendamiento 21% (Cobros) - IVA Normal
 * Click OK and Book it
 * Go to Return Material Receipt:
 * Create a Header:
  - Org: F&B España
  - Business Partner: Alimentos y Supermercados
  - Movement Date: 05/02/2015
 * Click on Pick/Edit Lines:
 * Select the line created in previous Return from Customer
  - Received: 5.236
  - Storage Bin: RN 0-0-0
 * Click Done and Complete it
 * Go to Process Request window
 * Run Costing Background process

 * In pgadmin run the following query: "select * from m_costadjustmentline order by created desc"

 Realize that an adjustment line of amount -0.0045 has been created, what is wrong because it should have been of 0.00 amount.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00294233.0PR15Q1.2 closedumartirena [Cost Adjustment] Adjustment amounts of more than 2 decimal precision are being created in costing background 

-  Notes
(0076085)
hgbot (developer)
2015-03-27 13:53

Repository: erp/devel/pi
Changeset: ae0dfbc0396e9174528cb01ad53b547f11ffc92d
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Mar 26 08:59:50 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ae0dfbc0396e9174528cb01ad53b547f11ffc92d [^]

Fixes bug 29417: Round with standard precision cost adjutment amounts

There are certain places in which the amount to be adjusted was being rounded to costing precision, instead of standard precision, and this is wrong because the amounts allways has to be at most of precision 2.

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0076086)
aferraz (developer)
2015-03-27 13:57

Code review + Testing OK
(0076160)
hudsonbot (developer)
2015-03-31 00:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/34da08f135b8 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-26 08:34 umartirena New Issue
2015-03-26 08:34 umartirena Assigned To => Sandrahuguet
2015-03-26 08:34 umartirena Modules => Core
2015-03-26 08:34 umartirena Triggers an Emergency Pack => No
2015-03-26 08:37 umartirena Steps to Reproduce Updated View Revisions
2015-03-26 08:37 umartirena Assigned To Sandrahuguet => umartirena
2015-03-26 08:55 umartirena Steps to Reproduce Updated View Revisions
2015-03-26 10:28 umartirena Status new => scheduled
2015-03-27 13:53 hgbot Checkin
2015-03-27 13:53 hgbot Note Added: 0076085
2015-03-27 13:53 hgbot Status scheduled => resolved
2015-03-27 13:53 hgbot Resolution open => fixed
2015-03-27 13:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ae0dfbc0396e9174528cb01ad53b547f11ffc92d [^]
2015-03-27 13:57 aferraz Review Assigned To => aferraz
2015-03-27 13:57 aferraz Note Added: 0076086
2015-03-27 13:57 aferraz Status resolved => closed
2015-03-27 14:43 umartirena Target Version => 3.0PR15Q2
2015-03-31 00:07 hudsonbot Checkin
2015-03-31 00:07 hudsonbot Note Added: 0076160


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker