Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028623
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2015-01-15 12:582015-02-04 20:34
ReporterAugustoMauchView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revisione3b446f2e3b0
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelCoding ( Testing )
Regression date2014-11-27
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d60c4bb642ea8203e7744cf4f58f9851b004b869 [^]
Triggers an Emergency PackNo
Summary

0028623: When a user opens a window using the Create New widget, the entry in the Recent Views list will not allow to create a new record

DescriptionIn the recent views list the list of the last five opened window is shown. If the user can add records in header tab of those windows, there will be a green icon beside the window name in the recent views list. Clicking that icon will create a new record in the header tab of that window.

The problem is that if the user opens a window using the Create New widget, when the window is added to the recent views list the green icon will not be shown.
Steps To Reproduce- Using the create new widget open any window that allows creating records and that is not currently shown in the recent views list. The window will be opened in form view so that the user can create a new record.
- Go back to the workspace and check that the window has been added to the recent views list, but that the green icon is not shown.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00277873.0PR15Q1 closedNaroaIriarte Create new in workspace allows the user to create new entries in tabs defined as Edit Only 
related to defect 0028679 acknowledgedplatform After opening a record/view from the direct link, the window is not shown in recent views layout. 

-  Notes
(0073605)
NaroaIriarte (developer)
2015-01-19 14:10

If at first a window was editable and it was possible to create a new record and if one creates a new record from the quick create new menu, that window is cached in the quick create new menu. So, if the role access changes to "read only" or if the UI Pattern for that window changes from "Standard" to "read only", "edit only" or "edit and delete only", it is possible to create a new record clicking in the name which is cached in the quick create new menu.
For avoiding this, we only have to open other windows from the quick create new menu, and at last our window will disappear from there.
(0073606)
NaroaIriarte (developer)
2015-01-19 14:16
edited on: 2015-01-19 14:17

Some tests have been performed:
The same tests that were performed for the issue 27787 and other:

- When tab/window access for role is editable, clicking the quick create new icon
and making sure that the green small "create new" icon by the name of the window, in the
recent views layout, is still there.

- Changing the role's accesses in every combination, and checking if the small "create new" icon by the name of the window in the recent views layout appears or not. This works well too.

(0073659)
hgbot (developer)
2015-01-20 19:01

Repository: erp/devel/pi
Changeset: e3b446f2e3b0077f4fb33ae61e9fb5f61b2d5eb5
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Mon Jan 19 14:42:57 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e3b446f2e3b0077f4fb33ae61e9fb5f61b2d5eb5 [^]

Fixed issue 28623: Window's behaviour changes when creating a new record.

When a window is opened using the "quick create new" widget, the same window in the recent views layout
does not allow to create a new record (the green small button for creating a new record, which should be
by the window name, disappears).

The problem was in the "ob-utilities.js", inside the "{OB.Utilities.openView}" function, the logic for
setting the "singleRecord" value (this is the Edit Only attribute) was wrong. If the value of the
variable singleRecord of that function was undefined or null, as it was in the case of clicking the "quick create new"
widget, that value was set to true and the window became an "edit only" window.That was why the small
green "create new" icon disappeared from the recent views layout.

For fixing this the condition has been removed, so we know that the value of the variable "singleRecord" is not
going to be modified and it will be set correctly.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
---
(0073660)
AugustoMauch (developer)
2015-01-20 19:02

Code reviewed and verified in pi@e3b446f2e3b0
(0074167)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-15 12:58 AugustoMauch New Issue
2015-01-15 12:58 AugustoMauch Assigned To => NaroaIriarte
2015-01-15 12:58 AugustoMauch Modules => Core
2015-01-15 12:58 AugustoMauch Regression level => Coding ( Testing )
2015-01-15 12:58 AugustoMauch Regression date => 2014-11-27
2015-01-15 12:58 AugustoMauch Regression introduced in release => main
2015-01-15 12:58 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d60c4bb642ea8203e7744cf4f58f9851b004b869 [^]
2015-01-15 12:58 AugustoMauch Triggers an Emergency Pack => No
2015-01-15 13:05 AugustoMauch Relationship added caused by 0027787
2015-01-19 14:10 NaroaIriarte Note Added: 0073605
2015-01-19 14:16 NaroaIriarte Note Added: 0073606
2015-01-19 14:17 NaroaIriarte Note Edited: 0073606 View Revisions
2015-01-19 16:07 NaroaIriarte Relationship added related to 0028679
2015-01-20 19:01 hgbot Checkin
2015-01-20 19:01 hgbot Note Added: 0073659
2015-01-20 19:01 hgbot Status new => resolved
2015-01-20 19:01 hgbot Resolution open => fixed
2015-01-20 19:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e3b446f2e3b0077f4fb33ae61e9fb5f61b2d5eb5 [^]
2015-01-20 19:02 AugustoMauch Review Assigned To => AugustoMauch
2015-01-20 19:02 AugustoMauch Note Added: 0073660
2015-01-20 19:02 AugustoMauch Status resolved => closed
2015-01-20 19:02 AugustoMauch Fixed in Version => 3.0PR15Q2
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074167


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker