Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027787
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminorhave not tried2014-10-07 17:212014-12-30 23:26
ReporterjonalegriaesarteView Statuspublic 
Assigned ToNaroaIriarte 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revisiond60c4bb642ea
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027787: Create new in workspace allows the user to create new entries in tabs defined as Edit Only

DescriptionCreate new in workspace allows the user to create new entries in tabs defined as Edit Only. The icon to use in the green one in recent views
Steps To Reproduce- Define a window with first tab Edit Only
- Access to it, check that it is working fine
- In Recent Views in workspace, use the create new icon
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
causes defect 00286233.0PR15Q1 closedNaroaIriarte When a user opens a window using the Create New widget, the entry in the Recent Views list will not allow to create a new record 

-  Notes
(0071923)
NaroaIriarte (developer)
2014-11-24 10:07

The "create new" button is also shown when the first tab of a window is "read Only" and when the chosen role's access is "read only" too.
(0072034)
NaroaIriarte (developer)
2014-11-26 14:51

Some tests have been performed:
-Opening the windows from the quick launch menu.
-Opening the windows from the application menu.
-Trying to create a new window by clicking the "create new" icon in the top left corner. If the window/tab access for the role is read only the window does not appear in the drop down list. So, it works well.
-Changing the role's accesses in every combination, and checking if the small "create new" icon by the name of the window in the recent views layout appears or not. This works well too.
(0072035)
NaroaIriarte (developer)
2014-11-26 16:25

The window/tab access for the role is cached in the quick launch menu and in the recent views layout.
This is not a problem because when other windows are opened, these windows are cached in the quick launch menu and in the recent views layout too and at last our window disappears from there.
When our window is opened again, it will be cached in the recent views layout with the correct window/tab access for roles.
(0072242)
hgbot (developer)
2014-12-02 17:28

Repository: erp/devel/pi
Changeset: d60c4bb642ea8203e7744cf4f58f9851b004b869
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Nov 27 09:46:03 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d60c4bb642ea8203e7744cf4f58f9851b004b869 [^]

Fixed issue 27787: Create new icon is shown when windows are readOnly.

When the window/tab access for roles was readOnly, the create new icon was shown by the name of the windows, in the recent views layout.

For fixing this the "MenuManager.java" has been changed.
The logic for the window/tab access for the roles has been created. This is for knowing if the window/tab access for roles is read only or not.
Now, if a role has read only access the "create new" icon is not shown in the recent views layout.
It is good to know that the role access data is cached in the quick launch menu and in the recent views layout, so at first the "create new"
green icon by the name of the window in the recent view layout still appears. It is not a problem because when the window is cached again the
correct status is shown.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/MenuManager.java
---
(0072243)
hgbot (developer)
2014-12-02 17:28

Repository: erp/devel/pi
Changeset: 79198ab4f09b36392019302c09ba7263a413b96d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Dec 01 15:13:04 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/79198ab4f09b36392019302c09ba7263a413b96d [^]

Related with issue 27787: Adds comments and removes unused code

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/MenuManager.java
---
(0072244)
hgbot (developer)
2014-12-02 17:28

Repository: erp/devel/pi
Changeset: 5a8a44dabdce35ef07a1bceb0edc200c7254e4e6
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Tue Dec 02 12:53:17 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5a8a44dabdce35ef07a1bceb0edc200c7254e4e6 [^]

Related with issue 27787: Create new icon is shown when windows are EditOnly

The case of the tab's UI Pattern put as "Edit Only" was not taken in the first fix of the issue.
So that case is fixed now.
When the tab's UI pattern was "Edit Only", the small green icon for "create new" was shown in the
recent views layaout.
For fixing this the "ob-utilities.js" has been changed.
Inside the "{OB.Utilities.openView}" function there was a condition for setting the "singleRecord" value
 (that is the Edit Only attribute) of the tab
to true or false, wich was dependent on other condition. It was not correct, because the "singleRecord" value does not depend
on the other condition for being true nor false.
The condition that evaluates the value of "singleRecord" has been moved outside of the other condition.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
---
(0072306)
AugustoMauch (developer)
2014-12-05 10:52

Code reviewed and verified in pi@5a8a44dabdce
(0073163)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073164)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073165)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-07 17:21 jonalegriaesarte New Issue
2014-10-07 17:21 jonalegriaesarte Assigned To => AugustoMauch
2014-10-07 17:21 jonalegriaesarte Modules => Core
2014-10-07 17:21 jonalegriaesarte Triggers an Emergency Pack => No
2014-11-24 09:28 alostale Assigned To AugustoMauch => NaroaIriarte
2014-11-24 10:07 NaroaIriarte Note Added: 0071923
2014-11-26 14:51 NaroaIriarte Note Added: 0072034
2014-11-26 14:53 NaroaIriarte Review Assigned To => alostale
2014-11-26 16:25 NaroaIriarte Note Added: 0072035
2014-11-28 09:14 alostale Review Assigned To alostale => AugustoMauch
2014-12-02 17:28 hgbot Checkin
2014-12-02 17:28 hgbot Note Added: 0072242
2014-12-02 17:28 hgbot Status new => resolved
2014-12-02 17:28 hgbot Resolution open => fixed
2014-12-02 17:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d60c4bb642ea8203e7744cf4f58f9851b004b869 [^]
2014-12-02 17:28 hgbot Checkin
2014-12-02 17:28 hgbot Note Added: 0072243
2014-12-02 17:28 hgbot Checkin
2014-12-02 17:28 hgbot Note Added: 0072244
2014-12-05 10:52 AugustoMauch Note Added: 0072306
2014-12-05 10:52 AugustoMauch Status resolved => closed
2014-12-05 10:52 AugustoMauch Fixed in Version => 3.0PR15Q1
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073163
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073164
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073165
2015-01-15 13:05 AugustoMauch Relationship added causes 0028623


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker