Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027957
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2014-10-23 10:472015-02-04 20:34
ReporterlorenzofidalgoView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchpiFixed in SCM revisionb4f4fca525d7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-05-28
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/dfda65fa925f89a21eee64f35d7aadb252c90dab [^]
Triggers an Emergency PackNo
Summary

0027957: Changing tab can cause that grid records get stuck

DescriptionThis has been reproduced in PR14Q4 & PR14Q3.1. Creating records in grid view in a specific way and changing tab after that triggers that these records does work properly. Some icons can not be clicked.

In PR14Q2.6 these icons can be clicked.
Steps To ReproduceLogin as Openbravo/openbravo.
Using F&B admin role go to Role window.
Create a new record with the following:
-
Name: Test
User Level: Organization
Manual: Checked
-
Save this record.
Go to "Form access" Tab and click in "Create One" link.
Write in "Special Form" field "Audit Trail" and press Enter to select this record .
Click in "Special Form" field and press Enter. A new record will be created.
Go to "Org Access" tab and go again to "Form Access" tab.
You will see that a new record is there and one of those records will have Cancel and Save non-clickable icons in that grid view.
TagsNo tags attached.
Attached Filespng file icon UI error.png [^] (116,747 bytes) 2014-10-23 10:49

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0026702 closedguillermogil On create a record while a filter is applied the focus get lost 
related to defect 0027975 acknowledgedplatform Under certain conditions the grid buttons disappear after saving a record in grid view. 
related to defect 0028646 closedalostale Grid view creation of prices in the Price tab of the product window is not correct 

-  Notes
(0071148)
AugustoMauch (developer)
2014-10-24 08:47

Also because of the changeset that caused this regression [1], the following problem is reproducible:
- Open Sales Order
- Clear the filters
- Add any filter
- Add a record in grid view, and save
- Add another record in grid view. The button on the left part of the row you created in the previous step disappear

[1] https://code.openbravo.com/erp/devel/pi/rev/dfda65fa925f89a21eee64f35d7aadb252c90dab [^]
(0071149)
AugustoMauch (developer)
2014-10-24 09:10

Correction: The bug reported in this note [1] was not caused by the changeset [2] that caused 27957. It will be reported in a separate issue and fixed there.

[1] https://issues.openbravo.com/view.php?id=27957#c71148 [^]
[2] https://code.openbravo.com/erp/devel/pi/rev/dfda65fa925f89a21eee64f35d7aadb252c90dab [^]
(0071151)
hgbot (developer)
2014-10-24 09:42

Repository: erp/devel/pi
Changeset: 5bce36f9c0471513873659882de2e46f539eaf47
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Oct 24 09:38:26 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5bce36f9c0471513873659882de2e46f539eaf47 [^]

Fixes issue 27957: Grid button don't get stuck after autosaving new record

In the fix [1] of this issue [2], a change was made to force reselecting a new record even if it was already selected, because otherwise when a record was created in grid mode while a filter was applied, when the record was saved the selection was lost.

The problem is that that change should only be applied when the editCompletionEvent is 'programmatic'. In the other cases (i.e. 'tab', 'enter', etc), the focus goes to another record, so it did not apply to [2]. In fact when the editCompletion event is not 'programmatic' not only reselecting the record was not needed, but also it caused the grid buttons to get stuck.

[1] https://code.openbravo.com/erp/devel/pi/rev/dfda65fa925f89a21eee64f35d7aadb252c90dab [^]
[2] https://issues.openbravo.com/view.php?id=26702 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0071152)
AugustoMauch (developer)
2014-10-24 09:47

Test plan:
- Test that https://issues.openbravo.com/view.php?id=26702 [^] is still not reproducible. There are several ways to save the record while keeping it selected:
  * By pressing the Save toolbar button
  * By pressing the Save grid button
  * By pressing Ctrl+S
- Test that https://issues.openbravo.com/view.php?id=27957 [^] is no longer reproducible. There are several ways to save a record and create new one at the same time:
  * With the focus on a field, press Enter
  * Press Tab when the focus is in the last editable field
(0071165)
alostale (developer)
2014-10-24 11:48

code reviewed

tested both current issue and the one causing it
(0072981)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073595)
hgbot (developer)
2015-01-19 12:40

Repository: erp/devel/pi
Changeset: b4f4fca525d71f872eca351abd3a3c170facbd73
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jan 19 12:35:25 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b4f4fca525d71f872eca351abd3a3c170facbd73 [^]

fixed bug 27957: new child grid record fails after parent new grid record

  When a new record was created in child grid view for a child tab just after
  creating its parent in grid view, it failed creating the second record for
  that child tab.

  The problem was caused by an extra request to child tab due to incorrect sync
  between lastSelectedRecord and getSelectedRecord for parent tab, lastSelectedRecord
  kept the temporary id for new records.

  The solution updates the selection once the parent one has been saved.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0073596)
alostale (developer)
2015-01-19 12:41

reclosing, incorrect changeset commit msg
(0074156)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-23 10:47 lorenzofidalgo New Issue
2014-10-23 10:47 lorenzofidalgo Assigned To => dbaz
2014-10-23 10:47 lorenzofidalgo File Added: UI error.png
2014-10-23 10:47 lorenzofidalgo Web browser => Google Chrome
2014-10-23 10:47 lorenzofidalgo Modules => Core
2014-10-23 10:47 lorenzofidalgo Regression level => Production - QA Approved
2014-10-23 10:47 lorenzofidalgo Regression introduced in release => 3.0PR14Q3.1
2014-10-23 10:47 lorenzofidalgo Triggers an Emergency Pack => No
2014-10-23 10:48 lorenzofidalgo File Deleted: UI error.png
2014-10-23 10:49 lorenzofidalgo File Added: UI error.png
2014-10-23 11:32 AugustoMauch Web browser Google Chrome => Google Chrome
2014-10-23 11:32 AugustoMauch Steps to Reproduce Updated View Revisions
2014-10-23 11:32 AugustoMauch Web browser Google Chrome => Google Chrome
2014-10-23 11:32 AugustoMauch Steps to Reproduce Updated View Revisions
2014-10-23 17:16 AugustoMauch Web browser Google Chrome => Google Chrome
2014-10-23 17:16 AugustoMauch Regression date => 2014-05-28
2014-10-23 17:16 AugustoMauch Regression introduced in release 3.0PR14Q3.1 => 3.0PR14Q3
2014-10-23 17:16 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/dfda65fa925f89a21eee64f35d7aadb252c90dab [^]
2014-10-24 07:26 alostale Assigned To dbaz => AugustoMauch
2014-10-24 07:26 alostale Web browser Google Chrome => Google Chrome
2014-10-24 07:26 alostale Priority normal => immediate
2014-10-24 07:28 alostale Relationship added caused by 0026702
2014-10-24 08:47 AugustoMauch Note Added: 0071148
2014-10-24 09:10 AugustoMauch Note Added: 0071149
2014-10-24 09:24 AugustoMauch Issue Monitored: alostale
2014-10-24 09:24 AugustoMauch Review Assigned To => alostale
2014-10-24 09:24 AugustoMauch Web browser Google Chrome => Google Chrome
2014-10-24 09:42 hgbot Checkin
2014-10-24 09:42 hgbot Note Added: 0071151
2014-10-24 09:42 hgbot Status new => resolved
2014-10-24 09:42 hgbot Resolution open => fixed
2014-10-24 09:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5bce36f9c0471513873659882de2e46f539eaf47 [^]
2014-10-24 09:47 AugustoMauch Note Added: 0071152
2014-10-24 10:41 AugustoMauch Relationship added related to 0027975
2014-10-24 11:06 alostale Note Added: 0071164
2014-10-24 11:06 alostale Status resolved => new
2014-10-24 11:06 alostale Resolution fixed => open
2014-10-24 11:12 alostale Note Deleted: 0071164
2014-10-24 11:47 alostale Status new => scheduled
2014-10-24 11:47 alostale fix_in_branch => pi
2014-10-24 11:47 alostale Status scheduled => resolved
2014-10-24 11:47 alostale Fixed in Version => 3.0PR15Q1
2014-10-24 11:47 alostale Resolution open => fixed
2014-10-24 11:48 alostale Note Added: 0071165
2014-10-24 11:48 alostale Status resolved => closed
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072981
2015-01-19 12:17 alostale Relationship added related to 0028646
2015-01-19 12:40 hgbot Checkin
2015-01-19 12:40 hgbot Note Added: 0073595
2015-01-19 12:40 hgbot Status closed => resolved
2015-01-19 12:40 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/5bce36f9c0471513873659882de2e46f539eaf47 [^] => http://code.openbravo.com/erp/devel/pi/rev/b4f4fca525d71f872eca351abd3a3c170facbd73 [^]
2015-01-19 12:41 alostale Note Added: 0073596
2015-01-19 12:41 alostale Status resolved => closed
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074156


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker