Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027918
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminorhave not tried2014-10-20 18:272014-12-30 23:23
ReporterjonalegriaesarteView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision5f9f3dae6e36
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-03-05
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/1ea574e6513c [^]
Triggers an Emergency PackNo
Summary

0027918: After PR14Q2.X and new tree infrastructure, window User Defined Accounting Report Setup window has lost the tree view

DescriptionAfter PR14Q2.X and new tree infrastructure, window User Defined Accounting Report Setup window has lost the tree view
Steps To Reproduce- Access to User Defined Accounting Report Setup
- Tree view is not implemented. In MP31.X it was working fine
Proposed Solution- Add tree structure to AD_AccountingRpt_Element table:
http://wiki.openbravo.com/wiki/How_to_Define_a_Table_as_a_Tree [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0012577 scheduledplatform dbsourcemanager cannot to an ad_column.name update of two columns with intermediate conflicting values like A->B,B->C 
related to defect 0028141 closeddmitry_mezentsev API Change: Deletion of row in AD_TABLE_TREE table 
causes defect 0027930 closedAugustoMauch Changeset has broken the int-inc-pgsql and int-inc-oracle tests 

-  Notes
(0071073)
hgbot (developer)
2014-10-21 11:29

Repository: erp/devel/pi
Changeset: 203b797e4189534f4b1dfca962588e3d6013ab62
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 21 11:28:25 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/203b797e4189534f4b1dfca962588e3d6013ab62 [^]

Fixes issue 27918: User Defined Accounting Report Setup shows tree view

The problem was that the tree configuration previous to the new tree implementation was wrong. The Table table had a field called Type Area which was originally used to specify the Tree type of the table. The FinancialMgmtAccountingRptElement table had this field empty, and instead the FinancialMgmtAccountingReport had this field set to Accounting Report, which is the value that should have been assigned to FinancialMgmtAccountingRptElement.

The configuration of the new implementation was done based on the Tree Type field, so it was wrong for the FinancialMgmtAccountingRptElement table. Now it has been properly done (it has been flagged as Is Tree, a record has been added to the Table Tree Category subtab and a value has been selected in the Table Tree Category field of the Tab tab.

Also, a module script has been modified to fix the data of ad_tree. The ad_tree table has a column called ad_table_id, which points to the table that the tree belongs to. The accounting report tree was mistakenly pointing to FinancialMgmtAccountingReport, and the updated modulescript fixes it so that now it points to FinancialMgmtAccountingRptElement.

---
M src-db/database/sourcedata/AD_TAB.xml
M src-db/database/sourcedata/AD_TABLE.xml
M src-db/database/sourcedata/AD_TABLE_TREE.xml
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateADTrees.class
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateADTreesData.class
M src-util/modulescript/src/org/openbravo/modulescript/UpdateADTrees.java
M src-util/modulescript/src/org/openbravo/modulescript/UpdateADTrees_Data.xsql
---
(0071074)
AugustoMauch (developer)
2014-10-21 11:57

Reopened to update severity
(0071075)
AugustoMauch (developer)
2014-10-21 11:58

Severity updated to minor to follow these guidelines [1]. This issue should be minor because it is best described by this epigraph: "There are errors causing partial, non-critical functionality loss. One which impairs some operations but allows the customer to continue to function"


[1] http://wiki.openbravo.com/wiki/Bug_Reporting_Guidelines#How_to_Choose_the_Right_Severity [^]
(0071077)
AugustoMauch (developer)
2014-10-21 12:02

Reopened because the fix is not passing CI: http://ci.openbravo.com/job/int-inc-pgsql/1116/ [^]
(0071080)
AugustoMauch (developer)
2014-10-21 12:35

CI is failing because of these design defect [1].

When this [2] part of the changeset is applied, 'AR' is set to the tree type of the table with ID '800178' before removing 'AR' from the tree type of the table with ID '800223'. Tree type has a unique constraint that is at that point enabled and because of that this error is thrown when applying that change: 'org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint "ad_table_treetype_un"'

[1] https://issues.openbravo.com/view.php?id=12577 [^]
[2] https://code.openbravo.com/erp/devel/pi/diff/203b797e4189/src-db/database/sourcedata/AD_TABLE.xml [^]
(0071083)
hgbot (developer)
2014-10-21 13:10

Repository: erp/devel/pi
Changeset: 8a23d66e2f6b9734c14076e86094cc527ac1044c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 21 13:09:51 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8a23d66e2f6b9734c14076e86094cc527ac1044c [^]

Fixes issue 27918, fixes issue 27930. Prevents breaking the int-inc tests

The problem was that due to this design defect [1], the oracle and postgres int-inc tests were failing. This is because a value 'AR' was being set to the treetype of a table and then being set to null in other table whose treetype was also 'AR'. Treetype has a unique constraint that was enabled when the application data was updated, so the constraint failed.

To prevent this error, the treetype of the second table is going to be set to null in a modulescript, that is executed before updating the application data.

[1] https://issues.openbravo.com/view.php?id=12577 [^]

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateADTrees.class
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateADTreesData.class
M src-util/modulescript/src/org/openbravo/modulescript/UpdateADTrees.java
M src-util/modulescript/src/org/openbravo/modulescript/UpdateADTrees_Data.xsql
---
(0071092)
vmromanos (developer)
2014-10-21 15:49

Code review + testing OK.

Update from previous releases: the tree structure is properly kept. After the upgrade process, the tree can be modified if necessary.

Install from scratch. I'm able to properly define a new tree.
(0071095)
AugustoMauch (developer)
2014-10-21 16:09

Reopened because it breaks CI: https://ci.openbravo.com/job/int-initial-pgsql/558/ [^]
(0071096)
hgbot (developer)
2014-10-21 16:18

Repository: erp/devel/pi
Changeset: 5f9f3dae6e3661a79ee3933e6f454994d32b43a7
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 21 16:18:05 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5f9f3dae6e3661a79ee3933e6f454994d32b43a7 [^]

Fixes issue 27918: Removes tree structure from table that is not a tree

In the initial changeset for fixing 27918, the tree type of the FinancialMgmtAccountingReport table was set to null because that table is not really a tree. The problem was that the cleaning up of the table was not complete, the Is Tree flag should be set to false, and its Tree Table Category subtab should be empty. This has been done now.

The Initial Client Setup was failing because of the incomplete cleanup. The Tree Table Category of FinancialMgmtAccountingReport had a record called Accounting Report, which is the same name as the tree of the FinancialMgmtAccountingRptElement table.

---
M src-db/database/sourcedata/AD_TABLE.xml
M src-db/database/sourcedata/AD_TABLE_TREE.xml
---
(0071098)
hgbot (developer)
2014-10-21 17:32

Repository: erp/devel/api-checks
Changeset: 6b93fec364183fb0053518861c5ca40ad350c8f1
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 21 17:32:20 2014 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/6b93fec364183fb0053518861c5ca40ad350c8f1 [^]

Related with issue 27918: Fixes API Change for deleting row of AD_TABLE_TREE

There is no risk in removing the entry in the AD_TABLE_TREE for the FinancialMgmtAccountingReport table. It had been mistakenly added in the beginning, and it was not being used.

---
M model/src-db/database/sourcedata/AD_TABLE_TREE.xml
---
(0071557)
AugustoMauch (developer)
2014-11-11 15:56

An API change [1] was reported for this changeset [2].

[1] https://issues.openbravo.com/view.php?id=28141 [^]
[2] https://code.openbravo.com/erp/devel/api-checks/rev/6b93fec364183fb0053518861c5ca40ad350c8f1 [^]
(0072957)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072958)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072962)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-20 18:27 jonalegriaesarte New Issue
2014-10-20 18:27 jonalegriaesarte Assigned To => vmromanos
2014-10-20 18:27 jonalegriaesarte Modules => Core
2014-10-20 18:27 jonalegriaesarte Triggers an Emergency Pack => No
2014-10-21 10:34 AugustoMauch Assigned To vmromanos => AugustoMauch
2014-10-21 11:12 AugustoMauch Issue Monitored: vmromanos
2014-10-21 11:12 AugustoMauch Review Assigned To => vmromanos
2014-10-21 11:29 hgbot Checkin
2014-10-21 11:29 hgbot Note Added: 0071073
2014-10-21 11:29 hgbot Status new => resolved
2014-10-21 11:29 hgbot Resolution open => fixed
2014-10-21 11:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/203b797e4189534f4b1dfca962588e3d6013ab62 [^]
2014-10-21 11:54 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/1ea574e6513c [^]
2014-10-21 11:55 AugustoMauch Regression level => Production - Confirmed Stable
2014-10-21 11:55 AugustoMauch Regression introduced in release => 3.0PR14Q2
2014-10-21 11:56 AugustoMauch Regression date => 2014-03-05
2014-10-21 11:57 AugustoMauch Note Added: 0071074
2014-10-21 11:57 AugustoMauch Status resolved => new
2014-10-21 11:57 AugustoMauch Resolution fixed => open
2014-10-21 11:58 AugustoMauch Note Added: 0071075
2014-10-21 11:58 AugustoMauch Severity major => minor
2014-10-21 11:58 AugustoMauch Status new => scheduled
2014-10-21 11:58 AugustoMauch fix_in_branch => pi
2014-10-21 11:58 AugustoMauch Status scheduled => resolved
2014-10-21 11:58 AugustoMauch Resolution open => fixed
2014-10-21 12:02 AugustoMauch Note Added: 0071077
2014-10-21 12:02 AugustoMauch Status resolved => new
2014-10-21 12:02 AugustoMauch Resolution fixed => open
2014-10-21 12:32 AugustoMauch Relationship added related to 0012577
2014-10-21 12:35 AugustoMauch Note Added: 0071080
2014-10-21 13:06 AugustoMauch Relationship added causes 0027930
2014-10-21 13:10 hgbot Checkin
2014-10-21 13:10 hgbot Note Added: 0071083
2014-10-21 13:10 hgbot Status new => resolved
2014-10-21 13:10 hgbot Resolution open => fixed
2014-10-21 13:10 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/203b797e4189534f4b1dfca962588e3d6013ab62 [^] => http://code.openbravo.com/erp/devel/pi/rev/8a23d66e2f6b9734c14076e86094cc527ac1044c [^]
2014-10-21 15:49 vmromanos Note Added: 0071092
2014-10-21 15:49 vmromanos Status resolved => closed
2014-10-21 16:09 AugustoMauch Note Added: 0071095
2014-10-21 16:09 AugustoMauch Status closed => new
2014-10-21 16:09 AugustoMauch Resolution fixed => open
2014-10-21 16:18 hgbot Checkin
2014-10-21 16:18 hgbot Note Added: 0071096
2014-10-21 16:18 hgbot Status new => resolved
2014-10-21 16:18 hgbot Resolution open => fixed
2014-10-21 16:18 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/8a23d66e2f6b9734c14076e86094cc527ac1044c [^] => http://code.openbravo.com/erp/devel/pi/rev/5f9f3dae6e3661a79ee3933e6f454994d32b43a7 [^]
2014-10-21 17:32 hgbot Checkin
2014-10-21 17:32 hgbot Note Added: 0071098
2014-10-22 13:41 vmromanos Status resolved => closed
2014-11-11 15:44 AugustoMauch Relationship added related to 0028141
2014-11-11 15:56 AugustoMauch Note Added: 0071557
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072957
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072958
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072962


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker