Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027930
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalhave not tried2014-10-21 13:052014-12-30 23:23
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision8a23d66e2f6b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression levelAutomated tests
Regression date2014-10-21
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/203b797e4189534f4b1dfca962588e3d6013ab62 [^]
Triggers an Emergency PackNo
Summary

0027930: Changeset has broken the int-inc-pgsql and int-inc-oracle tests

DescriptionThis changeset [1], in particular this part [2], has broken the integration. This is happening due to this known design defect [3].

The following error is thrown when updating the application dictionary data: ERROR: duplicate key value violates unique constraint "ad_table_treetype_un"

[1] https://code.openbravo.com/erp/devel/pi/rev/203b797e4189534f4b1dfca962588e3d6013ab62 [^]
[2] https://code.openbravo.com/erp/devel/pi/diff/203b797e4189/src-db/database/sourcedata/AD_TABLE.xml [^]
[3] https://issues.openbravo.com/view.php?id=12577 [^]
Steps To ReproduceSee [1] and [2].

[1] http://ci.openbravo.com/job/int-inc-pgsql/1116/ [^]
[2] http://ci.openbravo.com/job/int-inc-oracle/1113/ [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00279183.0PR15Q1 closedAugustoMauch After PR14Q2.X and new tree infrastructure, window User Defined Accounting Report Setup window has lost the tree view 

-  Notes
(0071084)
hgbot (developer)
2014-10-21 13:10

Repository: erp/devel/pi
Changeset: 8a23d66e2f6b9734c14076e86094cc527ac1044c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 21 13:09:51 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8a23d66e2f6b9734c14076e86094cc527ac1044c [^]

Fixes issue 27918, fixes issue 27930. Prevents breaking the int-inc tests

The problem was that due to this design defect [1], the oracle and postgres int-inc tests were failing. This is because a value 'AR' was being set to the treetype of a table and then being set to null in other table whose treetype was also 'AR'. Treetype has a unique constraint that was enabled when the application data was updated, so the constraint failed.

To prevent this error, the treetype of the second table is going to be set to null in a modulescript, that is executed before updating the application data.

[1] https://issues.openbravo.com/view.php?id=12577 [^]

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateADTrees.class
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateADTreesData.class
M src-util/modulescript/src/org/openbravo/modulescript/UpdateADTrees.java
M src-util/modulescript/src/org/openbravo/modulescript/UpdateADTrees_Data.xsql
---
(0071090)
AugustoMauch (developer)
2014-10-21 14:02

The tests are no longer broken
(0072959)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-21 13:05 AugustoMauch New Issue
2014-10-21 13:05 AugustoMauch Assigned To => AugustoMauch
2014-10-21 13:05 AugustoMauch Modules => Core
2014-10-21 13:05 AugustoMauch Regression level => Automated tests
2014-10-21 13:05 AugustoMauch Regression date => 2014-10-21
2014-10-21 13:05 AugustoMauch Regression introduced in release => pi
2014-10-21 13:05 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/203b797e4189534f4b1dfca962588e3d6013ab62 [^]
2014-10-21 13:05 AugustoMauch Triggers an Emergency Pack => No
2014-10-21 13:06 AugustoMauch Relationship added caused by 0027918
2014-10-21 13:10 hgbot Checkin
2014-10-21 13:10 hgbot Note Added: 0071084
2014-10-21 13:10 hgbot Status new => resolved
2014-10-21 13:10 hgbot Resolution open => fixed
2014-10-21 13:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8a23d66e2f6b9734c14076e86094cc527ac1044c [^]
2014-10-21 14:02 AugustoMauch Note Added: 0071090
2014-10-21 14:02 AugustoMauch Status resolved => closed
2014-10-21 14:02 AugustoMauch Fixed in Version => 3.0PR15Q1
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072959


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker