Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028141
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-11-11 15:442014-11-11 16:08
ReporterAugustoMauchView Statuspublic 
Assigned Todmitry_mezentsev 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision6b93fec36418
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028141: API Change: Deletion of row in AD_TABLE_TREE table

DescriptionThe AD_TABLE_TREE contained a row that had been add been added by mistake. That table stores the possible tree representations of the instances of AD_TABLE, and the AD_TABLE_TREE removed belonged to an AD_TABLE that was not a tree.

That AD_TABLE_TREE row was not referenced anywhere in our code. It is possible, though extremely unlikely, that someone had referenced it in an external module. The only place where that row can be referenced from is the AD_TAB table, to enable that tree representation of the table in that tab. Doing this makes no sense as it belonged to a table which was not a tree.

The changeset that broke the API was included in PRQ3.2. It had not been reported till now because it was mistakenly considered a false API positive.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00279183.0PR15Q1 closedAugustoMauch After PR14Q2.X and new tree infrastructure, window User Defined Accounting Report Setup window has lost the tree view 

-  Notes
(0071558)
AugustoMauch (developer)
2014-11-11 16:08

Approved by DME

- Issue History
Date Modified Username Field Change
2014-11-11 15:44 AugustoMauch New Issue
2014-11-11 15:44 AugustoMauch Assigned To => AugustoMauch
2014-11-11 15:44 AugustoMauch Modules => Core
2014-11-11 15:44 AugustoMauch Triggers an Emergency Pack => No
2014-11-11 15:44 AugustoMauch Assigned To AugustoMauch => dmitry_mezentsev
2014-11-11 15:44 AugustoMauch Relationship added related to 0027918
2014-11-11 16:07 AugustoMauch Status new => scheduled
2014-11-11 16:07 AugustoMauch fix_in_branch => pi
2014-11-11 16:08 AugustoMauch Note Added: 0071558
2014-11-11 16:08 AugustoMauch Status scheduled => resolved
2014-11-11 16:08 AugustoMauch Fixed in SCM revision => https://code.openbravo.com/erp/devel/api-checks/rev/6b93fec364183fb0053518861c5ca40ad350c8f1 [^]
2014-11-11 16:08 AugustoMauch Resolution open => fixed
2014-11-11 16:08 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker