Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027860
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2014-10-14 11:062014-10-14 17:26
ReporterlorenzofidalgoView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision62f6dc70bced
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-04-14
Regression introduced in release3.0PR14Q3
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/c41ba68ffe3860bf996b34e3858c9d05ab6fa99b [^]
Triggers an Emergency PackNo
Summary

0027860: "Go to previous/next record" malfunctioning when used with auto-save

DescriptionUsing auto-save when clicking "Go to previous record" or "Go to next record" button triggers that the interface does not work properly.

This happends when you do some change in your form and instead of clicking save, you click "go to previous/next record" allowing auto-save to record the changes. What actually happends is that the "go to previous/next record" buttons get disabled and there are some other malfunctioning.

Steps To ReproduceLogIn as Openbravo/openbravo.
Using default F&B admin user, go to sales order (for example).
Remove filters (clicking funnel).
Enter into the first record. (Form view).
Change "Invoice Terms" field to Immediate. (Some different value than the one you have).
After that, click "Go to next record". You will see that the "Go to next/previous record" are disabled. Moreover, the "Save changes" button is enabled, but, actually the previous changes are already saved.
TagsNo tags attached.
Attached Filespng file icon Auto-Save Regresion.png [^] (187,622 bytes) 2014-10-14 11:06

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0025125 closedguillermogil Creating a new Sales Order in Form view puts the Organization field as disabled 

-  Notes
(0070930)
alostale (developer)
2014-10-14 15:39

Executed test cases:

-Next/previous buttons trigger autosave and the loaded record is not in new mode (next/previous are enabled, * in tab title is not present and save is disabled)
-Same using keyboard shortcuts

Issue 0025125 can't be reproduced after the new fix.
(0070931)
hgbot (developer)
2014-10-14 15:40

Repository: erp/devel/pi
Changeset: 62f6dc70bced48249a5c3fa8620f6fac97104f65
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Oct 14 15:35:37 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/62f6dc70bced48249a5c3fa8620f6fac97104f65 [^]

fixed 27860: "Go to previous/next record" with autosave set new state

  When previous/next record button is used on a non saved record and autosave is
  executed. The loaded record is set with new UI.

  The problem was the way used to determine after save if current record is new or
  not: it checked if ID changed, which is correct in case of triggering autosave
  with new button but not if it is triggered with next/back.

  Using now for.isNewRecord to determine the same.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0070935)
AugustoMauch (developer)
2014-10-14 17:26

Code reviewed and verified in pi@62f6dc70bced

- Issue History
Date Modified Username Field Change
2014-10-14 11:06 lorenzofidalgo New Issue
2014-10-14 11:06 lorenzofidalgo Assigned To => dbaz
2014-10-14 11:06 lorenzofidalgo File Added: Auto-Save Regresion.png
2014-10-14 11:06 lorenzofidalgo Web browser => Google Chrome
2014-10-14 11:06 lorenzofidalgo Modules => Core
2014-10-14 11:06 lorenzofidalgo Regression level => Production - QA Approved
2014-10-14 11:06 lorenzofidalgo Regression introduced in release => 3.0PR14Q3
2014-10-14 11:06 lorenzofidalgo Triggers an Emergency Pack => No
2014-10-14 14:58 alostale Web browser Google Chrome => Google Chrome
2014-10-14 14:58 alostale Assigned To dbaz => alostale
2014-10-14 14:58 alostale Priority high => immediate
2014-10-14 14:58 alostale Relationship added caused by 0025125
2014-10-14 14:59 alostale Web browser Google Chrome => Google Chrome
2014-10-14 14:59 alostale Regression date => 2014-04-14
2014-10-14 14:59 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/c41ba68ffe3860bf996b34e3858c9d05ab6fa99b [^]
2014-10-14 15:22 alostale Review Assigned To => AugustoMauch
2014-10-14 15:22 alostale Web browser Google Chrome => Google Chrome
2014-10-14 15:39 alostale Note Added: 0070930
2014-10-14 15:40 hgbot Checkin
2014-10-14 15:40 hgbot Note Added: 0070931
2014-10-14 15:40 hgbot Status new => resolved
2014-10-14 15:40 hgbot Resolution open => fixed
2014-10-14 15:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/62f6dc70bced48249a5c3fa8620f6fac97104f65 [^]
2014-10-14 17:26 AugustoMauch Note Added: 0070935
2014-10-14 17:26 AugustoMauch Status resolved => closed
2014-10-14 17:26 AugustoMauch Fixed in Version => pi


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker