Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025125
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajorhave not tried2013-11-11 14:062014-05-07 18:11
ReporterplujanView Statuspublic 
Assigned Toguillermogil 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revisionc41ba68ffe38
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025125: Creating a new Sales Order in Form view puts the Organization field as disabled

DescriptionIf I create a Sales Order in Form view it works fine. However, if I click the New button again, Organization field is disabled so I cannot change it from the default.
Steps To Reproduce1. Login as F&B International Admin
2. Go to Sales Order window
3. Click New to create a new record in form
4. Change the Organization to F&B US Inc.
5. Change Business Partner to Healthy Foods
6. Before saving, click New to create a new record in form. Now Organization is not enabled. (This is the reported issued)
7. Click New again. Now Organization is enabled again.
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2013-11-13 16:16:19.png [^] (157,795 bytes) 2013-11-13 11:49

- Relationships Relation Graph ] Dependency Graph ]
causes defect 0027860 closedalostale "Go to previous/next record" malfunctioning when used with auto-save 

-  Notes
(0066367)
hgbot (developer)
2014-04-14 09:29

Repository: erp/devel/pi
Changeset: c41ba68ffe3860bf996b34e3858c9d05ab6fa99b
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Mon Apr 14 09:28:56 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c41ba68ffe3860bf996b34e3858c9d05ab6fa99b [^]

Fixed issue 25125:Creating a new Sales Order sets Organization as disabled

Moved var Id and compared to form value once autoSave is Done, if it is different set isNew as true because the record has changed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0066470)
shankarb (developer)
2014-04-15 21:46

Code reviewed and verified in pi changeset c25c56618b6d
(0066925)
hudsonbot (developer)
2014-05-07 18:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/02ca2648bcdc [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-11-11 14:06 plujan New Issue
2013-11-11 14:06 plujan Assigned To => dbaz
2013-11-11 14:06 plujan Modules => Core
2013-11-11 14:06 plujan Triggers an Emergency Pack => No
2013-11-11 14:06 dbaz Assigned To dbaz => AugustoMauch
2013-11-11 14:13 plujan Regression level => Production - Confirmed Stable
2013-11-13 09:58 shankarb Regression level Production - Confirmed Stable =>
2013-11-13 11:49 priyanka277 File Added: Screenshot from 2013-11-13 16:16:19.png
2014-04-02 18:01 AugustoMauch Steps to Reproduce Updated View Revisions
2014-04-08 16:02 guillermogil Assigned To AugustoMauch => guillermogil
2014-04-14 09:29 hgbot Checkin
2014-04-14 09:29 hgbot Note Added: 0066367
2014-04-14 09:29 hgbot Status new => resolved
2014-04-14 09:29 hgbot Resolution open => fixed
2014-04-14 09:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c41ba68ffe3860bf996b34e3858c9d05ab6fa99b [^]
2014-04-14 09:31 guillermogil Issue Monitored: shankarb
2014-04-14 09:31 guillermogil Review Assigned To => shankarb
2014-04-15 21:46 shankarb Note Added: 0066470
2014-04-15 21:46 shankarb Status resolved => closed
2014-04-15 21:46 shankarb Fixed in Version => PR14Q3
2014-05-07 18:11 hudsonbot Checkin
2014-05-07 18:11 hudsonbot Note Added: 0066925
2014-10-14 14:58 alostale Relationship added causes 0027860


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker