Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027788
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2014-10-07 17:392014-12-30 23:22
ReportervmromanosView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchpiFixed in SCM revision616e60ce9a70
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2014-07-14
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^]
Triggers an Emergency PackNo
Summary

0027788: Filters don't work properly on Manage Stock

DescriptionThe filters in the Manage Stock popup at Stock Reservation window have stopped working. No filtering is done when you filter by any of the columns: Storage Bin, Attribute Set Value, etc.

In 3.0PR14Q3.1 they worked fine, but it has suddenly stopped working. It looks like a regression in the platform side, because the java in charge of this datasource hasn't been modified during this period of time: https://code.openbravo.com/erp/devel/pi/log/tip/src/org/openbravo/common/datasource/StockReservationPickAndEditDataSource.java [^]
Note that the 3rd (last) changeset doesn't impact in this behavior.
Steps To ReproduceLogin as group admin:
1. Go to preference window and set the preference Enable Stock Reservations = Y
2. Go to Stock Reservation window and create a new record:
Org= F&B España - Región Norte
Product= Zumo de Naranja Bio 0,33L
Qty= 10
Warehouse= España Región Norte
3. Click on Manage Stock. A P&E is shown with several records.
4. Try to filter by any Storage Bin. It doesn't filter properly
5. Try with other columns, like Attribute Set Value. It doesn't filter properly
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0026719 closedSandrahuguet Stock reservation pick lines does not keep selected lines 
related to defect 00277353.0PR15Q1 closedAtulOpenbravo Stock Reservation cannot be manually done if there exist pending purchase orders for that product 
caused by design defect 0025211 closedAugustoMauch Filter by selected value in FK uses identifier instead of ID 
related to defect 0027848 closedreinaldoguerra Not possible to select more than one value in fk filter drop down on Manage Stock 
related to defect 0030455 closedmarkmm82 Filtering not working in Manage Reservation pop-up when selecting more than one record in Attribute Set Value and other column 
causes defect 0029216 closedalostale can't prevent filtering FK by identifier from Grid Configuration 

-  Notes
(0070781)
AugustoMauch (developer)
2014-10-07 18:02

The problem is caused by the project that improved the performance of the foreign key filters. Now when picking a value from the filter drop down instead of filtering by the record identifier, the record id is used.

This change is supported by Openbravo default datasources, but manual datasources need to be modified to support it.
(0070799)
hgbot (developer)
2014-10-08 12:12

Repository: erp/devel/pi
Changeset: 553b2d6a7722853be38755bc7b7f09a93f0a6f7b
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Oct 08 12:10:58 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/553b2d6a7722853be38755bc7b7f09a93f0a6f7b [^]

Related to bug 27788: Fk filters work in StockReservationPickAndEditDataSource

The StockReservationPickAndEditDataSource manual datasource did not support filtering the foreign key columns using their ids. This type of criteria is built when the user filters a foreign key by selecting a value from the filter drop down.

Now, for each foreign key column, the manual datasource is able to filter them by their id and by their identifier.

---
M src/org/openbravo/common/datasource/StockReservationPickAndEditDataSource.java
---
(0070800)
AugustoMauch (developer)
2014-10-08 12:14

Done:
- StockReservationPickAndEditDataSource
Pending:
- ReturnFromCustomerPickEditLineDatasource
- ManageVariantsDS
- ReturnToVendorPickAndEditDataSource
(0070832)
inigosanchez (developer)
2014-10-09 10:54

Some dropdowns in ReturnFromCustomerPickEditLineDatasource manual datasource did not work in 3.0PR14Q3.1:

- Attribute set value dropdown: "No items to show." message is displayed without considering that there is data in the grid.
- UOM dropdown: Same behavior than Attribute set value.
- Return reason dropdown: Same behavior than Attribute set value.

The queries that are created are not correct .
(0070834)
inigosanchez (developer)
2014-10-09 11:18

Filters in ReturnToVendorPickAndEditDataSource manual datasource works fine.
(0070844)
hgbot (developer)
2014-10-09 13:55

Repository: erp/devel/pi
Changeset: 17287f94d832847ab9ffceeb42df0c056dac2808
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Oct 09 13:53:32 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/17287f94d832847ab9ffceeb42df0c056dac2808 [^]

Related to bug 27788: Fk filters not work in manual datasource.

The ReturnFromCustomerPickEditLineDatasource manual datasource did not support filtering the foreign key columns using their ids.
This type of criteria is built when the user filters a foreign key by selecting a value from the filter drop down.

Now, for each foreign key column, ReturnFromCustomerPickEditLineDatasource manual datasource is able to filter them by their id and by their identifier.

Other manual datasources like ManageVariantsDS and ReturnToVendorPickAndEditDataSource it have been reviewed and they support filtering the foreign key columns using their ids.

---
M src/org/openbravo/common/datasource/ReturnFromCustomerPickEditLineDatasource.java
---
(0070850)
hgbot (developer)
2014-10-09 18:50

Repository: erp/devel/pi
Changeset: 4f9b797e17d289ec6bbd3475bf90fbcf1ed83be8
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Oct 09 18:47:37 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4f9b797e17d289ec6bbd3475bf90fbcf1ed83be8 [^]

Related with issue 27788: Adds new field to obserds_datasource table

The new field is a flag that controls how the foreign keys are filtered in the tables that uses a manual datasource to fetch its data. If the flag is checked, then if a foreign key field of that table is filtered by selecting a record from the filter drop down, the foreign key will be filtered using its id. That is, the criteria will be like this:

  {fieldName: foreign-key-name,
  operator: 'equals',
  value: record-id}

If this flag is unchecked, then the criteria used will be like this:

  {fieldName: foreign-key-name$_identifier
  operator: 'iContains',
  value: 'identifier'}

---
M modules/org.openbravo.service.datasource/src-db/database/model/tables/OBSERDS_DATASOURCE.xml
M modules/org.openbravo.service.datasource/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.service.datasource/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.service.datasource/src-db/database/sourcedata/AD_FIELD.xml
---
(0070851)
hgbot (developer)
2014-10-09 18:50

Repository: erp/devel/pi
Changeset: 49bb687fd5eace6902ce34b0e5c754ce4af19b65
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Oct 09 18:49:16 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/49bb687fd5eace6902ce34b0e5c754ce4af19b65 [^]

Related with issue 27788: Updates OBSERDS_DATASOURCE source data with new value

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/OBSERDS_DATASOURCE.xml
M modules/org.openbravo.client.querylist/src-db/database/sourcedata/OBSERDS_DATASOURCE.xml
M modules/org.openbravo.service.datasource/src-db/database/sourcedata/OBSERDS_DATASOURCE.xml
M modules/org.openbravo.userinterface.selector/src-db/database/sourcedata/OBSERDS_DATASOURCE.xml
M src-db/database/sourcedata/OBSERDS_DATASOURCE.xml
---
(0070867)
hgbot (developer)
2014-10-10 11:45

Repository: erp/devel/pi
Changeset: 616e60ce9a707b1d34b3e809af0f96faea749c0b
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Oct 10 11:33:59 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/616e60ce9a707b1d34b3e809af0f96faea749c0b [^]

Fixes issue 27788: Manual datasources can dissallow filtering by id

If the Support Filtering foreign keys by their id field of a manual datasource is checked, then in their grids the foreign key columns will always be filtered using their identifier instead of their id.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/ob-pick-and-execute-grid.js.ftl
M modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/ob-view-grid.js.ftl
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0070868)
hgbot (developer)
2014-10-10 11:45

Repository: erp/devel/pi
Changeset: 8d7c6812b4991e11fa03b7a1022d1dbca94fadea
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Oct 10 11:45:06 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8d7c6812b4991e11fa03b7a1022d1dbca94fadea [^]

Related with issue 27788: Updates the printed name of the new field

---
M modules/org.openbravo.service.datasource/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.service.datasource/src-db/database/sourcedata/AD_FIELD.xml
---
(0070896)
alostale (developer)
2014-10-13 10:42

Reopened.

In Stock Reservation > Manage Stock P&E it fails when the filter is for more than a single Storage Bin.
(0070901)
AugustoMauch (developer)
2014-10-13 11:19

Set to Resolved again as the problem described is not part of the regression. Selecting several rows in the filter drop down of the fks of that P&E window has never worked.
(0070902)
alostale (developer)
2014-10-13 12:18

Code reviewed.

Tested:

*Existent manual DS in ERP
 -Return from Customer
 -Return to Vendor
 -Stock Reservation
 -Manage Variants (does not apply as there is no FK filtering)
*New flag to warranty backwards compatibility
(0072915)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072924)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072925)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072926)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072927)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072928)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-07 17:39 vmromanos New Issue
2014-10-07 17:39 vmromanos Assigned To => AugustoMauch
2014-10-07 17:39 vmromanos Modules => Core
2014-10-07 17:39 vmromanos Regression level => Pre packaging ( pi )
2014-10-07 17:39 vmromanos Triggers an Emergency Pack => No
2014-10-07 17:40 vmromanos Relationship added related to 0026719
2014-10-07 17:40 vmromanos Relationship added related to 0027735
2014-10-07 17:47 vmromanos Regression level Pre packaging ( pi ) => Packaging and release
2014-10-07 17:57 AugustoMauch Regression date => 2014-07-14
2014-10-07 17:57 AugustoMauch Regression introduced in release => pi
2014-10-07 17:57 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb2a08d1486d2481f4478722a83186 [^]
2014-10-07 18:02 AugustoMauch Note Added: 0070781
2014-10-08 10:50 alostale Assigned To AugustoMauch => inigosanchez
2014-10-08 10:50 alostale Priority normal => immediate
2014-10-08 12:12 hgbot Checkin
2014-10-08 12:12 hgbot Note Added: 0070799
2014-10-08 12:14 AugustoMauch Note Added: 0070800
2014-10-09 10:54 inigosanchez Note Added: 0070832
2014-10-09 11:18 inigosanchez Note Added: 0070834
2014-10-09 13:55 hgbot Checkin
2014-10-09 13:55 hgbot Note Added: 0070844
2014-10-09 18:50 hgbot Checkin
2014-10-09 18:50 hgbot Note Added: 0070850
2014-10-09 18:50 hgbot Checkin
2014-10-09 18:50 hgbot Note Added: 0070851
2014-10-10 11:43 AugustoMauch Issue Monitored: alostale
2014-10-10 11:44 AugustoMauch Review Assigned To => alostale
2014-10-10 11:45 hgbot Checkin
2014-10-10 11:45 hgbot Note Added: 0070867
2014-10-10 11:45 hgbot Status new => resolved
2014-10-10 11:45 hgbot Resolution open => fixed
2014-10-10 11:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/616e60ce9a707b1d34b3e809af0f96faea749c0b [^]
2014-10-10 11:45 hgbot Checkin
2014-10-10 11:45 hgbot Note Added: 0070868
2014-10-13 10:34 alostale Assigned To inigosanchez => AugustoMauch
2014-10-13 10:34 alostale Status resolved => new
2014-10-13 10:34 alostale Resolution fixed => open
2014-10-13 10:35 alostale Relationship added caused by 0025211
2014-10-13 10:35 alostale Status new => scheduled
2014-10-13 10:35 alostale fix_in_branch => pi
2014-10-13 10:35 alostale Status scheduled => resolved
2014-10-13 10:35 alostale Resolution open => fixed
2014-10-13 10:42 alostale Note Added: 0070896
2014-10-13 10:42 alostale Status resolved => new
2014-10-13 10:42 alostale Resolution fixed => open
2014-10-13 11:18 AugustoMauch Status new => scheduled
2014-10-13 11:19 AugustoMauch Note Added: 0070901
2014-10-13 11:19 AugustoMauch Status scheduled => resolved
2014-10-13 11:19 AugustoMauch Resolution open => fixed
2014-10-13 11:33 AugustoMauch Relationship added related to 0027848
2014-10-13 12:18 alostale Note Added: 0070902
2014-10-13 12:18 alostale Status resolved => closed
2014-10-13 12:18 alostale Fixed in Version => 3.0PR14Q4
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072915
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072924
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072925
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072926
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072927
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072928
2015-03-10 12:23 alostale Relationship added causes 0029216
2016-06-02 12:47 ngarcia Relationship added related to 0030455


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker