Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027735
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2014-10-02 10:382014-12-30 23:22
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionda67328d205a
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-05-28
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/85730acf7b16 [^]
Triggers an Emergency PackNo
Summary

0027735: Stock Reservation cannot be manually done if there exist pending purchase orders for that product

DescriptionStock Reservation cannot be manually done if there exist pending purchase orders for that product
Steps To ReproduceAs group admin role:
   Create a Purchase Order for F&B España Region Norte, Refrescos Naturales business partner and Agua Sin Gas product and book it
   Check there is stock for that product in Región Norte warehouse
   Create a Stock Reservation for F&B España Region Norte and Agua Sin Gas product
   Leave the Storage Bin empty
   Click on Manage Stock button
   No Items are shown
   Create a Goods Receipt from the purchase order and complete it
   Go to the Stock Reservation window and check stock is shown when clicking on Manage Stock button
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027788 closedAugustoMauch Filters don't work properly on Manage Stock 

-  Notes
(0070758)
AtulOpenbravo (developer)
2014-10-07 08:44

- Login as Group admin role.
- Create a Purchase Order for F&B España Region Norte with Refrescos Naturales as business partner and Agua Sin Gas product with Qty 100 and book it.
- Check there is stock for that product in Región Norte warehouse.
- Create a Stock Reservation for F&B España Region Norte and Agua Sin Gas product. Leave the Storage Bin empty. Click on Manage Stock button
- Check that Pick and Edit window shows line with stock and Purchase Order Line created in the second step. [Records are shown in this window]
(0070765)
hgbot (developer)
2014-10-07 12:29

Repository: erp/devel/pi
Changeset: da67328d205addd162e8dd9c9e8b1c0636966269
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Oct 07 11:58:37 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/da67328d205addd162e8dd9c9e8b1c0636966269 [^]

Fixes Issue 27735:Stock Reservation cannot be manually done if there exist
pending purchase orders for that product

query created was for orderline but code seems to be incorrect so removed
wrong part which was trying to cast the result to Storage Detail

---
M src/org/openbravo/common/datasource/StockReservationPickAndEditDataSource.java
---
(0070778)
Sandrahuguet (developer)
2014-10-07 16:55

Code review + testing OK
(0072908)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-02 10:38 ngarcia New Issue
2014-10-02 10:38 ngarcia Assigned To => jonalegriaesarte
2014-10-02 10:38 ngarcia Modules => Core
2014-10-02 10:38 ngarcia Triggers an Emergency Pack => No
2014-10-02 11:48 ngarcia Target Version => 3.0PR15Q1
2014-10-02 12:06 ngarcia Regression level => Production - Confirmed Stable
2014-10-02 12:47 jonalegriaesarte Assigned To jonalegriaesarte => AtulOpenbravo
2014-10-07 08:35 AtulOpenbravo Status new => scheduled
2014-10-07 08:35 AtulOpenbravo fix_in_branch => pi
2014-10-07 08:44 AtulOpenbravo Note Added: 0070758
2014-10-07 10:31 AtulOpenbravo Regression date => 2014-05-28
2014-10-07 10:31 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/85730acf7b16 [^]
2014-10-07 10:31 AtulOpenbravo fix_in_branch pi =>
2014-10-07 12:29 hgbot Checkin
2014-10-07 12:29 hgbot Note Added: 0070765
2014-10-07 12:29 hgbot Status scheduled => resolved
2014-10-07 12:29 hgbot Resolution open => fixed
2014-10-07 12:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/da67328d205addd162e8dd9c9e8b1c0636966269 [^]
2014-10-07 16:54 Sandrahuguet Review Assigned To => Sandrahuguet
2014-10-07 16:56 Sandrahuguet Note Added: 0070778
2014-10-07 16:56 Sandrahuguet Status resolved => closed
2014-10-07 17:40 vmromanos Relationship added related to 0027788
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072908


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker