Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029216
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2015-03-10 12:202015-03-10 22:50
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision5cc98c60fb3c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-10-10
Regression introduced in release3.0PR14Q4
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/616e60ce9a707b1d34b3e809af0f96faea749c0b [^]
Triggers an Emergency PackNo
Summary

0029216: can't prevent filtering FK by identifier from Grid Configuration

DescriptionPreventing filtering FK by identifier from Grid Configuration does not work.

When this prevented, it is not possible to filter FK fields, a js error is thrown and the filter is not applied.
Steps To Reproduce-As System Admin
-Go to Grid Configuration at Window/Tab level
-Create a new record for Sales Order
-Add new record in Field tab
  - Field: Business Partner
  - Allow Filtering FK by its Identifier: No
-As OB admin
-Go to Sales Order
-Try to filter by BP by selecting one in the BP filter drop down
  -> ERROR:
     * Filter is not applied
     * This error can be seen in JS console: Uncaught TypeError: Cannot read property 'alwaysFilterFksByIdentifier' of undefined
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00291733.0PR15Q4 closedegoitz Performance problem when filtering in Return to Vendor pick and execute lines having a big amount of data 
depends on backport 00292173.0PR15Q1.2 closedalostale can't prevent filtering FK by identifier from Grid Configuration 
caused by defect 0027788 closedAugustoMauch Filters don't work properly on Manage Stock 

-  Notes
(0075376)
alostale (developer)
2015-03-10 12:55

Executed test plan:

* TestLink: http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-7753 [^]
* Grid Configuration, Allow Filter FK by identifier. Tested both in standard window and P&E
  - at system level
  - at window level
  - at field level
* Issue 0027788
  * Manage Stock filter by Storage Bin
    - Partial filtering: filters by identifier
    - Selecting from drop down: filters by id
  * Manual DS backwards comaptibility
    - Partial filtering: filters by identifier
    - Selecting from drop down: filters by identifier
(0075390)
hgbot (developer)
2015-03-10 14:04

Repository: erp/devel/pi
Changeset: 5cc98c60fb3c02ccebf85a2ab28aae0812b0b93f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Mar 10 13:01:12 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5cc98c60fb3c02ccebf85a2ab28aae0812b0b93f [^]

fixed bug 29216: can't prevent filtering FK by identifier from Grid Configuration

  It was not possible to prevent filtering FKs by identifier using Grid Configuration
  because the js code added to ensure backwards compatibility for manual datasources
  was trying to find this property in an incorrect place which was undefined, causing
  a js exception which prevented the flow to continue.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0075403)
AugustoMauch (developer)
2015-03-10 15:30

Code reviewed and verified in pi@5cc98c60fb3c
(0075425)
hudsonbot (developer)
2015-03-10 22:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b89b825e6235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-10 12:20 alostale New Issue
2015-03-10 12:20 alostale Assigned To => alostale
2015-03-10 12:20 alostale Modules => Core
2015-03-10 12:20 alostale Regression level => Production - QA Approved
2015-03-10 12:20 alostale Regression date => 2014-10-10
2015-03-10 12:20 alostale Regression introduced in release => 3.0PR14Q4
2015-03-10 12:20 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/616e60ce9a707b1d34b3e809af0f96faea749c0b [^]
2015-03-10 12:20 alostale Triggers an Emergency Pack => No
2015-03-10 12:20 alostale Review Assigned To => AugustoMauch
2015-03-10 12:21 alostale Status new => scheduled
2015-03-10 12:21 alostale Relationship added related to 0029173
2015-03-10 12:23 alostale Relationship added caused by 0027788
2015-03-10 12:55 alostale Note Added: 0075376
2015-03-10 14:04 hgbot Checkin
2015-03-10 14:04 hgbot Note Added: 0075390
2015-03-10 14:04 hgbot Status scheduled => resolved
2015-03-10 14:04 hgbot Resolution open => fixed
2015-03-10 14:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5cc98c60fb3c02ccebf85a2ab28aae0812b0b93f [^]
2015-03-10 15:30 AugustoMauch Note Added: 0075403
2015-03-10 15:30 AugustoMauch Status resolved => closed
2015-03-10 22:50 hudsonbot Checkin
2015-03-10 22:50 hudsonbot Note Added: 0075425


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker