Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025789
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-02-20 19:222014-03-04 12:35
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisionf8a24f45788a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025789: Duplicated records appearing in the grid after refreshing having all the records selected

DescriptionHaving more than 100 registers in a window, if we select all of then and after that we refresh the window, the number of records displayed in the window increases.
Steps To Reproduce1) Go to the [Country and Region] window
2) Select all the records
3) Click on the refresh button
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00257653.0PR14Q2 closedalostale Duplicated records can appear in the grid when it is refreshed 
related to defect 00230063.0MP22 closedAugustoMauch Wrong records shown in grid when the filter is entered before loading the records 
related to design defect 0025811 closedAugustoMauch unnecessary request on grid refresh 

-  Notes
(0064521)
alostale (developer)
2014-02-24 12:51

Executed test cases:
-Follow steps to reproduce and check number of records doesn't change
-Repeat case defined for issue 0023006 to ensure it is still fixed
-Without any filtering scroll down, select Dominican Republic and refresh check that:
  * Selected record is still selected and positioned in the middle of the window
  * Scroll down in the grid still works and it is possible to go till Zimbabwe (last record in the grid)
-Without any filtering scroll down, select Norway and refresh check that:
  * Selected record is still selected and positioned in the middle of the window -> NOT WORKING: reported in issue 0025811
  * Scroll down in the grid still works and it is possible to go till Zimbabwe (last record in the grid)
(0064522)
hgbot (developer)
2014-02-24 12:55

Repository: erp/devel/pi
Changeset: f8a24f45788a0006a0e684e4313159d932fc4b81
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 24 12:55:18 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f8a24f45788a0006a0e684e4313159d932fc4b81 [^]

fixed bug 25789: duplicated records appearing in the grid after refreshing

  Fixed 2 problems:
   -When targetRecordId is sent to the datasource, startRow is recomputed but it was sent
    back with the original value, this caused incorrect rows computation in client side
   -Reasiging totalRows should not decrease it's number because it causes incorrect pagination
    this is related to 2nd request reported in issue 0025811

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0064588)
hudsonbot (developer)
2014-02-25 20:14

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7579d638a80a [^]
Maturity status: Test
(0064791)
AugustoMauch (developer)
2014-03-04 12:35

Code reviewed and verified in pi@5e5fb94fad0b

- Issue History
Date Modified Username Field Change
2014-02-20 19:22 caristu New Issue
2014-02-20 19:22 caristu Assigned To => AugustoMauch
2014-02-20 19:22 caristu Modules => Core
2014-02-20 19:22 caristu Triggers an Emergency Pack => No
2014-02-20 19:23 caristu Issue Monitored: networkb
2014-02-20 19:23 caristu Relationship added related to 0025765
2014-02-24 11:58 alostale Assigned To AugustoMauch => alostale
2014-02-24 11:58 alostale Relationship added related to 0023006
2014-02-24 12:43 alostale Relationship added related to 0025811
2014-02-24 12:51 alostale Note Added: 0064521
2014-02-24 12:51 alostale Review Assigned To => AugustoMauch
2014-02-24 12:55 hgbot Checkin
2014-02-24 12:55 hgbot Note Added: 0064522
2014-02-24 12:56 hgbot Status new => resolved
2014-02-24 12:56 hgbot Resolution open => fixed
2014-02-24 12:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f8a24f45788a0006a0e684e4313159d932fc4b81 [^]
2014-02-25 20:14 hudsonbot Checkin
2014-02-25 20:14 hudsonbot Note Added: 0064588
2014-03-04 12:35 AugustoMauch Note Added: 0064791
2014-03-04 12:35 AugustoMauch Status resolved => closed
2014-03-04 12:35 AugustoMauch Fixed in Version => 3.0MP32


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker