Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025765
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-02-19 11:122014-03-04 12:35
ReportermarvintmView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisionb7a76254ee09
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025765: Duplicated records can appear in the grid when it is refreshed

DescriptionIn some situations, when the grid is refreshed, records are duplicated.

This can be reproduced when the user refreshes the grid after having selected at least one record in the grid. In that case, one or more records are duplicated, and added after the current page in the grid.
Steps To Reproduce- Go to the Country and Region window.
- Order the header tab by the Name column.
- Select one country ("Andorra").
- Click on the "Refresh" button in the grid toolbar.
- Scroll down until the second page is requested to the datasource. Notice that instead of receiving the second page, the first page is received again.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0025789 closedalostale Duplicated records appearing in the grid after refreshing having all the records selected 

-  Notes
(0064377)
AugustoMauch (developer)
2014-02-20 10:00

The startRow parameter is changed here https://code.openbravo.com/erp/devel/pi/file/34fb7ad71646/modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java#l433 [^]
(0064490)
alostale (developer)
2014-02-21 15:05

When the grid is refreshed, viewGrid.targetRecordId is set which is placed in the context.params._targetRecordId. This parameter should not be sent when requesting next page. The code in charge of removing it, is in viewGrid.grid.getFetchRequestParams which is called from viewGrid.fetchRemoteData, the problem is the result is not correctly set back in context.params.
(0064491)
alostale (developer)
2014-02-21 15:08

Test plan:
-Follow steps to reproduce and check it works
-Direct navigation to another records still works:
  * opens the correct record in form view
  * when switching to grid mode the selected record is filtered
  * when the filter is cleaned up all the records appear
(0064492)
hgbot (developer)
2014-02-21 15:10

Repository: erp/devel/pi
Changeset: b7a76254ee09b74fe47c35d159bd5e5cc490e0e5
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Feb 21 15:10:03 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b7a76254ee09b74fe47c35d159bd5e5cc490e0e5 [^]

fixed bug 25765: duplicated records can appear in the grid when it is refreshed

When the grid is refreshed, viewGrid.targetRecordId is set which is placed in the context.params._targetRecordId. This parameter should not be sent when requesting next page. The code in charge of removing it, is in viewGrid.grid.getFetchRequestParams which is called from viewGrid.fetchRemoteData, the problem is the result is not correctly set back in context.params.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0064503)
hudsonbot (developer)
2014-02-23 21:59

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3c3cb97a2d10 [^]
Maturity status: Test
(0064792)
AugustoMauch (developer)
2014-03-04 12:35

Code reviewed and verified in pi@5e5fb94fad0b

- Issue History
Date Modified Username Field Change
2014-02-19 11:12 marvintm New Issue
2014-02-19 11:12 marvintm Assigned To => AugustoMauch
2014-02-19 11:12 marvintm Modules => Core
2014-02-19 11:12 marvintm Triggers an Emergency Pack => No
2014-02-19 11:22 jonalegriaesarte Target Version => 3.0MP32
2014-02-19 11:38 marvintm Severity minor => major
2014-02-19 11:56 marvintm Priority normal => immediate
2014-02-20 10:00 AugustoMauch Steps to Reproduce Updated View Revisions
2014-02-20 10:00 AugustoMauch Note Added: 0064377
2014-02-20 19:23 caristu Relationship added related to 0025789
2014-02-21 15:05 alostale Note Added: 0064490
2014-02-21 15:05 alostale Assigned To AugustoMauch => alostale
2014-02-21 15:08 alostale Note Added: 0064491
2014-02-21 15:08 alostale Review Assigned To => AugustoMauch
2014-02-21 15:10 hgbot Checkin
2014-02-21 15:10 hgbot Note Added: 0064492
2014-02-21 15:10 hgbot Status new => resolved
2014-02-21 15:10 hgbot Resolution open => fixed
2014-02-21 15:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b7a76254ee09b74fe47c35d159bd5e5cc490e0e5 [^]
2014-02-23 21:59 hudsonbot Checkin
2014-02-23 21:59 hudsonbot Note Added: 0064503
2014-03-04 12:35 AugustoMauch Note Added: 0064792
2014-03-04 12:35 AugustoMauch Status resolved => closed
2014-03-04 12:35 AugustoMauch Fixed in Version => 3.0MP32


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker