Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025392
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementminoralways2013-12-23 14:262014-07-02 16:47
ReporterngarciaView Statuspublic 
Assigned Toeduardo_Argal 
PriorityhighResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revisionb1843f200a90
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned TodaniOpenbravo
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025392: Wrong customer balance when working with multicurrency

DescriptionWrong customer balance when working with multicurrency
Steps To ReproduceAs group admin role:
   Check the Customer balance of a Business Partner
   Create a Sales Invoice for that BP in EUR
   Check that the Customer balance has been increased with that amount
   Create a Sales Invoice for that BP in USD
   Check that the Customer balance has been increased with that amount (without converting it)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0022091 closedpramakrishnan Credit used is being updated without currency conversion 
related to defect 0027872 closedvmromanos Error obtained when trying to Reactivate a payment and related business partner does not have currency defined 
related to defect 0028078 closedfsoto82 Proper error should be raised when trying to pay an invoice whose business partner has not currency defined 
related to defect 0028077 closedfsoto82 In case business partner's currency is not defined, an error should be raised asking user to initialize it 
related to defect 0028076 closedAtulOpenbravo "InitializeBPCurrency" modulescript needs to be improved 
causes defect 0029273 closedumartirena Payment Out cannot be reactivated if the business partner does not have a purchase price list defined 
causes defect 0027298pi closeddaniOpenbravo Error when reactivating payment in/out if business partner field is blank. 

-  Notes
(0068369)
dmitry_mezentsev (developer)
2014-06-26 17:18

Eduardo,

This issues is without any action since February.
What is our plan here?
(0068487)
hgbot (developer)
2014-07-01 16:55

Repository: erp/devel/pi
Changeset: b1843f200a9092eea99d431776d029a09868615a
Author: Miguel A. Alsasua <miguel.alsasua <at> openbravo.com>
Date: Tue Jul 01 16:54:52 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b1843f200a9092eea99d431776d029a09868615a [^]

fixed issue 25392: Wrong customer balance when working with multicurrency

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
M src-db/database/model/tables/C_BPARTNER.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
M src-db/database/sourcedata/AD_REFERENCE.xml
M src-db/database/sourcedata/OBUIAPP_PARAMETER.xml
M src-db/database/sourcedata/OBUIAPP_PROCESS.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
A src-util/modulescript/build/classes/org/openbravo/modulescript/InitializeBPCurrency.class
A src-util/modulescript/build/classes/org/openbravo/modulescript/InitializeBPCurrencyData.class
A src-util/modulescript/src/org/openbravo/modulescript/InitializeBPCurrency.java
A src-util/modulescript/src/org/openbravo/modulescript/InitializeBPCurrency_data.xsql
A src/org/openbravo/common/actionhandler/SetNewBPCurrency.java
A src/org/openbravo/event/BusinessPartnerEventHandler.java
---
(0068488)
daniOpenbravo (developer)
2014-07-01 16:57

Verified.
(0068514)
hudsonbot (developer)
2014-07-02 16:47

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e8fdcd7d974b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-12-23 14:26 ngarcia New Issue
2013-12-23 14:26 ngarcia Assigned To => jonalegriaesarte
2013-12-23 14:26 ngarcia Modules => Core
2013-12-23 14:26 ngarcia Triggers an Emergency Pack => No
2013-12-23 14:30 ngarcia Issue Monitored: networkb
2014-01-09 12:04 jonalegriaesarte Target Version 3.0MP32 => 3.0MP33
2014-02-03 10:23 jonalegriaesarte Assigned To jonalegriaesarte => pramakrishnan
2014-02-19 12:43 pramakrishnan Status new => scheduled
2014-02-19 12:43 pramakrishnan fix_in_branch => pi
2014-03-12 10:30 jonalegriaesarte fix_in_branch pi =>
2014-03-17 14:19 jonalegriaesarte Target Version PR14Q3 => PR14Q2
2014-03-31 16:17 jonalegriaesarte Target Version PR14Q2 => PR14Q3
2014-06-26 17:17 dmitry_mezentsev Assigned To pramakrishnan => eduardo_Argal
2014-06-26 17:18 dmitry_mezentsev Note Added: 0068369
2014-06-30 13:46 jonalegriaesarte Target Version PR14Q3 => PR14Q4
2014-07-01 16:55 hgbot Checkin
2014-07-01 16:55 hgbot Note Added: 0068487
2014-07-01 16:55 hgbot Status scheduled => resolved
2014-07-01 16:55 hgbot Resolution open => fixed
2014-07-01 16:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b1843f200a9092eea99d431776d029a09868615a [^]
2014-07-01 16:57 daniOpenbravo Review Assigned To => daniOpenbravo
2014-07-01 16:57 daniOpenbravo Note Added: 0068488
2014-07-01 16:57 daniOpenbravo Status resolved => closed
2014-07-01 16:57 daniOpenbravo Fixed in Version => PR14Q3
2014-07-02 16:47 hudsonbot Checkin
2014-07-02 16:47 hudsonbot Note Added: 0068514
2014-07-08 13:38 ngarcia Relationship added related to 0022091
2014-10-15 13:24 vmromanos Relationship added related to 0027872
2014-11-04 12:45 maite Relationship added related to 0028078
2014-11-04 12:45 maite Relationship added related to 0028077
2014-11-04 12:45 maite Relationship added related to 0028076
2015-03-13 14:15 ngarcia Relationship added causes 0029273
2015-04-10 10:04 dmitry_mezentsev Relationship added causes 0027298


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker