Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027872
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2014-10-15 11:252014-12-30 23:22
ReportermaiteView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision36d35b92e566
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAtulOpenbravo
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2014-08-11
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/681262a36913d7d9e63662894a1f0fe3b131e7f3 [^]
Triggers an Emergency PackNo
Summary

0027872: Error obtained when trying to Reactivate a payment and related business partner does not have currency defined

DescriptionError obtained when trying to Reactivate a payment and related business partner does not have currency defined
Steps To Reproduce1. Create new Business Partner. Set it as "Customer" and define Payment MEthod and Financial Account (NO define Pricelist). Define Location for that business partner
2. Register new Payment In using business partner. Add gl item line and process
3. Try to run "Reactivate" or "Reactivate and delete lines" process and "Error" (with no information) will be raised

Real problem is that this business partner does not have currency defined, so null pointer exception error is thrown in line 774 of FIN_PaymentProcess.java, when following code is executed: toCurrency = businessPartner.getCurrency().getId();
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00253923.0PR14Q4 closededuardo_Argal Wrong customer balance when working with multicurrency 
caused by defect 0027298pi closeddaniOpenbravo Error when reactivating payment in/out if business partner field is blank. 

-  Notes
(0070957)
vmromanos (developer)
2014-10-15 13:31
edited on: 2014-10-15 13:32

Test plan:
Login as role admin
1. Create new Business Partner. Set it as "Customer" and define Payment Method and Financial Account (NO define Pricelist). Define Location for that business partner
2. Register new Payment In using business partner. Add gl item line and process
3. Try to run "Reactivate" or "Reactivate and delete lines" process. The payment will be successfully reactivated

(0070959)
hgbot (developer)
2014-10-15 13:41

Repository: erp/devel/pi
Changeset: 36d35b92e566c690bd1e8cea06b304eed40d8ad0
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Oct 15 13:40:56 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/36d35b92e566c690bd1e8cea06b304eed40d8ad0 [^]

Fixed bug 27872: NPE when reactivating payment for BPartner without currency

When reactivating the payment, the FIN_PaymentProcess was getting the business partner currency's ID where, in some strange circunstances, it may not be defined yet.
Moreover, getting the BP currency ID at this point is not needed at all, so these lines have been removed.

Finally, in another part of the code, we have done a trivial refactor to use Currency objects instead of Strings to have a better control over NPE.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
---
(0070967)
AtulOpenbravo (developer)
2014-10-15 15:24

Verified
(0072936)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-15 11:25 maite New Issue
2014-10-15 11:25 maite Assigned To => dmiguelez
2014-10-15 11:25 maite Modules => Core
2014-10-15 11:25 maite Regression level => Production - QA Approved
2014-10-15 11:25 maite Triggers an Emergency Pack => No
2014-10-15 11:25 maite Issue Monitored: networkb
2014-10-15 11:41 vmromanos Status new => scheduled
2014-10-15 11:41 vmromanos Assigned To dmiguelez => vmromanos
2014-10-15 11:41 vmromanos fix_in_branch => pi
2014-10-15 13:24 vmromanos Relationship added related to 0025392
2014-10-15 13:24 vmromanos Relationship added caused by 0027298
2014-10-15 13:27 vmromanos Regression level Production - QA Approved => Packaging and release
2014-10-15 13:27 vmromanos Regression date => 2014-08-11
2014-10-15 13:27 vmromanos Regression introduced in release => main
2014-10-15 13:27 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/681262a36913d7d9e63662894a1f0fe3b131e7f3 [^]
2014-10-15 13:27 vmromanos fix_in_branch pi =>
2014-10-15 13:31 vmromanos Note Added: 0070957
2014-10-15 13:32 vmromanos Note Edited: 0070957 View Revisions
2014-10-15 13:41 hgbot Checkin
2014-10-15 13:41 hgbot Note Added: 0070959
2014-10-15 13:41 hgbot Status scheduled => resolved
2014-10-15 13:41 hgbot Resolution open => fixed
2014-10-15 13:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/36d35b92e566c690bd1e8cea06b304eed40d8ad0 [^]
2014-10-15 15:24 AtulOpenbravo Review Assigned To => AtulOpenbravo
2014-10-15 15:24 AtulOpenbravo Note Added: 0070967
2014-10-15 15:24 AtulOpenbravo Status resolved => closed
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072936


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker