Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023344
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2013-03-19 17:452013-03-21 17:52
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP22
StatusclosedFix in branchpiFixed in SCM revision47d740ad4b2c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023344: API Change - Remove Smart Sprites functionality

DescriptionThe Smart Sprites functionality improves the performance when lots of images have to be loaded in a window by aggregating them into a sprite, so that instead of using one connection for each image only one connection per sprite is needeed.

This issue [1] raised an inconsistency with the Google Collect library. There are two different versions of it in Openbravo, one in lib/build and another one in modules/org.openbravo.base.weld/lib/runtime/.

The one located is lib/build is very old and is only used by the Smart Sprites functionality. The one located in modules/org.openbravo.base.weld/lib/runtime/ is used by Weld and by some new coworking functionality. Smart Sprites is not compatible with the new version of the library because it depends on some deprecated code, and Weld and the coworking development do not work with the old version.

The only viable choice that we can think to fix this inconsistency is to delete the old library and to get rid of the Smart Sprites functionality.

These are some reasons why we should removing this feature is not risky:
- It has almost no value in Openbravo 3.0. If activated, this feature would only be used in the Login window and in the 2.50 windows. Even in those cases the performance is virtually the same.
- It is disabled by default which means that we were unclear about its value from the beginning, and that all users who have not change this property will not even notice this API change.

To remove this functionality the public method applySpriteTags of the RTLSkin class would have to be removed. This will be an API change, but only because the signature of the method is wrong in the first place, because it should have been a private method, because it only makes sense using it inside that class.

[1] https://issues.openbravo.com/view.php?id=23082 [^]
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00230823.0MP22 closedAugustoMauch ANT compiling and module's libraries 

-  Notes
(0057315)
iciordia (manager)
2013-03-19 18:15

Approved.

Ismael
(0057375)
AugustoMauch (developer)
2013-03-21 17:52

try-api automated test has passed: http://builds.openbravo.com/view/try/job/try-api/1344/ [^]

- Issue History
Date Modified Username Field Change
2013-03-19 17:45 AugustoMauch New Issue
2013-03-19 17:45 AugustoMauch Assigned To => iciordia
2013-03-19 17:45 AugustoMauch Modules => Core
2013-03-19 17:45 AugustoMauch Triggers an Emergency Pack => No
2013-03-19 17:46 AugustoMauch Relationship added related to 0023082
2013-03-19 17:51 AugustoMauch Description Updated View Revisions
2013-03-19 18:15 iciordia Note Added: 0057315
2013-03-19 18:15 iciordia Assigned To iciordia => AugustoMauch
2013-03-21 17:50 AugustoMauch Status new => scheduled
2013-03-21 17:50 AugustoMauch fix_in_branch => pi
2013-03-21 17:50 AugustoMauch Status scheduled => resolved
2013-03-21 17:50 AugustoMauch Fixed in Version => 3.0MP22
2013-03-21 17:50 AugustoMauch Fixed in SCM revision => https://code.openbravo.com/erp/devel/pi/rev/47d740ad4b2c3d628f71608b61abb3277a5db740 [^]
2013-03-21 17:50 AugustoMauch Resolution open => fixed
2013-03-21 17:52 AugustoMauch Review Assigned To => AugustoMauch
2013-03-21 17:52 AugustoMauch Note Added: 0057375
2013-03-21 17:52 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker