Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023082
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-02-14 18:272013-03-21 23:36
ReportervmromanosView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0MP22
StatusclosedFix in branchFixed in SCM revision11600ac7d1e4
ProjectionnoneETAnoneTarget Version3.0MP22
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_12
OS VersionDebian 5.0Database version8.3.8Ant version1.7.0
Product VersionpiSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023082: ANT compiling and module's libraries

DescriptionMy module uses some classes provided by an external library. This library is included into the Weld module (installed within the Openbravo 3 distribution).
The library is inside:
./modules/org.openbravo.base.weld/lib/runtime/google-collect-1.0.jar

When compiling my module using Eclipse, it's working fine. However, if I try to compile it using ant into a fresh environment (no compiled before using Eclipse), I get a compilation error.

As a workaround, I have copied the google-collect-1.0.jar to the core's lib/build folder. This is the only way I have managed to compile it using ant.

It looks like a problem getting the Classpath from ant.
Steps To ReproduceYou can try to reproduce it following the steps in the description, or directly installing the org.openbravo.authorize.net module (available at pmods)
TagsCoworking
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0023344 closedAugustoMauch API Change - Remove Smart Sprites functionality 

-  Notes
(0056656)
shuehner (administrator)
2013-02-21 00:30

Hi Victor,
the problem runs a bit deeper than it looks:

lib/build/google-collections.jar exists also together with the lib/runtime copy in org.openbravo.base.weld.

At compile time both are included and the system uses the first one found when it searches for a specific class file.

It looks to me that the lib/build copy is a bit older, so that it does contain the HashMultiMap.class file but in a version which does not have the create() method you are calling, so compilation fails.

As a workaround it is sufficient to do an rm lib/build/google-collections.jar without moving the other jar file and it will compile just fine.

Note: problem only exists at compile-time as the lib/build copy is not copied over to tomcat so at runtime no version conflict exists.

Several ways of fixing this:
a.) just remove lib/build/google-collections.jar + also move the base.weld/lib/runtime/jar over to lib/runtime of core
b.) think of removing the ond lib/build user (is think the css sprites code) alltogether as its useabilty/effectiveness is questionable. + then do a.) also.

Note: if we want to do a.) we need to check if the build-time user will work fine with the new google-collections library version.
(0057368)
hgbot (developer)
2013-03-21 16:31

Repository: erp/devel/pi
Changeset: 0c44af13571d32b065633a34848733387c9619e5
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 21 16:30:17 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0c44af13571d32b065633a34848733387c9619e5 [^]

Fixes issue 23082: Removes smart sprites functionality

The root cause of the fix is that there two versions of the google collections library. The old one, located in lib/build/google-collections.jar was only used for the smart sprites functionality, that only applies to 2.50 windows and to the login window. This functionality does not work with the neweste version of the google collections library (modules/org.openbravo.base.weld/lib/runtime/google-collect-1.0.jar).

It has been decided that this feature is going to be removed. It has almost no significance in Openbravo 3.0, in fact it is disabled by default. Changes done:
- Removed now unused libraries:
   * lib/build/commons-math-1.2.jar
   * lib/build/google-collections.jar
   * lib/build/smartsprites-0.2.1-alpha.jar

- Removed functionality from src/build.xml

- Removed configuration option from Openbravo.properties.template

- Updated legal folder

---
M config/Openbravo.properties.template
M legal/Licensing.txt
M src/build.xml
---
(0057369)
AugustoMauch (developer)
2013-03-21 16:32

Reopened because part of the fix is missing. A clean up of the CSS must be done to get rid of the parts related to the sprites
(0057373)
hgbot (developer)
2013-03-21 17:18

Repository: erp/devel/pi
Changeset: 47d740ad4b2c3d628f71608b61abb3277a5db740
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 21 17:17:27 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/47d740ad4b2c3d628f71608b61abb3277a5db740 [^]

Related to issue 23082: Removes references to sprites from RTLSkin

---
M src-trl/src/org/openbravo/translate/RTLSkin.java
---
(0057374)
hgbot (developer)
2013-03-21 17:46

Repository: erp/devel/pi
Changeset: 11600ac7d1e4bac8d7963b2830b32ad12d05975a
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 21 17:45:39 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/11600ac7d1e4bac8d7963b2830b32ad12d05975a [^]

Fixes issue 23082: Removes SmartSprites comments from 2.50 CSS

---
M modules/org.openbravo.userinterface.skin.250to300Comp/web/org.openbravo.userinterface.skin.250to300Comp/skins/250to300Comp/Openbravo_ERP_250.css
M web/skins/Default/Openbravo_ERP_250.css
---
(0057376)
AugustoMauch (developer)
2013-03-21 17:55

Test plan:
- Test that the original issue is no longer reproducible
- Test that the layout of Openbravo RTL has not been modified.
(0057378)
dbaz (developer)
2013-03-21 23:36

Reviewed @ changeset: 19954 - 11600ac7d1e4

- Issue History
Date Modified Username Field Change
2013-02-14 18:27 vmromanos New Issue
2013-02-14 18:27 vmromanos Assigned To => AugustoMauch
2013-02-14 18:27 vmromanos Modules => Core
2013-02-14 18:27 vmromanos Triggers an Emergency Pack => No
2013-02-14 18:27 vmromanos Tag Attached: Coworking
2013-02-21 00:30 shuehner Note Added: 0056656
2013-02-21 00:30 shuehner Issue Monitored: shuehner
2013-02-28 16:31 AugustoMauch Target Version 3.0MP21 => 3.0MP22
2013-03-19 17:46 AugustoMauch Relationship added related to 0023344
2013-03-21 16:30 AugustoMauch Issue Monitored: shankarb
2013-03-21 16:30 AugustoMauch Issue End Monitor: shankarb
2013-03-21 16:30 AugustoMauch Issue Monitored: dbaz
2013-03-21 16:30 AugustoMauch Review Assigned To => dbaz
2013-03-21 16:31 hgbot Checkin
2013-03-21 16:31 hgbot Note Added: 0057368
2013-03-21 16:31 hgbot Status new => resolved
2013-03-21 16:31 hgbot Resolution open => fixed
2013-03-21 16:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0c44af13571d32b065633a34848733387c9619e5 [^]
2013-03-21 16:32 AugustoMauch Note Added: 0057369
2013-03-21 16:32 AugustoMauch Status resolved => new
2013-03-21 16:32 AugustoMauch Resolution fixed => open
2013-03-21 17:18 hgbot Checkin
2013-03-21 17:18 hgbot Note Added: 0057373
2013-03-21 17:46 hgbot Checkin
2013-03-21 17:46 hgbot Note Added: 0057374
2013-03-21 17:46 hgbot Status new => resolved
2013-03-21 17:46 hgbot Resolution open => fixed
2013-03-21 17:46 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/0c44af13571d32b065633a34848733387c9619e5 [^] => http://code.openbravo.com/erp/devel/pi/rev/11600ac7d1e4bac8d7963b2830b32ad12d05975a [^]
2013-03-21 17:55 AugustoMauch Note Added: 0057376
2013-03-21 23:36 dbaz Note Added: 0057378
2013-03-21 23:36 dbaz Status resolved => closed
2013-03-21 23:36 dbaz Fixed in Version => 3.0MP22


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker