Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0010979
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2009-10-15 11:562012-10-10 16:35
ReportervmromanosView Statuspublic 
Assigned Toshankarb 
PriorityurgentResolutionfixedFixed in Version3.0MP16
StatusclosedFix in branchFixed in SCM revision0bdd29a50fcc
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_12
OS VersionDebian 5.0Database version8.3.7Ant version1.7.0
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0010979: Import translation should show a red message when a trl file is not well formed

DescriptionDue to the bug 0009781, I have changed some Spanish translations into the AD_ELEMENT_TRL_es_ES.xml file (see rev. 340 at https://dev.openbravo.com/websvn/localization/translations/es_ES/trunk/ [^]). Then I have tried to import the new XML file using the Import/Export language window and also through the creation of a new version of the translation module, but with the same result: The modifications are not imported into the database.

The cause is the AD_ELEMENT_TRL_es_ES.xml file is not a well formed XML file, so the import process cannot import this file. In this case, a red error message should appear informing the user about the error while importing the file.
Steps To Reproduce1- Download the rev.340 of the Spanish translation module through the SVN repository https://dev.openbravo.com/websvn/localization/translations/es_ES/trunk/ [^]
2- Import the Spanish language following the normal procedure. Reading the log you will discover the import process has failed, but no message has been shown in the application
Proposed Solution1. Display a red error message if a file has not been imported
2. Be careful because this process is also used when importing a translation module
TagsOB3-Reviewed
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0021060)
shuehner (administrator)
2009-10-15 15:04

Note the import failed as one xml file which was to be imported was brkoen (not valid xml). This was shown in the error log but not shown to the user.

Two open issues:
- Improve logging of the exception to mention the file being imported when it happened
- Show error to the user in the UI (but be careful to not break installation of translation pack via an obx file)
(0021061)
hgbot (developer)
2009-10-15 15:07

Repository: erp/devel/pi
Changeset: 1b63de618c4b127c472d74dd9a7d269fda043845
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Thu Oct 15 15:06:58 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1b63de618c4b127c472d74dd9a7d269fda043845 [^]

Issue 10979: Improve exception logging when importing a translation
Mention filename in the error when an exception happens on parsing an xml file

---
M src/org/openbravo/erpCommon/ad_forms/Translation.java
---
(0052640)
shankarb (developer)
2012-09-26 16:55

Test plan:
1. In the Import/Export Translation, export a language. eg., Spanish
2. Go the attachments folder where the exported translation xml files are saved.
3. Edit and Save a xml file with some added text in header.
4. In the Import/Export Translation, try to import the same language that you exported.
5. An error appears with the file name.
6. Notice that other proper files have been imported.
(0052853)
hgbot (developer)
2012-09-28 10:24

Repository: erp/devel/pi
Changeset: 35d251a9e6597da463e0665003fc2e2f43f2d4fe
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Sep 27 17:13:54 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/35d251a9e6597da463e0665003fc2e2f43f2d4fe [^]

Fixes Issue 0010979 : Display Error for unparsed XML Files.

In Import translation process, added an error message with the files that has not been parsed.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/erpCommon/ad_forms/TranslationManager.java
---
(0052855)
hgbot (developer)
2012-09-28 10:53

Repository: erp/devel/pi
Changeset: fe3bcfb01f4859fb6a7e035e5d9d62f054764ce5
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 28 10:52:06 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fe3bcfb01f4859fb6a7e035e5d9d62f054764ce5 [^]

Related to issue 10979: Backs out changes until final fix is ready

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/erpCommon/ad_forms/TranslationManager.java
---
(0052856)
AugustoMauch (developer)
2012-09-28 10:53

Reopened because the changeset http://code.openbravo.com/erp/devel/pi/rev/35d251a9e6597da463e0665003fc2e2f43f2d4fe [^] did not fix it.
(0052927)
hgbot (developer)
2012-09-28 15:11

Repository: erp/devel/pi
Changeset: 0bdd29a50fccec52e35b64fb484b080a104ca40e
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Fri Sep 28 12:59:32 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0bdd29a50fccec52e35b64fb484b080a104ca40e [^]

Fixes Issue 0010979 : Display Error for unparsed XML Files.

In Import translation process, throws an exception when there are unparsable files.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/erpCommon/ad_forms/TranslationManager.java
---
(0052928)
AugustoMauch (developer)
2012-09-28 15:13

Code reviewed and verified in pi@0bdd29a50fcc
(0053035)
hudsonbot (developer)
2012-10-04 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c067ea513614 [^]

Maturity status: Test
(0053037)
hudsonbot (developer)
2012-10-04 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c067ea513614 [^]

Maturity status: Test
(0053045)
hudsonbot (developer)
2012-10-04 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c067ea513614 [^]

Maturity status: Test
(0053208)
hudsonbot (developer)
2012-10-10 16:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b088fe9dfe19 [^]

Maturity status: Test
(0053210)
hudsonbot (developer)
2012-10-10 16:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b088fe9dfe19 [^]

Maturity status: Test
(0053218)
hudsonbot (developer)
2012-10-10 16:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b088fe9dfe19 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2009-10-15 11:56 vmromanos New Issue
2009-10-15 11:56 vmromanos Assigned To => rafaroda
2009-10-15 11:57 vmromanos Relationship added blocks 0009781
2009-10-15 15:04 shuehner Note Added: 0021060
2009-10-15 15:07 hgbot Checkin
2009-10-15 15:07 hgbot Note Added: 0021061
2009-10-15 15:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1b63de618c4b127c472d74dd9a7d269fda043845 [^]
2009-10-15 15:09 vmromanos Severity major => minor
2009-10-15 15:09 vmromanos Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/1b63de618c4b127c472d74dd9a7d269fda043845 [^] =>
2009-10-15 15:09 vmromanos Summary Import AD_ELEMENT_TRL does not work properly => Import translation should show a red message when a trl file is not well formed
2009-10-15 15:09 vmromanos Description Updated
2009-10-15 15:09 vmromanos Proposed Solution updated
2009-10-15 15:09 vmromanos Steps to Reproduce Updated
2009-10-15 15:09 vmromanos Relationship deleted blocks 0009781
2009-10-16 13:52 psarobe Priority normal => urgent
2009-10-16 13:52 psarobe Status new => scheduled
2009-10-16 13:52 psarobe Target Version => 2.50MP9
2010-02-11 18:26 rafaroda Assigned To rafaroda => alostale
2010-02-15 15:13 alostale Assigned To alostale => shuehner
2011-11-22 18:32 shuehner Tag Attached: OB3-Reviewed
2012-02-20 11:09 shuehner Assigned To shuehner => alostale
2012-02-20 13:04 alostale Target Version 2.50MP9 =>
2012-09-26 12:39 AugustoMauch Assigned To alostale => shankarb
2012-09-26 16:55 shankarb Note Added: 0052640
2012-09-28 10:24 hgbot Checkin
2012-09-28 10:24 hgbot Note Added: 0052853
2012-09-28 10:24 hgbot Status scheduled => resolved
2012-09-28 10:24 hgbot Resolution open => fixed
2012-09-28 10:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/35d251a9e6597da463e0665003fc2e2f43f2d4fe [^]
2012-09-28 10:53 hgbot Checkin
2012-09-28 10:53 hgbot Note Added: 0052855
2012-09-28 10:53 AugustoMauch Note Added: 0052856
2012-09-28 10:53 AugustoMauch Status resolved => new
2012-09-28 10:53 AugustoMauch Resolution fixed => open
2012-09-28 15:11 hgbot Checkin
2012-09-28 15:11 hgbot Note Added: 0052927
2012-09-28 15:11 hgbot Status new => resolved
2012-09-28 15:11 hgbot Resolution open => fixed
2012-09-28 15:11 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/35d251a9e6597da463e0665003fc2e2f43f2d4fe [^] => http://code.openbravo.com/erp/devel/pi/rev/0bdd29a50fccec52e35b64fb484b080a104ca40e [^]
2012-09-28 15:13 AugustoMauch Closed by => AugustoMauch
2012-09-28 15:13 AugustoMauch Note Added: 0052928
2012-09-28 15:13 AugustoMauch Status resolved => closed
2012-09-28 15:13 AugustoMauch Fixed in Version => 3.0MP16
2012-10-04 18:18 hudsonbot Checkin
2012-10-04 18:18 hudsonbot Note Added: 0053035
2012-10-04 18:18 hudsonbot Checkin
2012-10-04 18:18 hudsonbot Note Added: 0053037
2012-10-04 18:18 hudsonbot Checkin
2012-10-04 18:18 hudsonbot Note Added: 0053045
2012-10-10 16:35 hudsonbot Checkin
2012-10-10 16:35 hudsonbot Note Added: 0053208
2012-10-10 16:35 hudsonbot Checkin
2012-10-10 16:35 hudsonbot Note Added: 0053210
2012-10-10 16:35 hudsonbot Checkin
2012-10-10 16:35 hudsonbot Note Added: 0053218


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker