Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0049636
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] Restaurantsmajorhave not tried2022-06-23 11:242022-07-05 08:34
ReportermmohammadView Statuspublic 
Assigned Toablasco 
PrioritynormalResolutionfixedFixed in Version
StatusscheduledFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0049636: FLUN-3105 - Wrong behavior when blind return with a product with pager and modifiers

DescriptionWhen you make a blind return for a product with biper and modifiers
with the "convert to return" option, we are asked to fill the modifiers and biper option. What is not necessary because of return.

Obtained result : the modifiers and beeper number are asked

Expected result : the product is directly added to the basket as a standard product.



Steps To ReproduceSteps :


- Login in POS2
- On the button area below the ticket info, click on the three dots button to open extra options
- Click on the "Convert to return" option. This ticket will represent now a return ticket.
- Add a product that has modifiers (i.e. Carbonio Helmet)
- The Product Configuration wizard will open, but it should not because there is no need to configure products that are about to be returned
TagsNo tags attached.
Attached Filespng file icon 3105_1.png [^] (101,088 bytes) 2022-06-23 11:24


png file icon 3105_2.png [^] (96,628 bytes) 2022-06-23 11:25

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 004972822Q3 scheduledablasco FLUN-3105 - Wrong behavior when blind return with a product with pager and modifiers 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0138829)
hgbot (developer)
2022-06-28 17:34

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/1053 [^]
(0138877)
hgbot (developer)
2022-06-30 00:20

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2 [^]
Changeset: 681ae055df97d601b7c4df8e3f5b2cfc59d55eff
Author: adrian.blasco <adrian.blasco@openbravo.com>
Date: 30-06-2022 00:16:13
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/commit/681ae055df97d601b7c4df8e3f5b2cfc59d55eff [^]

Fixes ISSUE-49636 - Configurable Product options should not appear in return Ticket

---
M web-jspack/org.openbravo.pos2/src/model/ticket/__test__/AddProduct.test.js
M web-jspack/org.openbravo.pos2/src/model/ticket/user-actions/AddProduct.js
---
(0138878)
hgbot (developer)
2022-06-30 00:20

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/1053 [^]
(0139000)
timothee_catteeuw (developer)
2022-07-04 11:10

Not totally good.

→ no modifier are asked when I select products → OK

→ but when I want refund by pressing refund button, it is not possible because of this message → KO

Product is not fully configured. Please, complete or abort the current product configuration.

- Issue History
Date Modified Username Field Change
2022-06-23 11:24 mmohammad New Issue
2022-06-23 11:24 mmohammad Assigned To => Retail
2022-06-23 11:24 mmohammad File Added: 3105_1.png
2022-06-23 11:24 mmohammad Triggers an Emergency Pack => No
2022-06-23 11:25 mmohammad File Added: 3105_2.png
2022-06-27 12:02 timothee_catteeuw Summary FLUN-3105 Error on blind return with a product with pager and modifiers => FLUN-3105 - Wrong behavior when blind return with a product with pager and modifiers
2022-06-27 12:02 timothee_catteeuw Description Updated View Revisions
2022-06-27 12:02 timothee_catteeuw Steps to Reproduce Updated View Revisions
2022-06-27 16:17 AugustoMauch Assigned To Retail => ablasco
2022-06-27 16:17 AugustoMauch Status new => scheduled
2022-06-27 16:26 AugustoMauch Steps to Reproduce Updated View Revisions
2022-06-28 17:34 hgbot Note Added: 0138829
2022-06-30 00:20 hgbot Resolution open => fixed
2022-06-30 00:20 hgbot Status scheduled => closed
2022-06-30 00:20 hgbot Note Added: 0138877
2022-06-30 00:20 hgbot Note Added: 0138878
2022-07-04 11:09 timothee_catteeuw Status closed => new
2022-07-04 11:10 timothee_catteeuw Note Added: 0139000
2022-07-05 08:34 guilleaer Status new => scheduled


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker