Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0049269
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] POScriticalalways2022-05-09 15:552022-05-17 15:05
Reportertimothee_catteeuwView Statuspublic 
Assigned TojavierRodriguez 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0049269: JIRA 2967 - Errors when trying to handle old tickets (regression)

DescriptionThe error described below appears as soon as wanting to handle an old ticket in sales history on WebPOS.

It happens when you want to :

Open the ticket

cancel the ticket

Cancel and replace the ticket

generate a proof of payment

 
POS2.js:3657 Cannot read properties of undefined (reading '0'); line: s (https://XXXXXX.test.cloud.openbravo.com/openbravo/web/pos/static/js/main.66b075ce.chunk.js:1:15344 [^]) (*)
OB.Console.error @ POS2.js:3657
i @ POS2.js:4346
OB.error @ POS2.js:4375
s @ ErrorHandler.js:28
await in s (asynchrone)
(anonyme) @ getUserAction.js:40
await in (anonyme) (asynchrone)
onLeftClick @ UserActionEvents.js:33
onLeftClick @ PopoverMenuEntry.jsx:56
onClick @ BaseButton.jsx:86
He @ react-dom.production.min.js:52
Ke @ react-dom.production.min.js:52
(anonyme) @ react-dom.production.min.js:53
Sr @ react-dom.production.min.js:100
_r @ react-dom.production.min.js:101
(anonyme) @ react-dom.production.min.js:113
ze @ react-dom.production.min.js:292
(anonyme) @ react-dom.production.min.js:50
Mr @ react-dom.production.min.js:105
Zt @ react-dom.production.min.js:75
Gt @ react-dom.production.min.js:74
t.unstable_runWithPriority @ scheduler.production.min.js:18
Hi @ react-dom.production.min.js:122
Ae @ react-dom.production.min.js:292
Xt @ react-dom.production.min.js:73

There is no error when I want to launch a verified return but Iā€™m notified there is not possible to do this operation for the moment.
Steps To Reproducego to WebPOS and login

go to sales ticket history

try to :

Open a ticket

cancel a ticket

Cancel and replace a ticket

generate a proof of payment for a ticket

ā†’ KO the error is displayed

try to do a verified return :

ā€“ > KO this message appears :

YYour request can't be completed right now
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0137113)
Felixaka (developer)
2022-05-10 11:57

I add a note that could be related to the pb.

-On the physical tills, when we print a ticket and we want to find him again by scan the barcode

we have the error message : The code '010000041/0000074' cannot be found
(0137328)
jmelin (developer)
2022-05-16 14:43

The issue is related to meal allocation.
In "PaidReceiptsProperties.java", we add to retrieve data from "ord.flintrmEmployee" which add a joint with flintrm_employee
That prevent the order to be loaded if no meal allocation is used in the order
(0137389)
guilleaer (manager)
2022-05-17 15:05

https://gitlab.com/obcustomers/AGAP/com.openbravo.flunch.integration.allocation/-/merge_requests/6 [^]

- Issue History
Date Modified Username Field Change
2022-05-09 15:55 timothee_catteeuw New Issue
2022-05-09 15:55 timothee_catteeuw Assigned To => Retail
2022-05-09 15:55 timothee_catteeuw Triggers an Emergency Pack => No
2022-05-10 11:57 Felixaka Note Added: 0137113
2022-05-13 21:12 sntgreale Assigned To Retail => sntgreale
2022-05-13 21:12 sntgreale Status new => scheduled
2022-05-16 14:43 jmelin Note Added: 0137328
2022-05-17 12:59 javierRodriguez Assigned To sntgreale => javierRodriguez
2022-05-17 15:05 guilleaer Note Added: 0137389
2022-05-17 15:05 guilleaer Status scheduled => resolved
2022-05-17 15:05 guilleaer Resolution open => fixed
2022-05-17 15:05 guilleaer Review Assigned To => guilleaer
2022-05-17 15:05 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker