Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0048054
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorrandom2021-11-12 15:292022-01-03 14:22
ReporterdromeroView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomigueldejuana
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0048054: Products with multiple UPC/EAN not found in Web POS

DescriptionWhen a product has 2 UPC/EAN registered by two different users, it is not found in the web pos "Scan" tab, but the behavior is random. If it is the first time you login to the webPOS, it works. If you have already logged in the web POS, it does not work unless you trigger the "Refresh Data" process. But in some cases, you will need a full refresh in order to make it work (erase cache)

Summary of some tests performed:
https://docs.google.com/spreadsheets/d/1_1ijcQZfoB6pBFSR8hJedIo-gmjUSUKOdzKUFez_jos/edit?usp=sharing [^]

Client version: Openbravo 3.0 PR20Q1.3
Steps To Reproduce1) Log into back office with the user Openbravo and an administrative role.
2) Choose a point of sale to realize the test from "chanel - Touchpoint" tab
3) Navigate to the assortment of that POS and pick a product to do the test.
4) Navigate to the product, select the "Multi UPC" tab and create a new record with a dummy UPC/EAN
5) Logout and log back in with another user that has the permisions to create UPC/EAN codes for a product. Make sure it does not have the same role as the Openbravo user.
6) Navigate to the same product and create a new record with another dummy UPC/EAN.
7) Log into the terminal chosen for this test, with any user.
8) Go to the "Scan" tab and input the UPC/EAN created with the Openbravo user. Observe the behavior.
9) Input the UPC/EAN created with the other user. Observe the behavior.
10) If the product is found, that is the expected behavior by the client.
11) In case the product is not found, perform the "Refresh Data" process and go back to step 8.
TagsNo tags attached.
Attached Filesdiff file icon 48054_multiupc.diff [^] (1,469 bytes) 2022-01-03 14:20 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0045288 closedranjith_qualiantech_com MultiUPC module doesn't work correctly when scanning if many products are available in local mode 
related to feature request 0045240 closedranjith_qualiantech_com MultiUPC filter by multiple UPCs should work in the SEARCH component in Remote mode 

-  Notes
(0132999)
dromero (developer)
2021-11-12 15:45

Support Ticket: 32122

We have more videos of other tests that we can submit if necessary.
(0133302)
rmagnoli (developer)
2021-11-23 14:39

Hi team.

When do you think we could get the resolution for this issue?
Thanks in advance.
(0133392)
dromero (developer)
2021-11-26 16:58

Hi Team,

Any update?

Thanks
(0134099)
ranjith_qualiantech_com (developer)
2022-01-03 13:40

Issue occurs due to the cache problem (cache was not initialized when searching UPC) explained in this issue https://issues.openbravo.com/view.php?id=45288 [^]

Suggested fix was remove the findUsingCache when searching with UPC.
Attached fix to the issue: 48054_multiupc.diff
(0134103)
migueldejuana (developer)
2022-01-03 14:22

Reviewed

- Issue History
Date Modified Username Field Change
2021-11-12 15:29 dromero New Issue
2021-11-12 15:29 dromero Assigned To => Retail
2021-11-12 15:29 dromero Regression date => 2021-11-26
2021-11-12 15:29 dromero Triggers an Emergency Pack => No
2021-11-12 15:45 dromero Note Added: 0132999
2021-11-23 14:39 rmagnoli Note Added: 0133302
2021-11-26 16:58 dromero Note Added: 0133392
2021-12-13 07:45 marvintm Regression date 2021-11-26 =>
2021-12-14 17:09 justin_patterson Assigned To Retail => justin_patterson
2021-12-17 08:29 marvintm Assigned To justin_patterson => Retail
2021-12-28 06:48 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2021-12-31 06:52 ranjith_qualiantech_com Relationship added related to 0045288
2021-12-31 06:54 ranjith_qualiantech_com Relationship added related to 0045240
2022-01-03 13:40 ranjith_qualiantech_com Status new => scheduled
2022-01-03 13:40 ranjith_qualiantech_com Note Added: 0134099
2022-01-03 13:40 ranjith_qualiantech_com Status scheduled => resolved
2022-01-03 13:40 ranjith_qualiantech_com Resolution open => fixed
2022-01-03 14:20 ranjith_qualiantech_com File Added: 48054_multiupc.diff
2022-01-03 14:22 migueldejuana Review Assigned To => migueldejuana
2022-01-03 14:22 migueldejuana Note Added: 0134103
2022-01-03 14:22 migueldejuana Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker