Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0045866
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2021-02-08 14:552021-03-15 08:02
ReporteraferrazView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR21Q2
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0045866: Print error when completing a ticket loaded from backoffice

DescriptionPrint error when completing a ticket loaded from backoffice
Steps To Reproduce- Login in New POS
- Create a ticket, pay and complete it
- Load previous ticket
- Complete it again
- Check "Printer and display are not available." error is shown
Proposed SolutionMigrate the printclosedreceipt.xml template. See the migration guide here: Migrate all the pending templates. See the migration guide here: http://wiki.openbravo.com/wiki/Retail:Developers_Guide/New_Javascript_template_engine_for_receipt_printer_and_customer_displays_documents#Migrating_legacy_templates [^]

Once fixed update this doc: https://docs.google.com/spreadsheets/d/1YSAuKzGMv2eVB1m8xMOHidwjFRh5-8K2KSYQKoVq3ww/edit#gid=117456702 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0045789 newRetail Migrate printing templates to the new definition 
related to defect 0045865 closedranjith_qualiantech_com Error in Print Last Receipt 
related to defect 0046134 closedcaristu Some migrated print templates fails in new POS 

-  Notes
(0126560)
hgbot (developer)
2021-03-09 03:49

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/340 [^]
(0126685)
hgbot (developer)
2021-03-15 08:01

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal [^]
Changeset: ef70d2e77a31de1533a801057846ef31c415b6bd
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2021-03-15T10:30:47+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/ef70d2e77a31de1533a801057846ef31c415b6bd [^]

Related to ISSUE-45866: Migrated Print Templates based on New Implementation

---
M src-db/database/sourcedata/OBPOS_PRINT_TEMPLATE.xml
M web/org.openbravo.retail.posterminal/app/external-device/printing/PrintTemplateStore.js
M web/org.openbravo.retail.posterminal/res/printcanceledlayaway.xml
M web/org.openbravo.retail.posterminal/res/printcanceledreceipt.xml
M web/org.openbravo.retail.posterminal/res/printcashmgmt.xml
M web/org.openbravo.retail.posterminal/res/printcashup.xml
M web/org.openbravo.retail.posterminal/res/printclosedinvoice.xml
M web/org.openbravo.retail.posterminal/res/printclosedreceipt.xml
M web/org.openbravo.retail.posterminal/res/printinvoice.xml
M web/org.openbravo.retail.posterminal/res/printlayaway.xml
M web/org.openbravo.retail.posterminal/res/printreceipt.xml
M web/org.openbravo.retail.posterminal/res/printreceipt32.xml
M web/org.openbravo.retail.posterminal/res/printreturn.xml
M web/org.openbravo.retail.posterminal/res/printreturninvoice.xml
M web/org.openbravo.retail.posterminal/res/printsimplifiedclosedinvoice.xml
M web/org.openbravo.retail.posterminal/res/printsimplifiedinvoice.xml
M web/org.openbravo.retail.posterminal/res/printsimplifiedreturninvoice.xml
---
(0126686)
hgbot (developer)
2021-03-15 08:01

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/340 [^]

- Issue History
Date Modified Username Field Change
2021-02-08 14:55 aferraz New Issue
2021-02-08 14:55 aferraz Assigned To => Retail
2021-02-08 14:55 aferraz Triggers an Emergency Pack => No
2021-02-08 14:55 aferraz Relationship added related to 0045865
2021-02-08 19:00 caristu Relationship added duplicate of 0045789
2021-02-28 18:40 guilleaer Assigned To Retail => aferraz
2021-03-01 10:06 caristu Proposed Solution updated
2021-03-01 11:48 guilleaer Assigned To aferraz => hernan-dp
2021-03-01 11:48 guilleaer Assigned To hernan-dp => ranjith_qualiantech_com
2021-03-07 13:48 ranjith_qualiantech_com Status new => scheduled
2021-03-09 03:49 hgbot Note Added: 0126560
2021-03-15 08:01 hgbot Note Added: 0126685
2021-03-15 08:01 hgbot Note Added: 0126686
2021-03-15 08:01 marvintm Project New POS => Retail Modules
2021-03-15 08:02 marvintm Category POS => Web POS
2021-03-15 08:02 marvintm Status scheduled => resolved
2021-03-15 08:02 marvintm Fixed in Version => RR21Q2
2021-03-15 08:02 marvintm Resolution open => fixed
2021-03-15 08:02 marvintm Review Assigned To => marvintm
2021-03-15 08:02 marvintm Status resolved => closed
2021-03-24 17:46 caristu Relationship added related to 0046134


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker