Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0045755
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo Localizations] Localization Francemajoralways2021-01-19 15:272021-08-10 09:34
ReporterpsanjuanView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Regression introduced in release
Summary

0045755: New taxes required set as Tax Exempt=Yes

DescriptionNew taxes required set as Tax Exempt=Yes
Steps To ReproduceCreate a BP and set it as Tax Exempt = Yes
Make a sales for it, for a product related with a Non-Exempt tax category (ie. TVA Normale)
Realize that a normal VAT Rate is shown in the order/sale.
Proposed SolutionIt is required to create below listed new taxes related to each existing FR tax category (but Exonere), set up as Tax Exempt.

TVA Normale Exonérée - Tax Category = TVA Normale - Rate 0,00 - Tax Exempt = Yes
TVA Réduite Exonérée- Tax Category = TVA Réduite - Rate 0,00 - Tax Exempt = Yes
TVA Intermédiaire Exonérée - Tax Category = TVA Intermédiaire - Rate 0,00 - Tax Exempt = Yes
TVA particulière Exonérée- Tax Category = TVA particulière - Rate 0,00 - Tax Exempt = Yes




1 ) Exonéré (existing) BCF698789D4F4F7DB82850F32B0E133D

UPDATE public.c_tax
SET ad_client_id='757D621ABD1948F5BCBAD91F19BB70AC', ad_org_id='0', isactive='Y', created='2019-11-07 12:42:24.412', createdby='100', updated=NOW(), "name"='Exonéré', updatedby='100', description='Exonéré', taxindicator=NULL, validfrom='2000-01-01 00:00:00.000', issummary='N', rate=0.0, parent_tax_id=NULL, c_country_id='102', c_region_id=NULL, to_country_id='102', to_region_id=NULL, c_taxcategory_id='65B3F8E34D32434DABC8D1E30B9F207E', isdefault='N', istaxexempt='Y', sopotype='B', "cascade"='N', c_bp_taxcategory_id=NULL, line=10, iswithholdingtax='N', isnotaxable='N', deducpercent=NULL, originalrate=NULL, istaxundeductable='N', istaxdeductable='N', isnovat='N', baseamount='LNA', c_taxbase_id=NULL, doctaxamount='D', iscashvat='N', em_obspti_declaration=NULL, em_obspti_isreversecharge='N', em_obspti_isequivalentcharge='N', em_obspti_isintracommunity='N', em_obspti_islease='N', em_obspti_isrealestate='N', em_obspti_reagyp='N', em_obspti_isrebu='N', em_obspti_isexport='N', em_obspti_isimplicitcharge='N'
WHERE c_tax_id='BCF698789D4F4F7DB82850F32B0E133D';
 


2 ) TVA Particulière Exonérée (NEW) B9AA30028EA14F778B3440F20BFF8692

INSERT INTO public.c_tax
(c_tax_id, ad_client_id, ad_org_id, isactive, created, createdby, updated, "name", updatedby, description, taxindicator, validfrom, issummary, rate, parent_tax_id, c_country_id, c_region_id, to_country_id, to_region_id, c_taxcategory_id, isdefault, istaxexempt, sopotype, "cascade", c_bp_taxcategory_id, line, iswithholdingtax, isnotaxable, deducpercent, originalrate, istaxundeductable, istaxdeductable, isnovat, baseamount, c_taxbase_id, doctaxamount, iscashvat, em_obspti_declaration, em_obspti_isreversecharge, em_obspti_isequivalentcharge, em_obspti_isintracommunity, em_obspti_islease, em_obspti_isrealestate, em_obspti_reagyp, em_obspti_isrebu, em_obspti_isexport, em_obspti_isimplicitcharge)
VALUES('B9AA30028EA14F778B3440F20BFF8692', '757D621ABD1948F5BCBAD91F19BB70AC', '0', 'Y', now(), '100', now(), 'TVA Particulière Exonérée', '100', 'TVA Particulière Exonérée', NULL, '2000-01-01 00:00:00.000', 'N', 0, NULL, '102', NULL, '102', NULL, 'F690417589B44D93A7A3BF92CF88148C', 'N', 'Y', 'S', 'N', NULL, 10, 'N', 'N', NULL, NULL, 'N', 'N', 'N', 'LNA', NULL, 'D', 'N', NULL, 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N');
 


3 ) TVA Intermédiaire Exonérée (NEW) E6884050472F4E9C82D4E90144996448

INSERT INTO public.c_tax
(c_tax_id, ad_client_id, ad_org_id, isactive, created, createdby, updated, "name", updatedby, description, taxindicator, validfrom, issummary, rate, parent_tax_id, c_country_id, c_region_id, to_country_id, to_region_id, c_taxcategory_id, isdefault, istaxexempt, sopotype, "cascade", c_bp_taxcategory_id, line, iswithholdingtax, isnotaxable, deducpercent, originalrate, istaxundeductable, istaxdeductable, isnovat, baseamount, c_taxbase_id, doctaxamount, iscashvat, em_obspti_declaration, em_obspti_isreversecharge, em_obspti_isequivalentcharge, em_obspti_isintracommunity, em_obspti_islease, em_obspti_isrealestate, em_obspti_reagyp, em_obspti_isrebu, em_obspti_isexport, em_obspti_isimplicitcharge)
VALUES('E6884050472F4E9C82D4E90144996448', '757D621ABD1948F5BCBAD91F19BB70AC', '0', 'Y', now(), '100', now(), 'TVA Intermédiaire Exonérée', '100', 'TVA Intermédiaire Exonérée', NULL, '2000-01-01 00:00:00.000', 'N', 0, NULL, '102', NULL, '102', NULL, '3DDBD769E0B14E54B8A55A54CA50C142', 'N', 'Y', 'S', 'N', NULL, 10, 'N', 'N', NULL, NULL, 'N', 'N', 'N', 'LNA', NULL, 'D', 'N', NULL, 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N');
 


4 ) TVA Réduite Exonérée (NEW) 47F6AF08EC0B4C8FB77E2CF724D79E1E

INSERT INTO public.c_tax
(c_tax_id, ad_client_id, ad_org_id, isactive, created, createdby, updated, "name", updatedby, description, taxindicator, validfrom, issummary, rate, parent_tax_id, c_country_id, c_region_id, to_country_id, to_region_id, c_taxcategory_id, isdefault, istaxexempt, sopotype, "cascade", c_bp_taxcategory_id, line, iswithholdingtax, isnotaxable, deducpercent, originalrate, istaxundeductable, istaxdeductable, isnovat, baseamount, c_taxbase_id, doctaxamount, iscashvat, em_obspti_declaration, em_obspti_isreversecharge, em_obspti_isequivalentcharge, em_obspti_isintracommunity, em_obspti_islease, em_obspti_isrealestate, em_obspti_reagyp, em_obspti_isrebu, em_obspti_isexport, em_obspti_isimplicitcharge)
VALUES('47F6AF08EC0B4C8FB77E2CF724D79E1E', '757D621ABD1948F5BCBAD91F19BB70AC', '0', 'Y', now(), '100', now(), 'TVA Réduite Exonérée', '100', 'TVA Réduite Exonérée', NULL, '2000-01-01 00:00:00.000', 'N', 0, NULL, '102', NULL, '102', NULL, '238F9E5D5FD142C2BB0E53A33E885656', 'N', 'Y', 'S', 'N', NULL, 10, 'N', 'N', NULL, NULL, 'N', 'N', 'N', 'LNA', NULL, 'D', 'N', NULL, 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N');
 


5 ) TVA Normale Exonérée (NEW) 57C3B025A5524E40B4C7120B55CC4B9C

INSERT INTO public.c_tax
(c_tax_id, ad_client_id, ad_org_id, isactive, created, createdby, updated, "name", updatedby, description, taxindicator, validfrom, issummary, rate, parent_tax_id, c_country_id, c_region_id, to_country_id, to_region_id, c_taxcategory_id, isdefault, istaxexempt, sopotype, "cascade", c_bp_taxcategory_id, line, iswithholdingtax, isnotaxable, deducpercent, originalrate, istaxundeductable, istaxdeductable, isnovat, baseamount, c_taxbase_id, doctaxamount, iscashvat, em_obspti_declaration, em_obspti_isreversecharge, em_obspti_isequivalentcharge, em_obspti_isintracommunity, em_obspti_islease, em_obspti_isrealestate, em_obspti_reagyp, em_obspti_isrebu, em_obspti_isexport, em_obspti_isimplicitcharge)
VALUES('57C3B025A5524E40B4C7120B55CC4B9C', '757D621ABD1948F5BCBAD91F19BB70AC', '0', 'Y', now(), '100', now(), 'TVA Normale Exonérée', '100', 'TVA Normale Exonérée', NULL, '2000-01-01 00:00:00.000', 'N', 0, NULL, '102', NULL, '102', NULL, '4F825B307C554B7BB97642E6317C8B9B', 'N', 'Y', 'S', 'N', NULL, 10, 'N', 'N', NULL, NULL, 'N', 'N', 'N', 'LNA', NULL, 'D', 'N', NULL, 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N');
FY


All of them set as Sales Taxes, with France - France (Metropolitan Regions) configuration

IDs will be provided.
TagsNOR
Attached Filespng file icon Screenshot from 2021-01-19 15-23-09.png [^] (57,110 bytes) 2021-01-19 15:43

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0045643 closedranjith_qualiantech_com Retail Modules Tax exempt usage is not applying in Tax Engine 
related to defect 0045642 closedranjith_qualiantech_com Retail Modules Deactivation of tax rates does not have effect in web POS 
related to feature request 0046314 newpsanjuan Retail Modules Net Prices must be used if a sale is created for an exempt BP for products having a price list including taxes. 
related to defect 0046791 closedranjith_qualiantech_com Retail Modules Tax can not be found 
related to defect 0047281 closedvmromanos Openbravo Localizations Some Exempt tax rates are not configured properly 
related to defect 0047264 closedTriage Finance Modules Configuration of 'Region' and 'Destination Region' in the 'Tax rate' header does not work, for instance 8.5 DOM-TOM 
related to defect 0047419 newfernando_merino Openbravo Localizations Wrong tax calculation for sales to not exempt customers from a Store located in Guadeloupe to a customer located in Guadeloupe 

-  Notes
(0125641)
rafaroda (developer)
2021-01-19 15:44

See related 0045643
(0125974)
psanjuan (manager)
2021-02-04 10:06
edited on: 2021-02-04 16:50

This "tax exempt" taxes configuration needs to be implemented together with a new feature that allows to recalculate "tax base amount", in case of price list including taxes.

As an example:

The store has configured a price list including taxes. The price of a given product is 121.00€

That product is related to a Normal VAT Tax Group which implies a 21% sales tax rate.

If this product is sold to a "normal" customer, the price of that product is 121.00€, and the system will calculate back a tax base amount of 100.00

But, let us imagine a BP configured as Tax Exempt.

If the same product is sold to this customer, the same price list will be applied, but the tax rate selected will be the one described above "TVA Normale Exonérée".

Currently, the sale price for this customer will be the same 121.00; but that is wrong as it should be just the tax base amount, because that price is including taxes.

A new FR entry needs to be created for this.

(0130034)
hgbot (developer)
2021-06-30 17:54

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.localization.france.referencedata.taxes/-/merge_requests/3 [^]
(0130423)
psanjuan (manager)
2021-07-13 16:52
edited on: 2021-07-20 18:47

Verified without regions and working.

Test Plan executed:

Apply taxes for France to a Legal Entity (The White Valley Franchise) located in France, region Auvergne-Rhone-Alpes.
Select the product "Balaclava Cap" and relate it to the Tax Category TVA Normale, configured also with "Home Delivery" delivery mode.

Test 1
Sale from Organization located in Auvergne-Rhone-Alpes to a BP exempt located in region Occitanie
Tax rate= TVA Normale Exonérée

Test 2
Sale from Organization located in Auvergne-Rhone-Alpes to a BP NOT exempt located in region Occitanie
Tax rate= TVA 20%

Test 3
Sale from Organization located in Auvergne-Rhone-Alpes to a BP NOT exempt located in region Guadeloupe
Tax rate= Export DOM-TOM Normale

Test 4
Sale from Organization located in Auvergne-Rhone-Alpes to a BP exempt located in region Guadeloupe
Tax rate= Export DOM-TOM Normale

(0131045)
hgbot (developer)
2021-08-10 09:24

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.localization.france.referencedata.taxes [^]
Changeset: bb253be918d7de9169997d4b509c66d5b3f3eb92
Author: Víctor Martínez Romanos <victor.martinez@openbravo.com>
Date: 2021-07-09T14:55:27+02:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.localization.france.referencedata.taxes/-/commit/bb253be918d7de9169997d4b509c66d5b3f3eb92 [^]

Related to ISSUE-45755: Removed Exonéré tax's region from and to

---
M referencedata/standard/Taxes_France.xml
---
(0131046)
hgbot (developer)
2021-08-10 09:24

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.localization.france.referencedata.taxes [^]
Changeset: 036eb2f68e8dc0cfe9f2d8a0c27b42d9a94ee076
Author: Víctor Martínez Romanos <victor.martinez@openbravo.com>
Date: 2021-07-09T14:56:05+02:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.localization.france.referencedata.taxes/-/commit/036eb2f68e8dc0cfe9f2d8a0c27b42d9a94ee076 [^]

Fixed ISSUE-45755: Added new tax exempt tax rates

* TVA Normale Exonérée - Tax Category = TVA Normale - Rate 0,00 - Tax Exempt = Yes
* TVA Réduite Exonérée- Tax Category = TVA Réduite - Rate 0,00 - Tax Exempt = Yes
* TVA Intermédiaire Exonérée - Tax Category = TVA Intermédiaire - Rate 0,00 - Tax Exempt = Yes
* TVA particulière Exonérée- Tax Category = TVA particulière - Rate 0,00 - Tax Exempt = Yes

Country from = Country To = France
Region from = Region To = null

---
M referencedata/standard/Taxes_France.xml
M src-db/database/sourcedata/AD_DATASET.xml
M src-db/database/sourcedata/AD_MODULE.xml
---
(0131047)
hgbot (developer)
2021-08-10 09:24

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.localization.france.referencedata.taxes/-/merge_requests/3 [^]

- Issue History
Date Modified Username Field Change
2021-01-19 15:27 psanjuan New Issue
2021-01-19 15:42 rafaroda Issue Monitored: rafaroda
2021-01-19 15:42 rafaroda Tag Attached: NOR
2021-01-19 15:43 rafaroda Proposed Solution updated
2021-01-19 15:43 rafaroda File Added: Screenshot from 2021-01-19 15-23-09.png
2021-01-19 15:44 rafaroda Relationship added related to 0045643
2021-01-19 15:44 rafaroda Note Added: 0125641
2021-01-19 15:44 rafaroda Relationship added related to 0045642
2021-02-04 10:06 psanjuan Note Added: 0125974
2021-02-04 10:06 psanjuan Note Edited: 0125974 View Revisions
2021-02-04 10:09 psanjuan Note Edited: 0125974 View Revisions
2021-02-04 16:50 psanjuan Note Edited: 0125974 View Revisions
2021-03-17 11:47 psanjuan Assigned To => psanjuan
2021-04-21 12:59 psanjuan Relationship added related to 0046314
2021-05-28 12:49 rafaroda Relationship added related to 0046791
2021-06-29 15:31 rafaroda Relationship added related to 0047281
2021-06-30 17:43 vmromanos Status new => scheduled
2021-06-30 17:43 vmromanos Assigned To psanjuan => vmromanos
2021-06-30 17:54 hgbot Note Added: 0130034
2021-07-13 12:55 rafaroda Relationship added related to 0047264
2021-07-13 16:52 psanjuan Note Added: 0130423
2021-07-20 18:47 psanjuan Note Edited: 0130423 View Revisions
2021-07-20 22:37 rafaroda Relationship added related to 0047419
2021-08-10 09:24 hgbot Note Added: 0131045
2021-08-10 09:24 hgbot Resolution open => fixed
2021-08-10 09:24 hgbot Status scheduled => resolved
2021-08-10 09:24 hgbot Note Added: 0131046
2021-08-10 09:24 hgbot Note Added: 0131047
2021-08-10 09:34 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker