Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044504
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2020-06-26 17:472020-07-07 10:01
ReporterrafarodaView Statuspublic 
Assigned Torafaroda 
PrioritynormalResolutionopenFixed in Version
StatusfeedbackFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044504: Scan logic is not following the same logic for Layaways than Open Receipts

DescriptionIn a project we are having layaways being sent by an external system that are integrated in the backoffice via the Order Loader.

We have extended the Order Loader to accept the same document number of Layaway: this means, if we receive a layaway with documentNo = 123 twice, the first order goes into status = Closed (from Booked), and the second Order goes into status = Booked

In Menu > Open Receipts, we can search for the documentNo = 123 and only shows the Booked status one: OK

But when we scan, we have result "123 can't be found": KO
Steps To Reproduce* In Backoffice (via database), make 2 layaways with the same documentNo = 123, one in status Closed and the second in status Booked
* In WebPOS: Menu > Open Receipts: you will find the documentNo = 123, OK
* In WebPOS, Scan 123: you will get result "123 can't be found"
Proposed SolutionScan when searching for orders whould follow the same logic as Menu > Open Receipts: which is, excluding the documents in status = Closed
TagsNOR
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0121290)
marvintm (developer)
2020-07-07 10:01

We cannot reproduce the issue. We have verified that the ScanReceipt module uses the PaidReceiptsFilter class to load the order, and this class is currently adding the filter to remove the "closed" orders from the result.

- Issue History
Date Modified Username Field Change
2020-06-26 17:47 rafaroda New Issue
2020-06-26 17:47 rafaroda Assigned To => Retail
2020-06-26 17:47 rafaroda Triggers an Emergency Pack => No
2020-06-26 17:47 rafaroda Tag Attached: NOR
2020-07-05 18:02 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-07-07 10:01 marvintm Note Added: 0121290
2020-07-07 10:01 marvintm Assigned To ranjith_qualiantech_com => rafaroda
2020-07-07 10:01 marvintm Status new => feedback


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker