Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044100
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2020-05-19 11:542020-06-01 19:52
Reportersanti_lozanoView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR20Q3
StatusclosedFix in branchFixed in SCM revision52afdf032206
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - QA Approved
Regression date2019-10-30
Regression introduced in releaseRR20Q1
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8010727b12224ff5cd51931cdd6ba6b79cd2015a [^]
Triggers an Emergency PackNo
Summary

0044100: Override existing promotions overrides all lines

DescriptionOverride existing promotions overrides all discounts on lines of the ticket on Web POS instead of only the selected ones
This happens on 20Q1 and tip, but doesn't happen on 19Q4.4
As explained on the wiki the correct behavior is the previous one:
"Indicate if this discount will override existing promotions. If this field is checked, no more promotions will be applied to affected lines."
Steps To Reproduce1- Add first line with product "Adhesive body warmers"
2- Add second line with product "Alpine poles"
3- Go to menu "Receipt discounts"
4- Select discount disc_5_var_perc
5- Select first line, click "Override existing promotion" and apply
6- Review that the discount has been applied on the first line
7- Go to menu "Receipt discounts"
8- Select discount disc_5_var_perc
9- Select second line, click "Override existing promotion" and apply
10- Review that the discount has been applied on the second line but the discount on the first line has disappeared
Proposed SolutionThere was an issue related to this topic that could be the cause 42117
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0044239RR20Q2 closedranjith_qualiantech_com Override existing promotions overrides all lines 
depends on backport 0044240RR20Q1.2 closedranjith_qualiantech_com Override existing promotions overrides all lines 

-  Notes
(0120478)
hgbot (developer)
2020-06-01 02:12

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 52afdf0322062ca7a994256f68e3ceb45729fd95
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Jun 01 05:42:12 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/52afdf0322062ca7a994256f68e3ceb45729fd95 [^]

Fixed issue-44100 : Added validation when applying discount with override option

* When applying discount with Override existing promotions,
  all manualpromotions should be removed for the selected line before applying new promotion
* When opening discount tab, "Override existing promotions" check box should not be checked by default

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/ticketdiscount.js
---
(0120479)
hgbot (developer)
2020-06-01 02:12

Repository: tools/automation/pi-mobile
Changeset: f99e0fa3351bdb73a463d23283dabe657afe366d
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Jun 01 05:42:26 2020 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/f99e0fa3351bdb73a463d23283dabe657afe366d [^]

Verifies issue 44100 : Added Automated Test I44100_VerifyManualDiscounts

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/splitline/SplitLineWithManualPromo2Combined.java
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/discountsandpromotions/I44100_VerifyManualDiscounts.java
---

- Issue History
Date Modified Username Field Change
2020-05-19 11:54 santi_lozano New Issue
2020-05-19 11:54 santi_lozano Assigned To => Retail
2020-05-19 11:54 santi_lozano Triggers an Emergency Pack => No
2020-05-19 12:05 Practics Issue Monitored: Practics
2020-05-22 10:26 ngarcia Type backport => defect
2020-05-29 11:59 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-05-29 14:23 ranjith_qualiantech_com Regression level => Production - QA Approved
2020-05-29 14:23 ranjith_qualiantech_com Regression date => 2019-10-30
2020-05-29 14:23 ranjith_qualiantech_com Regression introduced in release => RR20Q1
2020-05-29 14:23 ranjith_qualiantech_com Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8010727b12224ff5cd51931cdd6ba6b79cd2015a [^]
2020-05-29 17:01 marvintm Status new => scheduled
2020-06-01 02:12 hgbot Checkin
2020-06-01 02:12 hgbot Note Added: 0120478
2020-06-01 02:12 hgbot Status scheduled => resolved
2020-06-01 02:12 hgbot Resolution open => fixed
2020-06-01 02:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/52afdf0322062ca7a994256f68e3ceb45729fd95 [^]
2020-06-01 02:12 hgbot Checkin
2020-06-01 02:12 hgbot Note Added: 0120479
2020-06-01 19:52 marvintm Review Assigned To => marvintm
2020-06-01 19:52 marvintm Status resolved => closed
2020-06-01 19:52 marvintm Fixed in Version => RR20Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker