Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043831
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2020-04-22 21:372020-06-05 10:08
ReporterlbressanView Statuspublic 
Assigned Toinigo_lerga 
PriorityhighResolutionfixedFixed in VersionPR20Q3
StatusclosedFix in branchFixed in SCM revisionff56a9703ef5
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043831: Error processing G/L Journal with date format MM-DD-YYYY

DescriptionConfiguring the MM-DD-YYYY date format for an environment and creating the header of a G / L Journal will not allow you to create the lines or process it, since it throws an error in the class org.openbravo.erpCommon.ad_callouts.SLJournalPeriodData
Since the date format DD-MM-YYYY is being set in the "getCurrencyRate" function, so it is incompatible and throws an error.
(SLJournalPeriodData.png)
Steps To Reproduce0. Openbravo.properties is configured (Configuracion_en_OB_Properties.png)
1. Create a G/L Journal header dated 04-17-2020
It does not allow you to create lines, nor to process the G/L Journal (GLJournal_Fecha_Incompatible.png)
Proposed SolutionIt must be changed to read the date format configured in the Openbravo.properties
TagsNo tags attached.
Attached Fileszip file icon imgs.zip [^] (179,888 bytes) 2020-04-22 21:37

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0119684)
hgbot (developer)
2020-05-08 11:58

Repository: erp/devel/pi
Changeset: ff56a9703ef53221aac471faafd1a026f03d03b0
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu May 07 17:35:43 2020 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ff56a9703ef53221aac471faafd1a026f03d03b0 [^]

Related to Issue 43831. Removed the mask from the call to the TO_DATE
function in query

---
M src/org/openbravo/erpCommon/ad_callouts/SL_Journal_Period_data.xsql
---
(0119685)
dmiguelez (developer)
2020-05-08 12:00

The problem with this issue is not the mask of the TO_DATE function itself, but a problem with the Openbravo.properties configuration.

In the steps reported, the configuration for the bbdd.sessionConfig was wrong, as it should have the same date mask as the one defined for the dateformat.sql:
http://wiki.openbravo.com/wiki/Openbravo.properties#Database [^]

With this configuration, the issue is no longer reproducible, however, the fix to remove the mask from the TO_DATE call has been done to improve the existing code.
(0119686)
dmiguelez (developer)
2020-05-08 12:02
edited on: 2020-05-08 12:02

Test Plan

0. Openbravo.properties is configured (Configuracion_en_OB_Properties.png)
1. Configure the bbdd.sessionConfig with the same mask as the one defined for the dateformat.sql
2. ant update.database compile.complete
3. Create a G/L Journal header dated 04-17-2020
Check that it is possible to create new lines and no errors are shown in the log

(0119688)
dmiguelez (developer)
2020-05-08 12:03

Code Review + Testing Ok
(0120688)
hudsonbot (developer)
2020-06-05 10:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5df961d296a2 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2020-04-22 21:37 lbressan New Issue
2020-04-22 21:37 lbressan Assigned To => Triage Finance
2020-04-22 21:37 lbressan File Added: imgs.zip
2020-04-22 21:37 lbressan Modules => Core
2020-04-22 21:37 lbressan Triggers an Emergency Pack => No
2020-04-22 21:42 lbressan Reproducibility have not tried => always
2020-04-22 21:57 lbressan Proposed Solution updated
2020-04-28 16:22 ngarcia Priority normal => urgent
2020-04-28 16:22 ngarcia Severity minor => major
2020-04-28 16:34 matias-bernal Priority urgent => high
2020-04-30 09:23 inigo_lerga Assigned To Triage Finance => inigo_lerga
2020-04-30 09:23 inigo_lerga Status new => scheduled
2020-05-08 11:58 hgbot Checkin
2020-05-08 11:58 hgbot Note Added: 0119684
2020-05-08 11:58 dmiguelez Status scheduled => resolved
2020-05-08 11:58 dmiguelez Fixed in Version => 3.0PR20Q3
2020-05-08 11:58 dmiguelez Fixed in SCM revision => https://code.openbravo.com/erp/devel/pi/rev/ff56a9703ef53221aac471faafd1a026f03d03b0 [^]
2020-05-08 11:58 dmiguelez Resolution open => fixed
2020-05-08 12:00 dmiguelez Note Added: 0119685
2020-05-08 12:02 dmiguelez Note Added: 0119686
2020-05-08 12:02 dmiguelez Note Edited: 0119686 View Revisions
2020-05-08 12:03 dmiguelez Review Assigned To => dmiguelez
2020-05-08 12:03 dmiguelez Note Added: 0119688
2020-05-08 12:03 dmiguelez Status resolved => closed
2020-06-05 10:08 hudsonbot Checkin
2020-06-05 10:08 hudsonbot Note Added: 0120688


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker