Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043579
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2020-03-25 17:132020-04-06 15:50
Reporterjoniturralde93View Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revision61c747e233b4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release3.0PR19Q3
Regression introduced by commithttps://gitlab.com/openbravo/product/openbravo/-/commit/1894bfea7d6#7a285d1549149911e055ca745223e6079626867e [^]
Triggers an Emergency PackNo
Summary

0043579: Alerts don't show in the main button, only in alert management window

DescriptionAlerts which alert rule is defined in an organization different than * are not counted in the Alert widget in the main window top bar.
Steps To Reproduce1. Create a new alert rule in any organization different than * with this sql query:
SELECT i.c_order_id AS referencekey_id, i.documentno AS record_id, 0 AS ad_role_id, null AS ad_user_id, '' || i.documentno || ' se ha creado.' AS description, 'Y' AS isactive, i.ad_client_id, i.ad_org_id, now() AS created, 0 AS createdby, now() AS updated, 0 AS updatedby FROM c_order i WHERE i.created >= to_date('20-03-2020','dd-MM-yyyy')

2. Create a sales order

3. Create a new process request: Run immediately, alert process. Run the alert process.

4. At the top of the screen, it shows: Alerts (0), however, if you click on it, there is a new alert in the alert management window. The top button won't update by refreshing or waiting.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00435843.0PR20Q1.1 closedalostale Alerts don't show in the main button, only in alert management window 
depends on backport 00435853.0PR19Q4.4 closedalostale Alerts don't show in the main button, only in alert management window 
caused by defect 0040580 closedalostale AlertActionHandler.countActiveAlerts is not using bind-parameters 

-  Notes
(0118825)
alostale (developer)
2020-03-26 07:51

MR: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/52 [^]
(0118862)
hgbot (developer)
2020-03-30 10:12

Repository: erp/devel/pi
Changeset: 26608603ba58017a5ebe0c447082bb5bf164b469
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Mar 26 07:43:14 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/26608603ba58017a5ebe0c447082bb5bf164b469 [^]

fixed BUG-43579: alerts not counted in main top bar widget

  Alerts defined whose alert rule was defined in an organization
  different than * were not counted in main top bar widget.

  Parameter to set filter out not readeable organizations was
  incorrectly setting clients instead of organizations.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/AlertActionHandler.java
---
(0118912)
caristu (developer)
2020-04-02 08:52

MR: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/52 [^]
(0118976)
hgbot (developer)
2020-04-06 11:54

Repository: erp/devel/pi
Changeset: 61c747e233b4c303b1e807d24411e7c448d6db93
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Mar 26 07:43:14 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/61c747e233b4c303b1e807d24411e7c448d6db93 [^]

fixed BUG-43579: alerts not counted in main top bar widget

  Alerts defined whose alert rule was defined in an organization
  different than * were not counted in main top bar widget.

  Parameter to set filter out not readeable organizations was
  incorrectly setting clients instead of organizations.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/AlertActionHandler.java
---
(0118994)
cberner (developer)
2020-04-06 15:50

closed: wrongly reopened

- Issue History
Date Modified Username Field Change
2020-03-25 17:13 joniturralde93 New Issue
2020-03-25 17:13 joniturralde93 Assigned To => platform
2020-03-25 17:13 joniturralde93 Modules => Core
2020-03-25 17:13 joniturralde93 Regression level => Production - Confirmed Stable
2020-03-25 17:13 joniturralde93 Triggers an Emergency Pack => No
2020-03-25 17:25 joniturralde93 Regression introduced in release => 3.0PR19Q2
2020-03-25 17:25 joniturralde93 Description Updated View Revisions
2020-03-25 17:25 joniturralde93 Steps to Reproduce Updated View Revisions
2020-03-25 17:42 joniturralde93 Priority urgent => immediate
2020-03-26 07:17 alostale Assigned To platform => alostale
2020-03-26 07:22 alostale Relationship added caused by 0040580
2020-03-26 07:36 alostale Regression introduced in release 3.0PR19Q2 => 3.0PR19Q3
2020-03-26 07:36 alostale Regression introduced by commit => https://gitlab.com/openbravo/product/openbravo/-/commit/1894bfea7d6#7a285d1549149911e055ca745223e6079626867e [^]
2020-03-26 07:36 alostale Description Updated View Revisions
2020-03-26 07:36 alostale Steps to Reproduce Updated View Revisions
2020-03-26 07:36 alostale Review Assigned To => caristu
2020-03-26 07:38 alostale Status new => scheduled
2020-03-26 07:51 alostale Note Added: 0118825
2020-03-30 10:12 hgbot Checkin
2020-03-30 10:12 hgbot Note Added: 0118862
2020-03-30 10:12 hgbot Status scheduled => resolved
2020-03-30 10:12 hgbot Resolution open => fixed
2020-03-30 10:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/26608603ba58017a5ebe0c447082bb5bf164b469 [^]
2020-04-02 08:52 caristu Note Added: 0118912
2020-04-02 08:52 caristu Status resolved => closed
2020-04-02 08:53 caristu Fixed in Version => 3.0PR20Q2
2020-04-06 11:54 hgbot Checkin
2020-04-06 11:54 hgbot Note Added: 0118976
2020-04-06 11:54 hgbot Status closed => resolved
2020-04-06 11:54 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/26608603ba58017a5ebe0c447082bb5bf164b469 [^] => http://code.openbravo.com/erp/devel/pi/rev/61c747e233b4c303b1e807d24411e7c448d6db93 [^]
2020-04-06 15:50 cberner Note Added: 0118994
2020-04-06 15:50 cberner Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker