Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043507
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminorhave not tried2020-03-17 09:472020-03-27 06:53
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in VersionRR20Q2
StatusclosedFix in branchFixed in SCM revisionf71b8966f3cf
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043507: Remove winston npm dependency from mobile.core

DescriptionThe winston[1] npm library was added to provide to the jest based test infrastructure the ability to log information.

It seems that this does not provide so much value because:

- When enabled there is information logged that is not very useful. For that reason it is disabled by default.

- When creating/analyzing a test, it is possible to debug it using an IDE (VisualStudio, IntelliJ, etc.)

[1] https://www.npmjs.com/package/winston [^]
Steps To Reproduce.
Proposed SolutionDelete winston npm dependency
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0043288 closedmarvintm Implement StateController and SynchronizationBuffer components using IndexedDB 

-  Notes
(0118743)
caristu (developer)
2020-03-23 08:42

MR: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/10 [^]
(0118783)
hgbot (developer)
2020-03-24 10:58

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: f71b8966f3cf81039fe7b81a8c8424e33c28b118
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Sat Mar 21 18:04:30 2020 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/f71b8966f3cf81039fe7b81a8c8424e33c28b118 [^]

fixes BUG-43507: Remove winston npm dependency

  Remove winston npm dependency and log infrastructure from the JS tests since it is not being very used

---
M package.json
M web-test/base/adapter.js
M web-test/base/ob-app.js
R web-test/base/log.js
---

- Issue History
Date Modified Username Field Change
2020-03-17 09:47 caristu New Issue
2020-03-17 09:47 caristu Assigned To => Retail
2020-03-17 09:47 caristu Triggers an Emergency Pack => No
2020-03-17 09:47 caristu Assigned To Retail => caristu
2020-03-17 09:48 caristu Description Updated View Revisions
2020-03-23 08:38 alostale Relationship added related to 0043288
2020-03-23 08:42 caristu Note Added: 0118743
2020-03-24 10:58 hgbot Checkin
2020-03-24 10:58 hgbot Note Added: 0118783
2020-03-24 10:58 hgbot Status new => resolved
2020-03-24 10:58 hgbot Resolution open => fixed
2020-03-24 10:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/f71b8966f3cf81039fe7b81a8c8424e33c28b118 [^]
2020-03-24 10:59 caristu Review Assigned To => alostale
2020-03-27 06:53 alostale Status resolved => closed
2020-03-27 06:53 alostale Fixed in Version => RR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker