Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043445
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Gift cards and gift vouchersmajoralways2020-03-06 12:262020-03-27 09:58
ReporterngarciaView Statuspublic 
Assigned Torqueralta 
PriorityurgentResolutionopenFixed in Version
StatusscheduledFix in branchFixed in SCM revisionadc149f09c2a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043445: Gift Card is cancelled when it is returned although it is not included in the ticket because negative lines are not allowed

DescriptionGift Card is cancelled when it is returned although it is not included in the ticket because negative lines are not allowed
Steps To ReproduceIn the backoffice:
   Set the Do not allow Sales with return preference to Y

In the POS:
   Add a Gift Card Infinite to the receipt
   Pay it

In the backoffice:
   Check a new Gift Card Instance has been created in New status

In the POS:
   Add a product to the receipt
   Select Gift / Credit Notes
   Select previously created Gift Card
   Return it
   Check the following error is shown and the gift card is not included
      You cannot add a negative line in a sales order
   Complete the ticket

In the backoffice:
   Check the Gift Card Instance is Closed and it is set as Cancelled
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2020-03-23 13-48-57.png [^] (584,847 bytes) 2020-03-23 14:58

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0042880 closedranjith_qualiantech_com When the user do a return of a Gift Card based on product the negative line should be in a sales ticket 
related to defect 0042899 closedranjith_qualiantech_com [20Q1] Returning a non returnable Gift Card does not work as expected in some circumstances 

-  Notes
(0118684)
hgbot (developer)
2020-03-18 21:49

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: b603dd4c4554796d19440fdf93efbf9a4bb02cc9
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Mar 18 14:58:14 2020 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/b603dd4c4554796d19440fdf93efbf9a4bb02cc9 [^]

Fixed BUG-43445: Gift Card is cancelled when it is returned although it is not
included in the ticket because negative lines are not allowed

- If OBPOS_NotAllowSalesWithReturn preference is true, call to CancelGiftCard
service was avoided.

---
M web/org.openbravo.retail.giftcards/js/model/GiftCardUtils.js
---
(0118761)
adrianromero (manager)
2020-03-23 14:57

The are several issues related to this fix:

* The callback "fail()" of the function "cancelGiftCard" is not invoked, so the dialog stays in an inconsistent status.
* It should be allowed to add the returned giftcard to the receipt if there is no other line in the receipt. The preference "Do not allow Sales with return" does not allow to mix positive and negative lines. But it allows only negative lines. Otherwise it will not be possible to return a giftcard with this preference activated.
* To be consistent with other error messages displayed when trying to return or apply a giftcard, a dialog must be displayed instead of a "showerror" message. See for example screenshot attached.
(0118771)
adrianromero (manager)
2020-03-23 17:18

Important: Note this issue is closely related to issues 42899 and 42880 and probably all theses issues should be fixed as a whole allowing the functional flow of returning a gift card is consistent in all preferences combination related to returns and giftcards: "Do not allow Sales with return", "Web POS action Return receipt", ...
(0118850)
hgbot (developer)
2020-03-27 03:29

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: adc149f09c2a8c5935d431b8d650143fe266024e
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Thu Mar 26 22:25:23 2020 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/adc149f09c2a8c5935d431b8d650143fe266024e [^]

Fixed BUG-43445: Gift Card is cancelled when it is returned although it is not
included in the ticket because negative lines are not allowed

- Backed out changeset: b603dd4c4554

---
M web/org.openbravo.retail.giftcards/js/model/GiftCardUtils.js
---

- Issue History
Date Modified Username Field Change
2020-03-06 12:26 ngarcia New Issue
2020-03-06 12:26 ngarcia Assigned To => Retail
2020-03-06 12:26 ngarcia Triggers an Emergency Pack => No
2020-03-06 12:27 ngarcia Issue Monitored: networkb
2020-03-18 00:08 rqueralta Assigned To Retail => rqueralta
2020-03-18 00:09 rqueralta Status new => scheduled
2020-03-18 21:49 hgbot Checkin
2020-03-18 21:49 hgbot Note Added: 0118684
2020-03-18 21:49 hgbot Status scheduled => resolved
2020-03-18 21:49 hgbot Resolution open => fixed
2020-03-18 21:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/b603dd4c4554796d19440fdf93efbf9a4bb02cc9 [^]
2020-03-23 14:57 adrianromero Note Added: 0118761
2020-03-23 14:57 adrianromero Status resolved => new
2020-03-23 14:57 adrianromero Resolution fixed => open
2020-03-23 14:58 adrianromero File Added: Screenshot from 2020-03-23 13-48-57.png
2020-03-23 17:13 adrianromero Relationship added related to 0042880
2020-03-23 17:14 adrianromero Relationship added related to 0042899
2020-03-23 17:18 adrianromero Note Added: 0118771
2020-03-27 03:29 hgbot Checkin
2020-03-27 03:29 hgbot Note Added: 0118850
2020-03-27 03:29 hgbot Status new => resolved
2020-03-27 03:29 hgbot Resolution open => fixed
2020-03-27 03:29 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/b603dd4c4554796d19440fdf93efbf9a4bb02cc9 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/adc149f09c2a8c5935d431b8d650143fe266024e [^]
2020-03-27 08:19 marvintm Status resolved => new
2020-03-27 08:19 marvintm Resolution fixed => open
2020-03-27 09:58 guilleaer Status new => scheduled


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker