Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043364
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminorhave not tried2020-02-28 10:402020-03-23 09:01
ReporterAugustoMauchView Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionfixedFixed in VersionRR20Q2
StatusclosedFix in branchFixed in SCM revision4ce5aa1b2b73
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojorge-garcia
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043364: The layout is wrong when there are more than 6 payment methods in the Count Cash window

DescriptionIf there are more than 6 payment methods shown in the Count Cash step of the cashup, the numeric pad layout is wrong and the enter key is not shown.

See attached image.
Steps To ReproduceI reproduced it https://livebuilds.openbravo.com/retail_modules_pgsql_pi [^]

In the backend:
- Open the touchpoint type YS POS Terminal Type
- In the Payment method subtab, mark all payment methods as:Count Payment in Cashup = true, Count Cash = false

In the webpos
- Login in terminal YS-11
- Do a cashup (you might need to first finish the current one to reload the payment method info).
- In the count cash step the layout will be wrong (see attached image)
TagsNOR
Attached Filespng file icon WrongLayoutInCashup.png [^] (186,964 bytes) 2020-02-28 10:41

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0043537 newRetail "More" payment methods buttons in CashUp are wrong 

-  Notes
(0118342)
hgbot (developer)
2020-03-05 13:46

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 1193489d41a0e200aa0a1db5f96e1e21f23a1e9f
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Mar 04 18:48:31 2020 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1193489d41a0e200aa0a1db5f96e1e21f23a1e9f [^]

Fixed BUG-43364: The layout is wrong when there are more than 6 payment methods
in the Count Cash window

- Added min-height to this class and change the height to 100%

---
M web/org.openbravo.retail.posterminal/css/obpos-main.css
---
(0118561)
jorge-garcia (developer)
2020-03-12 18:03

The solution works and the buttons from keypad are shown, but the layout is still broken.

The "clock" component and the keyboard in Cashup should be always in the same relative position in all steps.

The propose solution is to check step 1 (in which the cashier declares how many coins and bills are of each type for the payment method) and replicate the behavior in the next step
(0118632)
hgbot (developer)
2020-03-16 20:14

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 0bb70167adb0f0eb6a9fc598c6428e727072d3ff
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Sun Mar 15 10:26:33 2020 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0bb70167adb0f0eb6a9fc598c6428e727072d3ff [^]

Fixed BUG-43364: The layout is wrong when there are more than 6 payment methods
in the Count Cash window

- Reverted this changes because was fixed in mobile core module css class

---
M web/org.openbravo.retail.posterminal/css/obpos-main.css
---
(0118633)
hgbot (developer)
2020-03-16 20:14

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 4ce5aa1b2b73f76d2e491866c58934de22a3065b
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Sun Mar 15 10:28:06 2020 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/4ce5aa1b2b73f76d2e491866c58934de22a3065b [^]

Fixed BUG-43364: The layout is wrong when there are more than 6 payment methods
in the Count Cash window

- Remove css class that broke the layout and change the button heigth

---
M web/org.openbravo.mobile.core/assets/css/obmobc-main.css
M web/org.openbravo.mobile.core/source/component/ob-keyboard.js
---
(0118744)
jorge-garcia (developer)
2020-03-23 09:01

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2020-02-28 10:40 AugustoMauch New Issue
2020-02-28 10:40 AugustoMauch Assigned To => Retail
2020-02-28 10:40 AugustoMauch Triggers an Emergency Pack => No
2020-02-28 10:41 AugustoMauch File Added: WrongLayoutInCashup.png
2020-02-28 12:40 rafaroda Tag Attached: NOR
2020-03-02 19:52 rqueralta Assigned To Retail => rqueralta
2020-03-02 19:52 rqueralta Status new => scheduled
2020-03-05 13:46 hgbot Checkin
2020-03-05 13:46 hgbot Note Added: 0118342
2020-03-05 13:46 hgbot Status scheduled => resolved
2020-03-05 13:46 hgbot Resolution open => fixed
2020-03-05 13:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1193489d41a0e200aa0a1db5f96e1e21f23a1e9f [^]
2020-03-12 17:43 jorge-garcia Review Assigned To => jorge-garcia
2020-03-12 18:03 jorge-garcia Note Added: 0118561
2020-03-12 18:03 jorge-garcia Status resolved => new
2020-03-12 18:03 jorge-garcia Resolution fixed => open
2020-03-16 20:14 hgbot Checkin
2020-03-16 20:14 hgbot Note Added: 0118632
2020-03-16 20:14 hgbot Status new => resolved
2020-03-16 20:14 hgbot Resolution open => fixed
2020-03-16 20:14 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1193489d41a0e200aa0a1db5f96e1e21f23a1e9f [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0bb70167adb0f0eb6a9fc598c6428e727072d3ff [^]
2020-03-16 20:14 hgbot Checkin
2020-03-16 20:14 hgbot Note Added: 0118633
2020-03-16 20:14 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0bb70167adb0f0eb6a9fc598c6428e727072d3ff [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/4ce5aa1b2b73f76d2e491866c58934de22a3065b [^]
2020-03-23 09:00 jorge-garcia Relationship added related to 0043537
2020-03-23 09:01 jorge-garcia Note Added: 0118744
2020-03-23 09:01 jorge-garcia Status resolved => closed
2020-03-23 09:01 jorge-garcia Fixed in Version => RR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker