Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043203
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2020-02-13 08:102020-03-20 17:54
ReporterpsarobeView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in VersionRR20Q2
StatusclosedFix in branchFixed in SCM revision38d39c4d560b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - QA Approved
Regression date2019-08-02
Regression introduced in releaseRR19Q4
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/file/711d273a9a3a/web/org.openbravo.retail.posterminal/js/model/order.js [^]
Triggers an Emergency PackNo
Summary

0043203: Discounts with Characteristics. Having diferent characteristics work as "OR" instead of "AND"

DescriptionIf you have two characterstics:
- Season
- Brand

And you use these two in the characteristic tab as:
- Season: 2019
- Brand: Gucci

Instead of applying the discount to the products that are in season 2019 and Gucci is applying to either product in season 2019 or with brand Gucci

Update: After analyze
Prior to discount refactor -> Working as OR -> match with above description -> Applying for products with at least one of the characteristics
After discounts refactor -> Working as AND -> only apply for products with both characteristics
Steps To Reproduce1. Create two characteristics with values
2. In the discount and promotion window select price adjustment with 10%
3. Move to the Characteristics tab and add these two characteristics and with value in each.
4. Go to POS and see the result.

Expected result:
- Only for products that are season 2019 and Gucci

Current result:
- It is applying to either products that in season 2019 or Gucci
Proposed SolutionThis is the expected behaviour with the current definition. We need to improve the configuration options so that we can support both ways of working.

The proposal is the following:
- First we need to change the configuration options of the "Included characteristics". We need to replace the "Only the values defined" by "Any of the ones defined" (change only the displayed value, we should not change the internal value of the reflist to preserve the compatibility with previous data), and we need to add a new one called "All of the values defined".
- After that we need to change the discount-rules.js file (specifically the isApplicableToLine function), to take into account this new value, so that if it is set, all characteristic values specified in the discount need to be present in the product for the discount to be applicable to the line.


Update: After analyze
-> return to previous behavior -> OR
-> add new behavior -> AND
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0043282RR20Q1 closedranjith_qualiantech_com Discounts with Characteristics. Having diferent characteristics work as "OR" instead of "AND" 
depends on backport 0043283RR19Q4.2 closedranjith_qualiantech_com Discounts with Characteristics. Having diferent characteristics work as "OR" instead of "AND" 
related to feature request 0043204 closedRetail Discounts with Characteristics. It is not possible to create exceptions within characteristics. 

-  Notes
(0117961)
ranjith_qualiantech_com (developer)
2020-02-20 10:12

Updated Sampledata
https://code.openbravo.com/erp/pmods-branches/org.openbravo.test.mobile.sampledata/rev/87fe0ab4e4b8 [^]
(0117974)
hgbot (developer)
2020-02-20 15:17

Repository: erp/devel/pi
Changeset: 872551aee83f5f6aa034dd974727f801c98d26c5
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Feb 20 19:47:12 2020 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/872551aee83f5f6aa034dd974727f801c98d26c5 [^]

Related to issue 43203 : Added Reference List for Characteristics Offers

* New Reference List is created for Characteristics Offers Definition
  a) All excluding defined
  b) Any of the ones defined (Only those defined)
  c) All of the values defined (Discount will be applied
     only if all Characteristics is available in product)

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_REFERENCE.xml
M src-db/database/sourcedata/AD_REF_LIST.xml
---
(0117975)
hgbot (developer)
2020-02-20 15:17

Repository: erp/pmods/org.openbravo.retail.discounts
Changeset: 38d39c4d560b2115a78f3dd41bd579e89c195124
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Feb 20 19:47:35 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/38d39c4d560b2115a78f3dd41bd579e89c195124 [^]

Fixed issue 43203 : Updated Discount Calculation for Characteristics Definition

* Characteristics Definition is updated
  a) All excluding defined
  b) Any of the ones defined (Only those defined)
  c) All of the values defined (Discount will be applied only if all Characteristics is available in product)

---
M src-test/org/openbravo/retail/discounts/test/base/model/DiscountRule.java
M src-test/org/openbravo/retail/discounts/test/base/model/OfferCharacteristic.java
M src-test/org/openbravo/retail/discounts/test/base/model/ProductCharacteristic.java
M src-test/org/openbravo/retail/discounts/test/unittests/DiscountPriceAdjusmentTest.java
M web/org.openbravo.retail.discounts/js/discountsengine/common/discount-rules.js
---
(0117976)
ranjith_qualiantech_com (developer)
2020-02-20 15:31

Reopening to create backports
(0117992)
hgbot (developer)
2020-02-21 05:58

Repository: erp/pmods/org.openbravo.retail.discounts
Changeset: 0d11298c1f4ccaa20c5ae4f23b8764046002dd69
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Fri Feb 21 10:28:04 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/0d11298c1f4ccaa20c5ae4f23b8764046002dd69 [^]

Related to issue 43203 : Disabled Unit Test

---
M src-test/org/openbravo/retail/discounts/test/unittests/DiscountPriceAdjusmentTest.java
---
(0118642)
hgbot (developer)
2020-03-17 13:19

Repository: retail/backports/3.0RR20Q1/pi-mobile
Changeset: 09ca2c51134db500ce873c7ecfc598da686e4080
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Mar 17 17:41:40 2020 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR20Q1/pi-mobile/rev/09ca2c51134db500ce873c7ecfc598da686e4080 [^]

Stabilized Test C360CheckStatistics.java

* Disabled tests which are failing due to issue 43203

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/certification_france/OBCFRTicket.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/discounts_bytotal/I39536_VerifyTotalDiscountWithSplitLines.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/discounts_scaledprice/I40478_VerifyScaledDiscountWithLowerPrice.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/multidiscounts/Multidiscounts_ChangeLineQuantitiesWithByTotals.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/multidiscounts/Multidiscounts_RemoveMultiDiscountsByTotal.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/restaurants/VerifySubstitutedProductWithNotes.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/splitline/SplitLineWithAutomaticPromoCombos.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/splitline/SplitLineWithAutomaticPromoDiscPerTotalAmt.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/splitline/SplitLineWithAutomaticPromoFreeProdPerTotalAmt.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/splitline/SplitLineWithAutomaticPromoFreeProdScaledPriceAndManualPromo.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/splitline/SplitLineWithAutomaticPromoPercentDiscPerTotalAmt.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/splitline/SplitLineWithAutomaticPromoScaledPrice.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/stockvalidation/I34089_OrderFromQuotationAllowNegativeStock.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/stockvalidation/I34089_OrderFromQuotationNotAllowNegativeStock.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/stockvalidation/I34092_OrderStockValidationMultiReceipt.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/customer/C360CheckStatistics.java
---
(0118737)
hudsonbot (developer)
2020-03-20 17:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b31620115262 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2020-02-13 08:10 psarobe New Issue
2020-02-13 08:10 psarobe Assigned To => Retail
2020-02-13 08:10 psarobe Triggers an Emergency Pack => No
2020-02-13 08:11 martinsdan Issue Monitored: martinsdan
2020-02-13 08:31 martinsdan Relationship added related to 0043204
2020-02-13 09:06 marvintm Proposed Solution updated
2020-02-17 12:58 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-02-17 12:58 ranjith_qualiantech_com Status new => scheduled
2020-02-17 13:31 ranjith_qualiantech_com Note Added: 0117856
2020-02-20 10:12 ranjith_qualiantech_com Note Added: 0117961
2020-02-20 15:17 hgbot Checkin
2020-02-20 15:17 hgbot Note Added: 0117974
2020-02-20 15:17 hgbot Checkin
2020-02-20 15:17 hgbot Note Added: 0117975
2020-02-20 15:17 hgbot Status scheduled => resolved
2020-02-20 15:17 hgbot Resolution open => fixed
2020-02-20 15:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/38d39c4d560b2115a78f3dd41bd579e89c195124 [^]
2020-02-20 15:26 guilleaer Note Deleted: 0117856
2020-02-20 15:31 ranjith_qualiantech_com Regression level => Production - QA Approved
2020-02-20 15:31 ranjith_qualiantech_com Regression date => 2019-08-02
2020-02-20 15:31 ranjith_qualiantech_com Regression introduced in release => RR19Q4
2020-02-20 15:31 ranjith_qualiantech_com Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/file/711d273a9a3a/web/org.openbravo.retail.posterminal/js/model/order.js [^]
2020-02-20 15:31 ranjith_qualiantech_com Note Added: 0117976
2020-02-20 15:31 ranjith_qualiantech_com Status resolved => new
2020-02-20 15:31 ranjith_qualiantech_com Resolution fixed => open
2020-02-20 15:31 ranjith_qualiantech_com Status new => scheduled
2020-02-20 15:32 ranjith_qualiantech_com Status scheduled => resolved
2020-02-20 15:32 ranjith_qualiantech_com Resolution open => fixed
2020-02-20 17:09 guilleaer Description Updated View Revisions
2020-02-20 17:09 guilleaer Proposed Solution updated
2020-02-20 19:39 marvintm Review Assigned To => marvintm
2020-02-20 19:39 marvintm Status resolved => closed
2020-02-20 19:39 marvintm Fixed in Version => RR20Q2
2020-02-21 05:58 hgbot Checkin
2020-02-21 05:58 hgbot Note Added: 0117992
2020-02-27 18:33 rafaroda Issue Monitored: rafaroda
2020-03-17 13:19 hgbot Checkin
2020-03-17 13:19 hgbot Note Added: 0118642
2020-03-20 17:54 hudsonbot Checkin
2020-03-20 17:54 hudsonbot Note Added: 0118737


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker