Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043042
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2020-01-29 09:552020-02-12 17:20
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revisionb85ca0db386b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2019-05-07
Regression introduced in release3.0PR19Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/3c5c9d991b1e6e6c6aeedad4a6cbf35dbbdcabe1 [^]
Triggers an Emergency PackNo
Summary

0043042: [Balance Sheet and P&L Structure: User can select General Ledger of organizations for its natural tree but not Accounting Report

Description[Balance Sheet and P&L Structure: User can select General Ledger of organizations for its natural tree but not Accounting Report
Steps To ReproduceAs group admin role:
   Define a General Ledger in * organization
   Define a Balance sheet and P&L structure setup in * organization

Log out and log in:
   Check you can select the General Ledger and the Accounting report in the Balance sheet and P&L structure

Log in with a role that do not have access to organization:
    Check you can select the General Ledger but you cannot select the Accounting report in the Balance sheet and P&L structure
Proposed SolutionThe filter of the Accounting Report field should be the same as the filter for the General Ledger. It is using #AccessibleOrgTree

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00431913.0PR20Q1 closedAtulOpenbravo [Balance Sheet and P&L Structure: User can select General Ledger of organizations for its natural tree but not Accounting Report 
depends on backport 00431923.0PR19Q4.2 closedAtulOpenbravo [Balance Sheet and P&L Structure: User can select General Ledger of organizations for its natural tree but not Accounting Report 
depends on backport 00431933.0PR19Q3.4 closedAtulOpenbravo [Balance Sheet and P&L Structure: User can select General Ledger of organizations for its natural tree but not Accounting Report 
caused by defect 0040698 closednonofrancisco Accounting Report field of Balance Sheet and P&L structure is showing definitions made in non-accessible organizations 

-  Notes
(0117509)
dmiguelez (developer)
2020-02-06 11:42

The severity of the issue has been updated to minor following the Openbravo reporting guidelines:
http://wiki.openbravo.com/wiki/Bug_Reporting_Guidelines [^]
(0117619)
AtulOpenbravo (developer)
2020-02-11 05:49
edited on: 2020-02-12 06:40

- Create a General Ledger (Star GL) and Balance Sheet and P&L Structure Setup (RPT Star) record in Star Organization.
- Create a new Organization (US 1) under F&B US Inc as Generic, Assign new General Ledger (Star GL) in new organization i.e US 1, set this as Ready.
- Create a General Ledger (GL US) and Balance Sheet and P&L Structure Setup (RPT US) record in F&B US Inc Organization. Assign new General Ledger in respective organization i.e F&B US Inc.
- Create a General Ledger (GL EC) and Balance Sheet and P&L Structure Setup (RPT EC) record in F&B US East Coast Organization. Assign new General Ledger in respective organization i.e F&B US East Coast.
- Create a Role (US Role) with access to F&B US Inc Organization and Balance Sheet and P&L Structure Report & Process access.
- Create a Role (EC Role) with access to F&B US East Coast Organization and Balance Sheet and P&L Structure Report & Process access..
- Create a Role (Group + EC Role) with access to F&B International Group & F&B US East Coast Organization and Balance Sheet and P&L Structure Report & Process access..
- Create a Role (US1 Role) with access to US1 Organization and Balance Sheet and P&L Structure Report & Process access.

Test A:

- Login with US1 Role
- Navigate to Balance Sheet and P/L Structure
- Realize that General Ledger shows Star GL, F&B International Group US/A/US Dollar and US GL in the list.
- When selecting Star GL, Accounting Report shown is Star RPT, select Star RPT, Organization shown is US1 in the list.
- When selecting F&B International Group US/A/US Dollar GL, Accounting Report shown are Balance Sheet, Profit & Loss.
- Select Balance Sheet RPT, Organization list is empty. This is correct has US1 organization is of Generic Type.
- Select Profit and Loss or US RPT, Organization US1 is shown in the list.
- Select US GL, US RPT is shown in Accounting Report, select it, US1 organization is in the list.


Test B:

- Login with US Role
- Navigate to Balance Sheet and P/L Structure
- Realize that General Ledger shows Star GL, US GL, EC GL, F&B International Group US/A/US Dollar
- When selecting EC GL, Accounting Report show EC RPT, select it, only organization F&B US Inc is available in the list.
- When selecting US GL, Accounting Report show US RPT, select it, only organization F&B US Inc is available in the list.
- When selecting Star GL, Accounting Report shows Star RPT, select it, only organization F&B US Inc is available in the list.
- When selecting F&B International Group US/A/US Dollar Ledger, Accounting Report displayed are Balance Sheet, Profit & Loss.
- When selecting any one of the RPT i.e Balance Sheet or Profit & Loss, Organization F&B US Inc is only available in the list.


Test C
- Login with EC Role
- Navigate to Balance Sheet and P/L Structure
- Realize that General Ledger available in the list are Star GL, US GL, EC GL, F&B International Group US/A/US Dollar.
- Select Star GL, Accounting Report shown is Star RPT, when selecting it, Organization list is empty.
- Select EC GL , Realize that Accounting Report list shows only EC RPT, select it, Organization shows only F&B US East Coast in the list.
- Select US GL , Realize that Accounting Report list shows only US RPT, select it, Organization shows only F&B US East Coast in the list.
- When selecting F&B International Group US/A/US Dollar Ledger, Accounting Report displayed are Balance Sheet, Profit & Loss.
- When selecting any one of the RPT i.e Profit & Loss, Organization F&B US East Coast is only available in the list. This is
correct.
- Select Balance Sheet RPT, Organization list is empty. This is correct has F&B US East Coast organization is of Generic Type.

Test D

- Login with Group + EC Role
- Navigate to Balance Sheet and P/L Structure
- Realize that General Ledger available in the list are
a. F&B Espana S.A US/A/Euro
b. F&B International Group US/A/US Dollar
c. GL US
d. GL EC
e. Star GL

D1.
- Select F&B Espana S.A US/A/Euro General Ledger, realize that Accounting Report shows
a. Balance de Situacion
b. Perdidas y Ganancias
appears in the list.
- Select a or b, realize only F&B International Group is available in Organization list. F&B East Coast is not shown here as it is not in the natural tree, though it is in the Role Organization Access list.

D2.
- Select F&B International Group US/A/US Dollar General Ledger, realize that Accounting Report shows
a. Balance Sheet
b. Profit and Loss
appears in the list.
- Select Balance Sheet in the Accounting Report
- Realize only F&B International Group is available in Organization list.
- Select Profit and Loss in the Accounting Report
- Realize F&B International Group & F&B US East Coast both are available in Organization list.

D3.
- Select GL US General Ledger
- Realize RPT US is only available in the Accounting Report, select it.
- Realize F&B International Group & F&B US East Coast both are available in Organization list.

D4.
- Select GL EC General Ledger
- Realize RPT EC is only available in the Accounting Report, select it.
- Realize F&B International Group & F&B US East Coast both are available in Organization list.

D5.
- Select Star GL General Ledger
- Realize RPT EC is only available in the Accounting Report, select it.
- Realize only F&B International Group is available in Organization list.

(0117704)
hgbot (developer)
2020-02-12 17:17

Repository: erp/devel/pi
Changeset: b85ca0db386b650f4584d9cc43dcae3227f82efb
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Fri Feb 07 14:55:33 2020 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/b85ca0db386b650f4584d9cc43dcae3227f82efb [^]

Fixes BUG-43042:[Balance Sheet and P&L Structure: User can
select General Ledger of organizations for its natural tree
but not Accounting Report

**While loading Accounting Reports in Balance Sheet and P&L
strcture, consider the natural tree of the accessible orgs,
instead of just checking the accessible organizations from
Role - Organization Access

---
M src/org/openbravo/erpCommon/ad_reports/GeneralAccountingReports.java
M src/org/openbravo/erpCommon/ad_reports/GeneralAccountingReports_data.xsql
---
(0117708)
dmiguelez (developer)
2020-02-12 17:20

Code Review + Testing Ok

- Issue History
Date Modified Username Field Change
2020-01-29 09:55 ngarcia New Issue
2020-01-29 09:55 ngarcia Assigned To => Triage Finance
2020-01-29 09:55 ngarcia Modules => Core
2020-01-29 09:55 ngarcia Triggers an Emergency Pack => No
2020-01-29 09:55 ngarcia Relationship added caused by 0040698
2020-01-29 09:58 ngarcia Proposed Solution updated
2020-01-29 09:59 ngarcia Issue Monitored: networkb
2020-01-30 15:40 dmiguelez Assigned To Triage Finance => AtulOpenbravo
2020-01-31 14:57 AtulOpenbravo Status new => scheduled
2020-02-06 11:42 dmiguelez Note Added: 0117509
2020-02-06 11:42 dmiguelez Severity major => minor
2020-02-11 05:49 AtulOpenbravo Note Added: 0117619
2020-02-12 05:39 AtulOpenbravo Note Edited: 0117619 View Revisions
2020-02-12 06:40 AtulOpenbravo Note Edited: 0117619 View Revisions
2020-02-12 06:41 AtulOpenbravo Status scheduled => acknowledged
2020-02-12 06:43 AtulOpenbravo Regression level => Production - Confirmed Stable
2020-02-12 06:43 AtulOpenbravo Regression date => 2019-05-07
2020-02-12 06:43 AtulOpenbravo Regression introduced in release => 3.0PR19Q3
2020-02-12 06:43 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/3c5c9d991b1e6e6c6aeedad4a6cbf35dbbdcabe1 [^]
2020-02-12 06:44 AtulOpenbravo Status acknowledged => scheduled
2020-02-12 17:17 hgbot Checkin
2020-02-12 17:17 hgbot Note Added: 0117704
2020-02-12 17:17 hgbot Status scheduled => resolved
2020-02-12 17:17 hgbot Resolution open => fixed
2020-02-12 17:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b85ca0db386b650f4584d9cc43dcae3227f82efb [^]
2020-02-12 17:20 dmiguelez Review Assigned To => dmiguelez
2020-02-12 17:20 dmiguelez Note Added: 0117708
2020-02-12 17:20 dmiguelez Status resolved => closed
2020-02-12 17:20 dmiguelez Fixed in Version => 3.0PR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker