Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042664
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-12-31 11:312020-06-24 14:59
ReportercbernerView Statuspublic 
Assigned Tocberner 
PrioritynormalResolutionfixedFixed in VersionPR20Q3
StatusclosedFix in branchFixed in SCM revision3ca41f8257dd
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0042664: Deprecated properties usage should be removed in platform modules

DescriptionSome columns have been deprecated in AD and their usage should be removed from platform modules.

There's a spreadsheet with modules that should be reviewed: https://docs.google.com/spreadsheets/d/1u90ALVtT3vLhhuq-Xqu5LLbunPjOexG3Ryt1FoN0OiQ/edit?usp=sharing [^]
Steps To ReproduceIn openbravo.properties add at the end:
hb.generate.deprecated.properties=true

- Execute ant smartbuild and it should show some warnings regarding the use of deprecated methods/properties.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0042665 closedAtulOpenbravo Openbravo ERP Deprecated properties usage should be removed in ERP modules 
related to defect 0042666 newRetail Retail Modules Deprecated properties usage should be removed in retail modules 
related to design defect 0044325 newplatform Openbravo ERP Remove columns of deprecated properties and its usage in XSQL/PL 

-  Notes
(0117881)
cberner (developer)
2020-02-17 18:37

Currently tracked in this MR: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/45 [^]
(0120821)
hgbot (developer)
2020-06-12 10:30

Repository: erp/devel/pi
Changeset: 3ca41f8257dd4fc6fe8851ca67759167bce841b8
Author: Cristian Berner <cristian.berner <at> openbravo.com>
Date: Tue Feb 25 11:01:08 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3ca41f8257dd4fc6fe8851ca67759167bce841b8 [^]

Fixes ISSUE-42664: Remove usage of deprecated properties in platform modules

Usage of deprecated properties is removed from core with some other
methods that were only strictly used by those deprecated methods or
properties.
Property deprecation is not set as default, so some SupressWarnings
will be added in future to address the remaining deprecation eclipse warnings.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachImplementationManager.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/DefaultsAttachmentActionHandler.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/event/NoteEventHandler.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewFieldHandler.java
M src-db/database/sourcedata/AD_COLUMN.xml
M src-test/src/org/openbravo/test/model/ClassLoaderTest.java
M src/org/openbravo/erpCommon/security/SessionLogin.java
---
(0120849)
alostale (developer)
2020-06-15 13:40
edited on: 2020-06-15 13:41

The following commit has is linked with an incorrect issue, it should be related to this one:

Repository: erp/devel/pi
Changeset: 62bb2d63402defd531020093f5e2e6d8a0dee4c5
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jun 15 13:28:58 2020 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/62bb2d63402defd531020093f5e2e6d8a0dee4c5 [^] [^]

related to ISSUE-44249: reverted part of the original commit

Reverting restriction in ClassLoaderTest querying for ad_model_object.
Although the original patch was correct, it made to fail some test in an
obsolte module.

Reverting this part now unitl the failing module gets fixed so that the
change can be re-applied again.

---
M src-test/src/org/openbravo/test/model/ClassLoaderTest.java
---

(0121034)
hgbot (developer)
2020-06-24 14:19

Repository: erp/mods/org.openbravo.obbo
Changeset: 833f854b2d42b6dee2b441cbd085818151c1bb37
Author: Cristian Berner <cristian.berner <at> openbravo.com>
Date: Thu Jun 18 18:31:54 2020 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.obbo/rev/833f854b2d42b6dee2b441cbd085818151c1bb37 [^]

Related to ISSUE-42664: Remove Model Implementations without java class

ClassLoaderTest had recently removed the usage of deprecated Tab
property, as a side effect, some AD_MODEL_OBJECT have been found
in this module without a java class implementation.

Those records have been removed from AD_MODEL_OBJECT as they are not
useful nor implemented.

---
M src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
---
(0121036)
hgbot (developer)
2020-06-24 14:59

Repository: erp/devel/pi
Changeset: fef95dbc12f82f3a5493f13ef8c8a885c75c55c1
Author: Cristian Berner <cristian.berner <at> openbravo.com>
Date: Wed Jun 24 14:57:29 2020 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fef95dbc12f82f3a5493f13ef8c8a885c75c55c1 [^]

Related to ISSUE-42664: Recover backed out ClassLoaderTest change

This removes usage of Deprecated property
"ModelImplementation.PROPERTY_TAB" in ClassLoaderTest class, it was
backed out because of a module test failing, this was fixed, so it is
reintroduced

---
M src-test/src/org/openbravo/test/model/ClassLoaderTest.java
---

- Issue History
Date Modified Username Field Change
2019-12-31 11:31 cberner New Issue
2019-12-31 11:31 cberner Assigned To => platform
2019-12-31 11:31 cberner Modules => Core
2019-12-31 11:31 cberner Triggers an Emergency Pack => No
2019-12-31 11:50 cberner Relationship added related to 0042666
2019-12-31 11:50 cberner Relationship added related to 0042665
2020-02-17 18:36 cberner Assigned To platform => cberner
2020-02-17 18:37 cberner Status new => scheduled
2020-02-17 18:37 cberner Note Added: 0117881
2020-06-09 17:57 cberner Relationship added related to 0044325
2020-06-12 10:30 hgbot Checkin
2020-06-12 10:30 hgbot Note Added: 0120821
2020-06-12 10:30 hgbot Status scheduled => resolved
2020-06-12 10:30 hgbot Resolution open => fixed
2020-06-12 10:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3ca41f8257dd4fc6fe8851ca67759167bce841b8 [^]
2020-06-12 11:29 alostale Review Assigned To => alostale
2020-06-12 11:29 alostale Status resolved => closed
2020-06-12 11:29 alostale Fixed in Version => 3.0PR20Q3
2020-06-15 13:40 alostale Note Added: 0120849
2020-06-15 13:41 alostale Note Edited: 0120849 View Revisions
2020-06-24 14:19 hgbot Checkin
2020-06-24 14:19 hgbot Note Added: 0121034
2020-06-24 14:59 hgbot Checkin
2020-06-24 14:59 hgbot Note Added: 0121036


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker