Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041837
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-09-18 12:562019-09-26 17:42
ReporteraaroncaleroView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in VersionRR19Q4
StatusclosedFix in branchFixed in SCM revision932a9c3e7c2b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojorge-garcia
Regression levelProduction - Confirmed Stable
Regression date2017-11-24
Regression introduced in releaseRR18Q1
Regression introduced by commithttp://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a43d2a1ce34121b644a806d761857b224f27a184 [^]
Triggers an Emergency PackNo
Summary

0041837: Order Selector no longer verifies if an order is in error status (import entry error/error while importing)

DescriptionIn 17Q4, the fix for issue 0035058 added a check when loading an order, to prevent loading it in web pos if the order was present in an Error While Importing or in an error Import Entry.
In 18Q1 the Paid Receipts selector was refactored and a new selector was created (issue 0036936).
The new selector missed the logic to check if the receipt being opened was present in the errors table.
Steps To ReproduceLogin in Web POS
Create a new layaway, add a product and complete it by clicking on Layaway.
Load the same layaway in two different terminals. Pay it partially on both terminals.
When completing the second payment, a new record will be generated in Errors While Importing POS Data window due to an Outdated Change exception.
Verify that after that it is still possible to load the receipt in WebPOS
Proposed SolutionThe check for records in import entry that currently exists for verified returns should be added to the code in charge of loading receipts on the standard selector:
This code:
                if (data[0].recordInImportEntry) {
                  OB.UTIL.showLoading(false);
                  OB.UTIL.showConfirmation.display(
                    OB.I18N.getLabel('OBMOBC_Error'),
                    OB.I18N.getLabel('OBPOS_ReceiptNotSynced', [
                      data[0].documentNo
                    ])
                  );
                }

Should be added to orderLoaded function in orderSelectorUtils.js
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0041862RR19Q3.1 closedranjith_qualiantech_com Order Selector no longer verifies if an order is in error status (import entry error/error while importing) 
depends on backport 0041863RR19Q2.3 closedranjith_qualiantech_com Order Selector no longer verifies if an order is in error status (import entry error/error while importing) 
caused by feature request 0036936 closedaaroncalero It would be nice to have a single selector to retrieve any type of document in WebPOS 

-  Notes
(0114720)
hgbot (developer)
2019-09-23 11:22

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: f96e970a4c125ce0f92dad4704c94de68d5ad69a
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Sep 23 14:51:46 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f96e970a4c125ce0f92dad4704c94de68d5ad69a [^]

Fixed issue 41837 : Sync Error should be shown when opening the receipt in POS.

* If receipt presents in Import Error, then error "ReceiptNotSynced" should be shown
  when opening the receipt/layaway in the pos

---
M web/org.openbravo.retail.posterminal/js/utils/orderSelectorUtils.js
---
(0114787)
jorge-garcia (developer)
2019-09-25 17:44

The issue is not completely correct.

After we detect the order is in Errors While Importing POS data (check of "data[0].recordInImportEntry") a popup is shown in the screen. After clicking OK on that confirmation popup, the user cannot load again any ticket using "Open Receipt" unless the application is refreshed.

The solution must include a statement to execute the errorCallback in case we detect the order is in Errors While Importing POS data ("data[0].recordInImportEntry" check).

This errorCallback should be invoked when the popup is closed.
(0114821)
hgbot (developer)
2019-09-26 17:33

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 932a9c3e7c2b7f3a88460ef62562ad319d1a1bf1
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Sep 26 21:02:39 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/932a9c3e7c2b7f3a88460ef62562ad319d1a1bf1 [^]

Fixed issue 41837 : Open Receipt Selector should verify the receipt status of ImportEntry

* Added AD Message for Open Related ticket

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/utils/orderSelectorUtils.js
---
(0114823)
jorge-garcia (developer)
2019-09-26 17:42

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-09-18 12:56 aaroncalero New Issue
2019-09-18 12:56 aaroncalero Assigned To => Retail
2019-09-18 12:56 aaroncalero Resolution time => 1569967200
2019-09-18 12:56 aaroncalero Regression level => Production - Confirmed Stable
2019-09-18 12:56 aaroncalero Regression date => 2017-11-24
2019-09-18 12:56 aaroncalero Regression introduced in release => RR18Q1
2019-09-18 12:56 aaroncalero Regression introduced by commit => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a43d2a1ce34121b644a806d761857b224f27a184 [^]
2019-09-18 12:56 aaroncalero Triggers an Emergency Pack => No
2019-09-18 12:57 aaroncalero Relationship added caused by 0036936
2019-09-19 12:43 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-09-20 07:51 ranjith_qualiantech_com Status new => scheduled
2019-09-20 14:35 marvintm Status scheduled => acknowledged
2019-09-20 14:36 marvintm Status acknowledged => scheduled
2019-09-23 11:22 hgbot Checkin
2019-09-23 11:22 hgbot Note Added: 0114720
2019-09-23 11:22 hgbot Status scheduled => resolved
2019-09-23 11:22 hgbot Resolution open => fixed
2019-09-23 11:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f96e970a4c125ce0f92dad4704c94de68d5ad69a [^]
2019-09-25 17:07 jorge-garcia Review Assigned To => jorge-garcia
2019-09-25 17:44 jorge-garcia Note Added: 0114787
2019-09-25 17:44 jorge-garcia Status resolved => new
2019-09-25 17:44 jorge-garcia Resolution fixed => open
2019-09-26 08:08 ranjith_qualiantech_com Status new => scheduled
2019-09-26 17:33 hgbot Checkin
2019-09-26 17:33 hgbot Note Added: 0114821
2019-09-26 17:33 hgbot Status scheduled => resolved
2019-09-26 17:33 hgbot Resolution open => fixed
2019-09-26 17:33 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f96e970a4c125ce0f92dad4704c94de68d5ad69a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/932a9c3e7c2b7f3a88460ef62562ad319d1a1bf1 [^]
2019-09-26 17:42 jorge-garcia Note Added: 0114823
2019-09-26 17:42 jorge-garcia Status resolved => closed
2019-09-26 17:42 jorge-garcia Fixed in Version => RR19Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker