Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041862
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajoralways2019-09-18 12:562019-09-27 09:41
ReporteraaroncaleroView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in VersionRR19Q3.1
StatusclosedFix in branchFixed in SCM revision6cf45ce3bf8a
ProjectionnoneETAnoneTarget VersionRR19Q3.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojorge-garcia
Regression levelProduction - Confirmed Stable
Regression date2017-11-24
Regression introduced in releaseRR18Q1
Regression introduced by commithttp://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a43d2a1ce34121b644a806d761857b224f27a184 [^]
Triggers an Emergency PackNo
Summary

0041862: Order Selector no longer verifies if an order is in error status (import entry error/error while importing)

DescriptionIn 17Q4, the fix for issue 0035058 added a check when loading an order, to prevent loading it in web pos if the order was present in an Error While Importing or in an error Import Entry.
In 18Q1 the Paid Receipts selector was refactored and a new selector was created (issue 0036936).
The new selector missed the logic to check if the receipt being opened was present in the errors table.
Steps To ReproduceLogin in Web POS
Create a new layaway, add a product and complete it by clicking on Layaway.
Load the same layaway in two different terminals. Pay it partially on both terminals.
When completing the second payment, a new record will be generated in Errors While Importing POS Data window due to an Outdated Change exception.
Verify that after that it is still possible to load the receipt in WebPOS
Proposed SolutionThe check for records in import entry that currently exists for verified returns should be added to the code in charge of loading receipts on the standard selector:
This code:
                if (data[0].recordInImportEntry) {
                  OB.UTIL.showLoading(false);
                  OB.UTIL.showConfirmation.display(
                    OB.I18N.getLabel('OBMOBC_Error'),
                    OB.I18N.getLabel('OBPOS_ReceiptNotSynced', [
                      data[0].documentNo
                    ])
                  );
                }

Should be added to orderLoaded function in orderSelectorUtils.js
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0041837 closedranjith_qualiantech_com Order Selector no longer verifies if an order is in error status (import entry error/error while importing) 

-  Notes
(0114824)
hgbot (developer)
2019-09-26 18:19

Repository: retail/backports/3.0RR19Q3.1/org.openbravo.retail.posterminal
Changeset: 6cf45ce3bf8af4171853694b91f00c43e8c5669b
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Sep 26 21:48:51 2019 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR19Q3.1/org.openbravo.retail.posterminal/rev/6cf45ce3bf8af4171853694b91f00c43e8c5669b [^]

Fixed issue 41862 : Open Receipt Selector should verify the receipt status of ImportEntry

* Added AD Message for Open Related ticket

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/utils/orderSelectorUtils.js
---
(0114830)
jorge-garcia (developer)
2019-09-27 09:41

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-09-20 14:36 marvintm Type defect => backport
2019-09-20 14:36 marvintm Target Version => RR19Q3.1
2019-09-26 18:19 hgbot Checkin
2019-09-26 18:19 hgbot Note Added: 0114824
2019-09-26 18:19 hgbot Status scheduled => resolved
2019-09-26 18:19 hgbot Resolution open => fixed
2019-09-26 18:19 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/backports/3.0RR19Q3.1/org.openbravo.retail.posterminal/rev/6cf45ce3bf8af4171853694b91f00c43e8c5669b [^]
2019-09-27 09:41 jorge-garcia Review Assigned To => jorge-garcia
2019-09-27 09:41 jorge-garcia Note Added: 0114830
2019-09-27 09:41 jorge-garcia Status resolved => closed
2019-09-27 09:41 jorge-garcia Fixed in Version => RR19Q3.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker