Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041315
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2019-07-08 12:022019-08-22 14:44
Reporterinaki_garciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revision9cb428280b30
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelAutomated tests
Regression date2019-07-03
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f831b0b71a5ec700751e645c9e6980001acd8c7b [^]
Triggers an Emergency PackNo
Summary

0041315: [AUoM] Operative Quantity isn't correctly calculated when Creating Lines in Purchase Invoice from a Return To Vendor order

DescriptionWhen creating lines from a Return To Vendor order in the Purchase Invoice window, those that make use of Alternate Unit of Measure don't have their Operative Quantity
correctly calculated, in accordance to the Conversion Rate of the alternate unit as the assertion of the AUMRTVc010InvoiceAReturnToVendorShipment test expects it.

This issue has arised from thanks to qa-pi-aum jobs executing under the QA tab of CI, and with the mentioned test. More details of one of the latest execution showing the
issue can be found in the following link:
https://ci.openbravo.com/view/qa/job/qa-pi-aum-pgsql/485/ [^]
Steps To ReproduceAs group admin role:
   Set 'Enable UOM Management' preference to Y
   Log out and log in
   Add Liter unit to 'Cerveza Ale 0,5L' in Alternate UOM tab as Primary UOM
   Add a conversion of 2
   Create a Goods Receipt
   Add 10 Liters of 'Cerveza Ale 0,5L':
      Operative Quantity: 10
      Alternative UOM: Liter
      Ordered Quantity: 20
      Storage Bin: O01
      UOM: Unit
   Book it
   Go to Return To Vendor
   Open the Pick/Edit Lines popup to select the lines of the previously created Goods Receipt
   Check the quantities and other fields are shown as in the order line in the pop-up
   Set the "returned" field to 3, "returned UOM" to "Liter" and "return reason" to "Defective"
   Check the Alternative UOM is updated with Liter in the Return To Vendor line:
      Movement Quantity: 6
   Book it
   Go to Return to Vendor Shipment, and use the Pick/Edit Lines popup to create the lines from the Return to Vendor, and book it
   Go to Purchase Invoice window, and create a new record by importing the lines with the Return To Vendor.
   NOTICE that the Operative Quantity shows as "-6" when the value expected by the test is "-3"
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00413213.0PR19Q3 closedcollazoandy4 [AUoM] Operative Quantity isn't correctly calculated when Creating Lines in Purchase Invoice from a Return To Vendor order 
depends on backport 00413273.0PR19Q1.2 closedcollazoandy4 [AUoM] Operative Quantity isn't correctly calculated when Creating Lines in Purchase Invoice from a Return To Vendor order 
depends on backport 00413283.0PR19Q2.1 closedcollazoandy4 [AUoM] Operative Quantity isn't correctly calculated when Creating Lines in Purchase Invoice from a Return To Vendor order 
caused by defect 0041174 closedcollazoandy4 Alternative UOM is modified to UOM in Create Lines From processes of Invoice window if it is defined as Secondary 

-  Notes
(0113294)
collazoandy4 (developer)
2019-07-11 18:29

Test Plan
  As system admin role:
   Set 'Enable UOM Management' preference to Y
   Log out and log in
  As F&B group admin role:
   Add Liter unit to 'Cerveza Ale 0,5L' in Alternate UOM tab as Primary UOM
   Add a conversion of 2
   Create a Goods Receipt with 10 Liters of 'Cerveza Ale 0,5L':
      Operative Quantity: 10
      Alternative UOM: Liter
      Ordered Quantity: 20
      Storage Bin: O01
      UOM: Unit
   Book it
   Go to Return To Vendor and return 3 Liter of previous Goods Receipt and Book it
   Go to Return to Vendor Shipment, and use the Pick/Edit Lines popup to create the lines from the Return to Vendor, and book it
   Go to Purchase Invoice window, and create a new record by importing the lines with the Return To Vendor and check:
     Operative Quantity: -6
     Alternative UOM: Unit
     Invoice Quantity: -6
     UOM: Unit
   Remove the new invoice line
   Create a new record by importing the line from the Return to Vendor Shipment and check:
     Operative Quantity: -6
     Alternative UOM: Unit
     Invoice Quantity: -6
     UOM: Unit

Test Plan II
  Create a new Sales Order with 5 Liter of Cerveza Ale 0,5L
  Create a new Sales Invoice and import the previous order line and check:
     Operative Quantity: 5
     Alternative UOM: Liter
     Invoice Quantity: 10
     UOM: Unit
(0113305)
hgbot (developer)
2019-07-11 20:16

Repository: erp/devel/pi
Changeset: 9cb428280b30ca250597896a89ab563265e3696a
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Thu Jul 11 10:53:26 2019 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/9cb428280b30ca250597896a89ab563265e3696a [^]

Fixes issue 41315: [AUoM] Operative Quantity isn't correctly calculated when
Creating Lines in Purchase Invoice from a Return To Vendor order

A wrong operative UOM was used to create the new invoiceline if the orderline is
related to a shipment, the quantity is calculated in the P&E and the UOM from the copied
line.

Now when a line is created from an orderline and is related to a not invoiced shipmentline
this shipmentline is used to create the new invoiceline, in case the orderline is a return
the return to vendor shipment line is used to create a new invoiceline

---
M src/org/openbravo/common/actionhandler/createlinesfromprocess/CreateLinesFromUtil.java
M src/org/openbravo/common/actionhandler/createlinesfromprocess/UpdateQuantitiesAndUOMs.java
---
(0113306)
hgbot (developer)
2019-07-11 20:16

Repository: erp/devel/pi
Changeset: 221767830742f8b992ed20c5c4b00071d7943525
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Jul 11 17:24:07 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/221767830742f8b992ed20c5c4b00071d7943525 [^]

related to issue 41315 code review changes

---
M src/org/openbravo/common/actionhandler/createlinesfromprocess/CreateLinesFromUtil.java
---
(0113316)
Sandrahuguet (developer)
2019-07-11 20:19

code review + testing ok
(0113467)
hgbot (developer)
2019-07-17 10:09

Repository: tools/automation/int
Changeset: 918ff9656d031728b0f1c5caa69a2ecb13a508f0
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Thu Jul 11 10:42:00 2019 -0400
URL: http://code.openbravo.com/tools/automation/int/rev/918ff9656d031728b0f1c5caa69a2ecb13a508f0 [^]

Related to issue 41315: Updated operative Quantity and UOM

The Operative Quantity and Operative UOM was updated to properly check the correct
values

---
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/aum/testsuites/returntovendor/AUMRTVc010InvoiceAReturnToVendorShipment.java
---
(0114143)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114144)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-07-08 12:02 inaki_garcia New Issue
2019-07-08 12:02 inaki_garcia Assigned To => Triage Finance
2019-07-08 12:02 inaki_garcia Modules => Core
2019-07-08 12:02 inaki_garcia Regression level => Automated tests
2019-07-08 12:02 inaki_garcia Regression date => 2019-07-03
2019-07-08 12:02 inaki_garcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f831b0b71a5ec700751e645c9e6980001acd8c7b [^]
2019-07-08 12:02 inaki_garcia Triggers an Emergency Pack => No
2019-07-08 12:02 inaki_garcia Issue generated from 0041174
2019-07-08 12:02 inaki_garcia Relationship added caused by 0041174
2019-07-08 12:44 inaki_garcia Description Updated View Revisions
2019-07-08 12:44 inaki_garcia Steps to Reproduce Updated View Revisions
2019-07-08 16:32 inaki_garcia Steps to Reproduce Updated View Revisions
2019-07-08 16:37 ngarcia Issue Monitored: ngarcia
2019-07-08 17:10 Sandrahuguet Assigned To Triage Finance => collazoandy4
2019-07-08 17:14 inaki_garcia Steps to Reproduce Updated View Revisions
2019-07-08 21:35 collazoandy4 Status new => scheduled
2019-07-09 10:22 Sandrahuguet Status scheduled => acknowledged
2019-07-09 10:22 Sandrahuguet Status acknowledged => scheduled
2019-07-10 08:54 Sandrahuguet Status scheduled => acknowledged
2019-07-10 08:54 Sandrahuguet Status acknowledged => scheduled
2019-07-10 18:41 Sandrahuguet Steps to Reproduce Updated View Revisions
2019-07-11 12:48 aferraz Steps to Reproduce Updated View Revisions
2019-07-11 12:50 aferraz Steps to Reproduce Updated View Revisions
2019-07-11 18:29 collazoandy4 Note Added: 0113294
2019-07-11 20:16 hgbot Checkin
2019-07-11 20:16 hgbot Note Added: 0113305
2019-07-11 20:16 hgbot Status scheduled => resolved
2019-07-11 20:16 hgbot Resolution open => fixed
2019-07-11 20:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9cb428280b30ca250597896a89ab563265e3696a [^]
2019-07-11 20:16 hgbot Checkin
2019-07-11 20:16 hgbot Note Added: 0113306
2019-07-11 20:19 Sandrahuguet Review Assigned To => Sandrahuguet
2019-07-11 20:19 Sandrahuguet Note Added: 0113316
2019-07-11 20:19 Sandrahuguet Status resolved => closed
2019-07-11 20:19 Sandrahuguet Fixed in Version => 3.0PR19Q4
2019-07-17 10:09 hgbot Checkin
2019-07-17 10:09 hgbot Note Added: 0113467
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114143
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114144


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker