Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041114
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-06-18 11:152019-06-26 14:10
Reporterinaki_garciaView Statuspublic 
Assigned Torqueralta 
PriorityimmediateResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression levelAutomated tests
Regression date2019-06-11
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9cc793f1bb71e37b7f18eb6716ea760dafe55815 [^]
Triggers an Emergency PackNo
Summary

0041114: Invoicing an Order with a prepayment in a different currency shows inconsistent Received Amounts in the Payment Plan of Order

DescriptionWhen invoicing an Order by partially prepaying it to a different currency (such as from EUR to USD), the Received Amount in the foreign currency doesn't match the original one. The Received foreign amount seems to match that of the Expected Amount for the Order.

This issue has arised thanks to the automated tests contributed for the related issue, SALRegression31873In*, which are running in the qa-pi-salreg and qa-pi-proreg jobs of the "qa" tab in
CI. It's reproducible in "main" and "pi" as of june 2019, but not in PR19Q1.1.

Steps To ReproduceThe steps to reproduce by the automated test are similar to these of the related issue. If further configuration details were needed, check the related issue
https://issues.openbravo.com/view.php?id=29403 [^]

0. Define conversion rate for today between EUR and USD
0. Define Prepayment account for Bebidas Alegres business partner in Vendor Accounting tab
0. Ensure that there is a Price List in USD currency, for purchase transactions. If it doesn't exist, create it
0. Define Financial Account payment to use different currencies for the same organization the Business Partner belongs to. Create a new Payment Method if needed which has the
"Receive Payments in Multiple Currencies" and "Make Payments in Multiple Currencies" checkboxes checked
1. Register Purchase Order for "España" org and "Bebidas Alegres" BP with the newly created Payment Method and with "Immediate" Invoice Term. Add any line setting qty=2 and process
2. Register Payment via the "Add Payment" process action to prepay the order completely
3. Register Purchase Invoice for "España" org and "Bebidas Alegres" BP. Run "Create lines from" and select previous order. Edit qty to set 1 and process
4. Post invoice and realize that entry generated for International Group ledger (in USD) is not correct as balance of prepayment account is not the invoice gross amount converted
4*. NOTICE that in the Payment Details of the first payment of the Payment Plan of the original Sales/Purchase Order, the "Received Amount *" and "Received (Account Currency)" fields don't match with each other

The execution of the automated test is depicted in the attached video, and the step 4*. can be checked in the 08:45-09:05 timeframe.
TagsNo tags attached.
Attached Files? file icon text.ParseException __ 17-06-2019 09_47_17.avi [^] (4,655,248 bytes) 2019-06-18 11:15

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00318733.0PR16Q2 closedvmromanos Openbravo ERP Wrong multicurrency accounting entry when posting partial invoice related to a prepaid order 
caused by defect 0040928 closedrqueralta Retail Modules The precision of the financial account currency is not used in transactions when paying a ticket with a different currency 

-  Notes
(0112972)
guilleaer (developer)
2019-06-24 12:22

Repository: erp/devel/pi
Changeset: fedce3dcb450098dfdf30948be3c2e64a5772eb5
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue Jun 18 18:28:20 2019 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/fedce3dcb450098dfdf30948be3c2e64a5772eb5 [^] [^]

Fixed issue 40928: The precision of the financial account currency is not
used in transactions when paying a ticket with a different currency

- If Payment_Schedule_Detail amount is different to Fin_Payment amount the
paidconverted is payment amount by rate in other case is the fin_payment amount

---
M src-db/database/model/views/FIN_PAYMENT_DETAIL_V.xml
---
(0113033)
marvintm (developer)
2019-06-26 14:10

Repository: erp/devel/pi
Changeset: 4a6e7e8d1c4c54b829802143377cb060238e315a
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue Jun 25 18:18:00 2019 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/4a6e7e8d1c4c54b829802143377cb060238e315a [^] [^]

Related to issue 40928: Backed out changeset: fedce3dcb450

---
M src-db/database/model/views/FIN_PAYMENT_DETAIL_V.xml
---
(0113034)
marvintm (developer)
2019-06-26 14:10

Changeset causing the issue was backed out.

- Issue History
Date Modified Username Field Change
2019-06-18 11:15 inaki_garcia New Issue
2019-06-18 11:15 inaki_garcia Assigned To => Triage Finance
2019-06-18 11:15 inaki_garcia File Added: text.ParseException __ 17-06-2019 09_47_17.avi
2019-06-18 11:15 inaki_garcia Modules => Core
2019-06-18 11:15 inaki_garcia Regression introduced in release => main
2019-06-18 11:15 inaki_garcia Triggers an Emergency Pack => No
2019-06-18 11:15 inaki_garcia Issue generated from 0031873
2019-06-18 11:15 inaki_garcia Relationship added related to 0031873
2019-06-18 11:25 inaki_garcia version main => pi
2019-06-18 12:57 inaki_garcia Steps to Reproduce Updated View Revisions
2019-06-18 13:40 Sandrahuguet Regression level => Automated tests
2019-06-18 13:40 Sandrahuguet Regression date => 2019-06-11
2019-06-18 13:40 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/9cc793f1bb71e37b7f18eb6716ea760dafe55815 [^]
2019-06-18 13:40 Sandrahuguet Assigned To Triage Finance => Retail
2019-06-18 13:52 jorge-garcia Project Openbravo ERP => Retail Modules
2019-06-18 13:53 jorge-garcia Category 09. Financial management => Web POS
2019-06-18 14:00 jorge-garcia Relationship added caused by 0040928
2019-06-18 14:26 ngarcia Issue Monitored: ngarcia
2019-06-24 12:21 guilleaer Status new => scheduled
2019-06-24 12:22 guilleaer Note Added: 0112972
2019-06-24 12:22 guilleaer Status scheduled => resolved
2019-06-24 12:22 guilleaer Fixed in Version => RR19Q3
2019-06-24 12:22 guilleaer Resolution open => fixed
2019-06-24 12:22 guilleaer Assigned To Retail => rqueralta
2019-06-24 19:03 marvintm Status resolved => new
2019-06-24 19:03 marvintm Resolution fixed => open
2019-06-24 19:03 marvintm Fixed in Version RR19Q3 =>
2019-06-26 00:25 rqueralta Status new => scheduled
2019-06-26 00:26 rqueralta Status scheduled => resolved
2019-06-26 00:26 rqueralta Resolution open => fixed
2019-06-26 14:10 marvintm Note Added: 0113033
2019-06-26 14:10 marvintm Review Assigned To => marvintm
2019-06-26 14:10 marvintm Note Added: 0113034
2019-06-26 14:10 marvintm Status resolved => closed
2019-06-26 14:10 marvintm Fixed in Version => RR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker