Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029403
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2015-03-25 13:082015-05-07 22:16
ReportermaiteView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisiona20d7406cc39
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-06-02
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/3e75e4d92c649e3293c1b6830771b0fba009b2da [^]
Triggers an Emergency PackNo
Summary

0029403: Invoice's entry generated against Currency Balancing account instead of Vendor Prepayment account

DescriptionInvoice's entry generated against Currency Balancing account instead of Vendor Prepayment account
Steps To Reproduce1. Define Conversion Rate for today between MXN - EUR and MXN - USD
2. Create Price List in MXN currency, for purchase transactions
3. Define Financial Account payment to use different currencies
4. Register Purchase Order using MXN price list, add any line and process
5. Register multicurrency payment using Add Payment process from order's header
6. Register receipt using Pending Goods Receipt form
7. Register Purchase Invoice using Create Lines from process. Post invoice and realize that accounting entry is generated against Currency balancing account instead of Vendor Prepayment account
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00294563.0PR15Q1.3 closedvmromanos Invoice's entry generated against Currency Balancing account instead of Vendor Prepayment account 
depends on backport 00294713.0PR15Q2 closedvmromanos Invoice's entry generated against Currency Balancing account instead of Vendor Prepayment account 
caused by feature request 00259763.0PR14Q3 closededuardo_Argal Open Balances 
related to defect 00318733.0PR16Q2 closedvmromanos Wrong multicurrency accounting entry when posting partial invoice related to a prepaid order 

-  Notes
(0076169)
hgbot (developer)
2015-03-31 12:33

Repository: erp/devel/pi
Changeset: a20d7406cc397985fbcb325c9f38c5467dd8a69f
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Mar 30 13:43:26 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a20d7406cc397985fbcb325c9f38c5467dd8a69f [^]

Fixed bug 29403: Invoice's entry Currency Balancing instead of Vendor Prepayment

The selectPrepayments method now searches by FIN_PAYMENT_SCHEDULEDETAIL.FIN_PAYMENT_SCHEDULE_ORDER instead of FIN_PAYMENT_SCHEDULEDETAIL.FIN_PAYMENT_SCHEDULE_INVOICE, because a prepayment is linked to an order.

---
M src/org/openbravo/erpCommon/ad_forms/DocInvoice_data.xsql
---
(0076285)
umartirena (developer)
2015-04-01 09:56

Code Review + Testing OK
(0077105)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-25 13:08 maite New Issue
2015-03-25 13:08 maite Assigned To => Sandrahuguet
2015-03-25 13:08 maite Modules => Core
2015-03-25 13:08 maite Triggers an Emergency Pack => No
2015-03-25 13:08 maite Issue Monitored: networkb
2015-03-25 13:18 heccam Issue Monitored: heccam
2015-03-25 13:54 umartirena Assigned To Sandrahuguet => eduardo_Argal
2015-03-27 10:48 umartirena Assigned To eduardo_Argal => vmromanos
2015-03-27 13:50 maite Target Version => 3.0PR15Q2
2015-03-27 14:39 vmromanos Regression level => Production - Confirmed Stable
2015-03-27 14:39 vmromanos Regression date => 2014-06-09
2015-03-27 14:39 vmromanos Regression introduced in release => 3.0PR14Q3
2015-03-27 14:39 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/57ae71ea5865 [^]
2015-03-27 14:41 vmromanos Regression date 2014-06-09 =>
2015-03-27 14:41 vmromanos Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/57ae71ea5865 [^] =>
2015-03-30 13:32 vmromanos Regression date => 2014-06-02
2015-03-30 13:32 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/3e75e4d92c649e3293c1b6830771b0fba009b2da [^]
2015-03-30 13:32 vmromanos Relationship added caused by 0025976
2015-03-30 13:33 vmromanos Status new => scheduled
2015-03-30 13:59 jonalegriaesarte Target Version 3.0PR15Q2 => 3.0PR15Q3
2015-03-31 12:32 umartirena Status scheduled => acknowledged
2015-03-31 12:32 umartirena Status acknowledged => scheduled
2015-03-31 12:33 hgbot Checkin
2015-03-31 12:33 hgbot Note Added: 0076169
2015-03-31 12:33 hgbot Status scheduled => resolved
2015-03-31 12:33 hgbot Resolution open => fixed
2015-03-31 12:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a20d7406cc397985fbcb325c9f38c5467dd8a69f [^]
2015-04-01 09:56 umartirena Review Assigned To => umartirena
2015-04-01 09:56 umartirena Note Added: 0076285
2015-04-01 09:56 umartirena Status resolved => closed
2015-04-01 09:56 umartirena Fixed in Version => pi
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077105
2016-01-14 17:25 vmromanos Relationship added related to 0031873


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker