Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029456
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 03. Procurement managementmajoralways2015-03-25 13:082015-04-01 17:57
ReportermaiteView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1.3
StatusclosedFix in branchFixed in SCM revision9f198e6affe3
ProjectionnoneETAnoneTarget Version3.0PR15Q1.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-06-02
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/3e75e4d92c649e3293c1b6830771b0fba009b2da [^]
Triggers an Emergency PackNo
Summary

0029456: Invoice's entry generated against Currency Balancing account instead of Vendor Prepayment account

DescriptionInvoice's entry generated against Currency Balancing account instead of Vendor Prepayment account
Steps To Reproduce1. Define Conversion Rate for today between MXN - EUR and MXN - USD
2. Create Price List in MXN currency, for purchase transactions
3. Define Financial Account payment to use different currencies
4. Register Purchase Order using MXN price list, add any line and process
5. Register multicurrency payment using Add Payment process from order's header
6. Register receipt using Pending Goods Receipt form
7. Register Purchase Invoice using Create Lines from process. Post invoice and realize that accounting entry is generated against Currency balancing account instead of Vendor Prepayment account
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00294033.0PR15Q3 closedvmromanos Invoice's entry generated against Currency Balancing account instead of Vendor Prepayment account 

-  Notes
(0076170)
umartirena (developer)
2015-03-31 12:37
edited on: 2015-03-31 12:51

Patch attached till Q1.3 backports repo is ready to push. Code Review + Testing already Done.

(0076298)
hgbot (developer)
2015-04-01 10:58

Repository: erp/backports/3.0PR15Q1.3
Changeset: 9f198e6affe383e140daf42849b13b3daa2a260a
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Mar 30 15:20:12 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/9f198e6affe383e140daf42849b13b3daa2a260a [^]

Fixed bug 29456: Invoice's entry Currency Balancing instead of Vendor Prepayment

The selectPrepayments method now searches by FIN_PAYMENT_SCHEDULEDETAIL.FIN_PAYMENT_SCHEDULE_ORDER instead of FIN_PAYMENT_SCHEDULEDETAIL.FIN_PAYMENT_SCHEDULE_INVOICE, because a prepayment is linked to an order.

---
M src/org/openbravo/erpCommon/ad_forms/DocInvoice_data.xsql
---

- Issue History
Date Modified Username Field Change
2015-03-30 13:33 vmromanos Type defect => backport
2015-03-30 13:33 vmromanos Target Version 3.0PR15Q2 => 3.0PR15Q1.3
2015-03-31 12:36 umartirena File Added: backport_29456.diff
2015-03-31 12:37 umartirena Note Added: 0076170
2015-03-31 12:51 umartirena Note Edited: 0076170 View Revisions
2015-04-01 10:58 hgbot Checkin
2015-04-01 10:58 hgbot Note Added: 0076298
2015-04-01 10:58 hgbot Status scheduled => resolved
2015-04-01 10:58 hgbot Resolution open => fixed
2015-04-01 10:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/9f198e6affe383e140daf42849b13b3daa2a260a [^]
2015-04-01 10:58 umartirena Review Assigned To => umartirena
2015-04-01 10:58 umartirena Status resolved => closed
2015-04-01 10:58 umartirena Fixed in Version => 3.0PR15Q1.3
2015-04-01 10:59 umartirena File Deleted: backport_29456.diff
2015-04-01 17:57 dmitry_mezentsev Tag Attached: Approved


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker