Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040900
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-05-17 11:172019-05-27 12:38
Reportersalvador_campanellaView Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revision7d9d8e0754a7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRR19Q1.1SCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040900: when a receipt is printed the receipt have an blank spaces and a page break not wanted

Descriptionwhen a receipt is printed the receipt have an blank spaces and a page break

But if you reprint the receipt this problem not appears

The same Jasper report is used by the two process.
Steps To Reproduce[Web POS]
1.- Login
3.- Select a Business partner to do the receipt
3.- Make a Order Sale
4.- Click on amount button
5.- Select a Vendor
6.- finish the sale and print

Error: the receipt have an blank spaces and a page break not wanted
---

[Web POS]
1.- Open the receipt made before
2.- Print this receipt

The blank spaces and page break not wanted not appears

TagsNo tags attached.
Attached Filespatch file icon issue40900.patch [^] (1,324 bytes) 2019-05-20 13:28 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0111776)
hgbot (developer)
2019-05-19 17:36

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 7d9d8e0754a74b639f02ff6b1b26d9f521590cf4
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Fri May 17 17:46:23 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7d9d8e0754a74b639f02ff6b1b26d9f521590cf4 [^]

Fixed issue 40900: when a receipt is printed the receipt have an blank spaces
and a page break not wanted

- Removed unwanted spaces and page break

---
M web/org.openbravo.retail.posterminal/res/printclosedreceipt.xml
---
(0112137)
gsuarez (developer)
2019-05-24 23:35

This fix does not solve the problem described. the problem is reproduced only with jasper reports.
(0112163)
marvintm (developer)
2019-05-27 12:38

The fix does solve the problem reported. We know that the problem reported in the customer environment was related to jasper reports, but the custom jasper reports created for the customer have to be reviewed.

The same problem was reproducible with the standard xml templates in pi, and this is what we have resolved in this issue.

- Issue History
Date Modified Username Field Change
2019-05-17 11:17 salvador_campanella New Issue
2019-05-17 11:17 salvador_campanella Assigned To => Retail
2019-05-17 11:17 salvador_campanella Triggers an Emergency Pack => No
2019-05-17 23:29 rqueralta Assigned To Retail => rqueralta
2019-05-17 23:30 rqueralta Status new => scheduled
2019-05-19 17:36 hgbot Checkin
2019-05-19 17:36 hgbot Note Added: 0111776
2019-05-19 17:36 hgbot Status scheduled => resolved
2019-05-19 17:36 hgbot Resolution open => fixed
2019-05-19 17:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7d9d8e0754a74b639f02ff6b1b26d9f521590cf4 [^]
2019-05-20 13:28 marvintm File Added: issue40900.patch
2019-05-20 13:41 marvintm Review Assigned To => marvintm
2019-05-20 13:41 marvintm Status resolved => closed
2019-05-20 13:41 marvintm Fixed in Version => RR19Q3
2019-05-24 23:35 gsuarez Note Added: 0112137
2019-05-24 23:35 gsuarez Status closed => new
2019-05-24 23:35 gsuarez Resolution fixed => open
2019-05-24 23:35 gsuarez Fixed in Version RR19Q3 =>
2019-05-27 12:37 marvintm Status new => scheduled
2019-05-27 12:37 marvintm Status scheduled => resolved
2019-05-27 12:37 marvintm Fixed in Version => RR19Q3
2019-05-27 12:37 marvintm Resolution open => fixed
2019-05-27 12:38 marvintm Note Added: 0112163
2019-05-27 12:38 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker