Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040839
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Cash upmajoralways2019-05-10 14:042019-05-16 09:35
ReporteraaroncaleroView Statuspublic 
Assigned Torqueralta 
PriorityhighResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revisiond6c29e6e89fc
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040839: Partial Cash Up prints wrong amounts in the summary section

DescriptionPartial Cash Up prints wrong amounts in the summary section, it shows "undefined" instead of showing real amounts.

In addition, if the environment is using the Sessions module, if the printing fails and the user clicks on cancel or closes the popup, the application performs a logout.
Steps To ReproduceLogin in backend, go to the Channel - Touchpoint window and configure the hardware url for the VBS-1 terminal.
Login in webpos, terminal VBS-1.
Turn on the hardware manager.
Click on the menu > Cash Up Partial
Click on Print & Close.
Check the hardware manager for the printed report
Proposed SolutionThe parameters in the call to the print function in Partial Cash Up[1] are wrong: instead of following the "report, sumary, closed, callback" order (as defined by the function here[2]) the parameters are sent to the function in the order "report, closed, sumary, callback".

The boolean in place of the summary breaks the partial cashup printing, while the summary object in place of the closed boolean causes the sessions module to force a logout (since the print function has been overriden in that module).

The fix is simply to revert the order of the parameters to the correct order.


[1] https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/file/tip/web/org.openbravo.retail.posterminal/js/closecash/model/cashup-model.js#l838 [^]

[2] https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/file/tip/web/org.openbravo.retail.posterminal/js/closecash/model/cashup-print.js#l22 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0111698)
hgbot (developer)
2019-05-16 00:42

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: d6c29e6e89fc27ae4210743498890fe585fa4250
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue May 14 13:50:54 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d6c29e6e89fc27ae4210743498890fe585fa4250 [^]

Fixed issue 40839: Partial Cash Up prints wrong amounts in the summary section

- Changed parameters order in printCashUp.print function call

---
M web/org.openbravo.retail.posterminal/js/closecash/model/cashup-model.js
---

- Issue History
Date Modified Username Field Change
2019-05-10 14:04 aaroncalero New Issue
2019-05-10 14:04 aaroncalero Assigned To => Retail
2019-05-10 14:04 aaroncalero Triggers an Emergency Pack => No
2019-05-11 13:49 rqueralta Assigned To Retail => rqueralta
2019-05-11 13:49 rqueralta Status new => scheduled
2019-05-16 00:42 hgbot Checkin
2019-05-16 00:42 hgbot Note Added: 0111698
2019-05-16 00:42 hgbot Status scheduled => resolved
2019-05-16 00:42 hgbot Resolution open => fixed
2019-05-16 00:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d6c29e6e89fc27ae4210743498890fe585fa4250 [^]
2019-05-16 09:35 marvintm Review Assigned To => marvintm
2019-05-16 09:35 marvintm Status resolved => closed
2019-05-16 09:35 marvintm Fixed in Version => RR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker