Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040385
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-03-14 15:552019-03-28 14:56
ReporterplujanView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revisionedbcd9f7b55c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040385: [PR19Q1] Activating an instance after installing modules may create an incomplete update

DescriptionWhen the instance is set to update modules using a maturity other than "Confirmed Stable" the update process cannot be completed and the information shown to the user is not clear. See steps.
Steps To Reproduce0. In order to execute these steps a professional module with updates for QA status should exist.

1. Use a professional instance with maturity level when seeking for new modules is "QA Approved" and every module updated to this level.
2. Execute an install source. This will remove the activation but will keep the installed professional modules
3. In Module Management window, change the maturity level to "QA"
4. Scan for updates, check some of the professional modules have updates
5. Launch the update process. Note a message saying some modules require a professional instance.
6. Open "Instance activation" window and activate the instance
7. Clear cache and log back in.
8. In the Module Management window, check the list of modules to install is still present.
9. Launch the update process. Note an incomplete window is shown (see attached screenshot)
10. Return to the maturity level tab, note the maturity level has been set to "Confirmed Stable"
11. Change the level back to "QA" and repeat the process of update. Now should work as expected.

Proposed SolutionThe unexpected reset of the maturity level and the fact that the modules available for update remain unchanged are the root causes of this strange behaviour.
And an empty window showing no error nor information does not help.
TagsNo tags attached.
Attached Filespng file icon UpdatingBackend.png [^] (38,811 bytes) 2019-03-14 15:55

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0021251 closedAugustoMauch Model level reset to Confirmed Stable after license refresh 
related to design defect 0041229 feedbackplatform [19Q3] Activation of the instance resets the maturity level to search modules/updates 

-  Notes
(0110455)
hgbot (developer)
2019-03-15 11:53

Repository: erp/devel/pi
Changeset: edbcd9f7b55c515ef0b084ab3034d4e4f4f25296
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 15 11:53:09 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/edbcd9f7b55c515ef0b084ab3034d4e4f4f25296 [^]

fixed bug 40385: reset available updates when activating a community instance

  as in this process maturity status for updates in increased to confirmed stable
  if there were updates for lower status they might now be invalid.

---
M src/org/openbravo/erpCommon/obps/ActiveInstanceProcess.java
---
(0110566)
hgbot (developer)
2019-03-22 09:36

Repository: erp/devel/pi
Changeset: 56fd14677f8fdc749f2e9458003ebdd2ca00e1c8
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Mar 22 09:36:17 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/56fd14677f8fdc749f2e9458003ebdd2ca00e1c8 [^]

related to issue 40385: fix typo

---
M src/org/openbravo/erpCommon/obps/ActiveInstanceProcess.java
---
(0110567)
caristu (developer)
2019-03-22 09:37

Reviewed
(0110871)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110882)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-03-14 15:55 plujan New Issue
2019-03-14 15:55 plujan Assigned To => platform
2019-03-14 15:55 plujan File Added: UpdatingBackend.png
2019-03-14 15:55 plujan Modules => Core
2019-03-14 15:55 plujan Triggers an Emergency Pack => No
2019-03-15 11:51 alostale Assigned To platform => alostale
2019-03-15 11:51 alostale Review Assigned To => caristu
2019-03-15 11:53 hgbot Checkin
2019-03-15 11:53 hgbot Note Added: 0110455
2019-03-15 11:53 hgbot Status new => resolved
2019-03-15 11:53 hgbot Resolution open => fixed
2019-03-15 11:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/edbcd9f7b55c515ef0b084ab3034d4e4f4f25296 [^]
2019-03-22 09:36 hgbot Checkin
2019-03-22 09:36 hgbot Note Added: 0110566
2019-03-22 09:37 caristu Note Added: 0110567
2019-03-22 09:37 caristu Status resolved => closed
2019-03-22 09:37 caristu Fixed in Version => 3.0PR19Q2
2019-03-22 09:38 caristu Relationship added related to 0021251
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110871
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110882
2019-07-02 13:42 plujan Relationship added related to 0041229


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker