Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040253
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-02-21 13:292019-03-08 11:05
ReportercaristuView Statuspublic 
Assigned Tojarmendariz 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision372e1bed6b76
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-02-18
Regression introduced in release3.0PR18Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/0b908a2c7f992827a230b06193ad7f8f9bd2ce9b [^]
Triggers an Emergency PackNo
Summary

0040253: Responses from OB.RemoteCallManager calls are not handled if the Smartclient timeout is fired

DescriptionResponses from OB.RemoteCallManager calls are not handled if the Smartclient timeout is fired . This is a change in the behavior introduced with the following changeset[1].

Before that change the timeout error was not being properly handled causing the thrown of JS errors in the console. Despite this errors, the response was being handled by Smatclient.

Now the timeout error is being handled, showing the message in the UI. But seems that this causes the request response to be ignored when it finishes.

[1] https://code.openbravo.com/erp/devel/pi/rev/0b908a2c7f992827a230b06193ad7f8f9bd2ce9b#l1.37 [^]
Steps To ReproduceArtificial test:

1) Open the [Sales Order] window
2) Create a new sales order with at least one line and book it
3) Open the Add Payment window
4) Using the dev tools console reduce the timeout to be able to simulate the timeout expiration: isc.RPCManager.defaultTimeout = 1000
5) Put a breakpoint in the AddPaymentActionHandler class
6) In the client the message information about the timeout expiration appears
7) Step over the breakpoint and finish the execution of the handler --> note that the response message from the action handler does not apper

Before the mentioned changeset, the behavior was different:

1) The timeout message was not appearing (the error was thrown in the console instead)
2) The process pop-up was closed
3) The message from the action handler was shown properly in the header
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00402953.0PR19Q1 closedjarmendariz Responses from OB.RemoteCallManager calls are not handled if the Smartclient timeout is fired 
depends on backport 00402963.0PR18Q4.2 closedjarmendariz Responses from OB.RemoteCallManager calls are not handled if the Smartclient timeout is fired 
depends on backport 00402973.0PR18Q3.6 closedjarmendariz Responses from OB.RemoteCallManager calls are not handled if the Smartclient timeout is fired 
caused by defect 0035268 closedjarmendariz Request timeout message is not handled properly in the UI 
related to defect 0040342 newplatform Define a default query timeout profile for the standard grids 

-  Notes
(0110130)
hgbot (developer)
2019-02-28 17:47

Repository: erp/devel/pi
Changeset: 372e1bed6b76e79e3aa6dee740c399a80cc0e4d4
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Thu Feb 28 10:53:54 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/372e1bed6b76e79e3aa6dee740c399a80cc0e4d4 [^]

Fixed issue 40253: RemoteCallManager response not handled when timemout is fired.

Removed result sanitizing in RPCManager. This makes timeout message appears but
also marks the request as complete and the actual response is not processed when
it arrives.

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0110307)
caristu (developer)
2019-03-08 10:45

Code reviewed + tested OK.

- Issue History
Date Modified Username Field Change
2019-02-21 13:29 caristu New Issue
2019-02-21 13:29 caristu Assigned To => jarmendariz
2019-02-21 13:29 caristu Modules => Core
2019-02-21 13:29 caristu Regression level => Production - Confirmed Stable
2019-02-21 13:29 caristu Regression date => 2018-02-18
2019-02-21 13:29 caristu Regression introduced in release => 3.0PR18Q2
2019-02-21 13:29 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/0b908a2c7f992827a230b06193ad7f8f9bd2ce9b [^]
2019-02-21 13:29 caristu Triggers an Emergency Pack => No
2019-02-21 13:30 caristu Relationship added caused by 0035268
2019-02-28 17:10 jarmendariz Status new => scheduled
2019-02-28 17:47 hgbot Checkin
2019-02-28 17:47 hgbot Note Added: 0110130
2019-02-28 17:47 hgbot Status scheduled => resolved
2019-02-28 17:47 hgbot Resolution open => fixed
2019-02-28 17:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/372e1bed6b76e79e3aa6dee740c399a80cc0e4d4 [^]
2019-02-28 18:04 jarmendariz Assigned To jarmendariz => caristu
2019-02-28 18:04 jarmendariz Assigned To caristu => jarmendariz
2019-02-28 18:05 jarmendariz Review Assigned To => caristu
2019-03-08 10:45 caristu Note Added: 0110307
2019-03-08 10:45 caristu Status resolved => closed
2019-03-08 10:45 caristu Fixed in Version => 3.0PR19Q2
2019-03-08 11:05 caristu Issue cloned 0040342
2019-03-08 11:05 caristu Relationship added related to 0040342


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker