Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040219
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Retail Modules] StoreServermajorhave not tried2019-02-15 12:072019-03-14 18:07
ReportermtaalView Statuspublic 
Assigned Tomtaal 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision6852a2e09533
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040219: Simplify check on offline with sync errors or delta age, show delta age in mobile server

DescriptionThe current logic keeps track if when the store goes offline there are two cases:
- incoming errors
- age of the incoming batch is too old (expired)

This is done with two flags in the mobile server definition [1]. But there is also the check when going offline that neither of the two cases is allowed [2]. So offline is prevented in this case. So logically the flags are never set to true as the store does not offline in these cases.

Other change: would be good to show the delta age in the mobile server window.

[1]
https://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/file/tip/src/org/openbravo/retail/storeserver/synchronization/eventhandler/MobileServerEventHandler.java#l100 [^]
https://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/file/tip/src/org/openbravo/retail/storeserver/synchronization/RetailSynchronizationRequestHandler.java#l124 [^]

[2]
https://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/file/tip/src/org/openbravo/retail/storeserver/synchronization/StoreServerTransitionToOfflineExternalHandler.java#l40 [^]
Steps To Reproducerun multi-server
create incoming error
stop central
store does not go offline and extra flags/checks are not needed
Proposed SolutionRemove the code here remove the flags from the table
https://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/file/tip/src/org/openbravo/retail/storeserver/synchronization/eventhandler/MobileServerEventHandler.java#l100 [^]

https://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/file/tip/src/org/openbravo/retail/storeserver/synchronization/RetailSynchronizationRequestHandler.java#l124 [^]
TagsNo tags attached.
Attached Filesdiff file icon 40219-mobile-core.diff [^] (16,257 bytes) 2019-02-18 18:12 [Show Content]
diff file icon 40219-retail-sync.diff [^] (9,309 bytes) 2019-02-18 18:12 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
blocks feature request 0040287 resolvedmtaal API Change due to removal of internal/technical column in mobile server definition 

-  Notes
(0110196)
hgbot (developer)
2019-03-04 15:21

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: a9c1492b139dd1580d1ce4cb145f29e62d6d77f4
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Mar 04 15:15:32 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/a9c1492b139dd1580d1ce4cb145f29e62d6d77f4 [^]

Related to issue 40219: Simplify check on offline with sync errors or delta age, show delta age in mobile server
Remove the two 'flag' columns and add a field to show delta age in mobile server window

---
M src-db/database/model/tables/OBMOBC_SERVER_DEFINITION.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
---
(0110200)
hgbot (developer)
2019-03-04 15:32

Repository: erp/pmods/org.openbravo.retail.storeserver.synchronization
Changeset: 4bee8fab73a2788d5649955574c368628d1a6245
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Mar 04 15:32:26 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/rev/4bee8fab73a2788d5649955574c368628d1a6245 [^]

Fixes issue 40219: Simplify check on offline with sync errors or delta age, show delta age in mobile server
Remove the usage of the incoming error and delta-sync-error flag columns in the mobile server definition.

---
M src-db/database/sourcedata/STRSYNC_EXCLUDEDCOL.xml
M src/org/openbravo/retail/storeserver/synchronization/RetailSynchronizationRequestHandler.java
M src/org/openbravo/retail/storeserver/synchronization/StoreServerTransitionToOfflineExternalHandler.java
M src/org/openbravo/retail/storeserver/synchronization/eventhandler/MobileServerEventHandler.java
---
(0110356)
AugustoMauch (developer)
2019-03-11 17:01

The clean in the js for the management of the INVALID_OFFLINE error is missing
(0110359)
hgbot (developer)
2019-03-11 20:56

Repository: erp/pmods/org.openbravo.retail.storeserver.synchronization
Changeset: 6852a2e09533deebb29983424bbf458ef01528f2
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Mar 11 20:56:52 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/rev/6852a2e09533deebb29983424bbf458ef01528f2 [^]

Fixes issue 40219: Simplify check on offline with sync errors or delta age, show delta age in mobile server
Remove not needed jscript and messages

---
M src-db/database/sourcedata/AD_MESSAGE.xml
R web/org.openbravo.retail.storeserver.synchronization/js/responseCallbackHandler.js
---
(0110447)
AugustoMauch (developer)
2019-03-14 18:07

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2019-02-15 12:07 mtaal New Issue
2019-02-15 12:07 mtaal Assigned To => mtaal
2019-02-15 12:07 mtaal Triggers an Emergency Pack => No
2019-02-18 18:12 mtaal File Added: 40219-mobile-core.diff
2019-02-18 18:12 mtaal File Added: 40219-retail-sync.diff
2019-02-18 18:31 mtaal Review Assigned To => AugustoMauch
2019-03-04 15:21 hgbot Checkin
2019-03-04 15:21 hgbot Note Added: 0110196
2019-03-04 15:25 mtaal Relationship added blocks 0040287
2019-03-04 15:32 hgbot Checkin
2019-03-04 15:32 hgbot Note Added: 0110200
2019-03-04 15:32 hgbot Status new => resolved
2019-03-04 15:32 hgbot Resolution open => fixed
2019-03-04 15:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/rev/4bee8fab73a2788d5649955574c368628d1a6245 [^]
2019-03-11 17:01 AugustoMauch Note Added: 0110356
2019-03-11 17:01 AugustoMauch Status resolved => new
2019-03-11 17:01 AugustoMauch Resolution fixed => open
2019-03-11 20:56 hgbot Checkin
2019-03-11 20:56 hgbot Note Added: 0110359
2019-03-11 20:56 hgbot Status new => resolved
2019-03-11 20:56 hgbot Resolution open => fixed
2019-03-11 20:56 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/rev/4bee8fab73a2788d5649955574c368628d1a6245 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.storeserver.synchronization/rev/6852a2e09533deebb29983424bbf458ef01528f2 [^]
2019-03-14 18:07 AugustoMauch Note Added: 0110447
2019-03-14 18:07 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker