Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040086
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-01-31 13:262019-02-12 15:25
ReporterJONHMView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisionbd0f19e74267
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojorge-garcia
Regression levelPackaging and release
Regression date2019-02-07
Regression introduced in releaseRR18Q1.3
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/b249c950e647 [^]
Triggers an Emergency PackNo
Summary

0040086: In remote mode, the search on advance BP selector does not clear the filters

DescriptionIn remote mode, the search on advance BP selector does not clear the filters.
When filtering by City we got an error because the filter is not allowed, then we search for the Name and we still are getting the same error as before.
Also, if we open the Advance Filters, we can check that the filters are not deleted, and when pressing the 'Clear All' button is not working.
Probably those two errors are related.
Steps To ReproduceIn the backend, set the Preference "Enable Remote for Customer" with value 'Y' for "The White Valley Group" client.

In the WebPos, open the BP selector, select 'City' on the drop-down and enter some value. We got an error because filtering is not allowed for that property.

Then, select 'Full Name' on the drop-down and enter some value. We get the same error as before.

Notice that if we click on 'Advanced Filters' we are getting both values, and if we click on 'Clear All' button, nothing happens.
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2019-01-31 13-25-49.png [^] (108,190 bytes) 2019-01-31 13:26


patch file icon issue 40086 mobilecore fix.patch [^] (1,549 bytes) 2019-02-01 08:13 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0040126RR19Q1 closedranjith_qualiantech_com In remote mode, the search on advance BP selector does not clear the filters 
depends on backport 0040127RR18Q4.2 closedranjith_qualiantech_com In remote mode, the search on advance BP selector does not clear the filters 
depends on backport 0040128RR18Q3.5 closedranjith_qualiantech_com In remote mode, the search on advance BP selector does not clear the filters 
related to defect 0040097 closedranjith_qualiantech_com JS Error when searching with disabled filter in Open Receipt Selector 

-  Notes
(0109442)
hgbot (developer)
2019-02-02 07:34

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 53ec61cbfb0b44dd0dbc25765e15fa210765d28c
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Sat Feb 02 12:04:02 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/53ec61cbfb0b44dd0dbc25765e15fa210765d28c [^]

Fixed issue 40086 : All FilterSelector Fields should be cleared even it is disabled

* When clear method is called for FilterSelector Modal, all fields should be cleared even it is disabled
* For disabled fields, setPresetValue function will be undefined.
  Refactored clearAll method to support setPresetValue is present or not

---
M web/org.openbravo.mobile.core/source/component/dialog/ob-modaladvancedfilters.js
---
(0109539)
jorge-garcia (developer)
2019-02-04 17:47

Reopened to create backports
(0109589)
jorge-garcia (developer)
2019-02-05 15:40

Reopened to implement the logic to hide a combo filter in customer modal if the filter is disabled
(0109641)
hgbot (developer)
2019-02-06 15:14

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: bd0f19e74267b83ce40eb33ed6465e0022533990
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Feb 06 19:44:17 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/bd0f19e74267b83ce40eb33ed6465e0022533990 [^]

Fixed issue 40086 : Updated Filter Selector Table to use Filter with Selector Preference

* In Filter Selector Table, Filter Combo will be listed based on Entity Selector Preference

---
M web/org.openbravo.mobile.core/source/component/dialog/ob-advancedfilterselector.js
M web/org.openbravo.mobile.core/source/data/ob-model.js
---
(0109642)
hgbot (developer)
2019-02-06 15:14

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 1ee6378782bb1ebc20daeba387cc0006120282b6
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Feb 06 19:44:28 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1ee6378782bb1ebc20daeba387cc0006120282b6 [^]

Related to issue 40086 : Updated Filter Selector Table to use Filter with Selector Preference

* Refactored to get Filter Properties with Entity Selector Preference

---
M web/org.openbravo.retail.posterminal/js/components/businesspartner_selector.js
M web/org.openbravo.retail.posterminal/js/components/modal-pay-open-tickets.js
M web/org.openbravo.retail.posterminal/js/components/modalassociatetickets.js
M web/org.openbravo.retail.posterminal/js/components/modalorderselector.js
---
(0109658)
ranjith_qualiantech_com (developer)
2019-02-11 02:31

Reopened to refactor the AdvancedFilter Model
(0109664)
hgbot (developer)
2019-02-11 13:06

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e44e2232018b8ee25f7fa469177fb5527d56d5d9
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Feb 11 17:34:46 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e44e2232018b8ee25f7fa469177fb5527d56d5d9 [^]

Related to issue 40086 : Refactored Advanced Filter Modal to use FilterProperties With SelectorPreference

* filterModel is moved to parent component of FilterSelectorTableHeader to support/modify the filters based on configuration
  for eg. Business Partner Advanced Filter will be updated by Temrinal's "Show Business Partner Category"
* filters has been initialized before component rendering, since Filter Combo is rendered based on Filter Properties

---
M web/org.openbravo.retail.posterminal/js/components/businesspartner_selector.js
M web/org.openbravo.retail.posterminal/js/components/modal-pay-open-tickets.js
M web/org.openbravo.retail.posterminal/js/components/modalassociatetickets.js
M web/org.openbravo.retail.posterminal/js/components/modalorderselector.js
M web/org.openbravo.retail.posterminal/js/model/bpartnerfilter.js
---
(0109665)
hgbot (developer)
2019-02-11 13:06

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 882740b2a700eed878a7af68799836be9f76c0cd
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Feb 11 17:35:28 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/882740b2a700eed878a7af68799836be9f76c0cd [^]

Related to issue 40086 : Refactored Advanced Filter Modal to use model filter conditions

* Filters properties is defined in parent of advanced filter selector popup

---
M web/org.openbravo.mobile.core/source/component/dialog/ob-advancedfilterselector.js
M web/org.openbravo.mobile.core/source/component/dialog/ob-modaladvancedfilters.js
M web/org.openbravo.mobile.core/source/data/ob-model.js
---
(0109734)
jorge-garcia (developer)
2019-02-12 15:25

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-01-31 13:26 JONHM New Issue
2019-01-31 13:26 JONHM Assigned To => Retail
2019-01-31 13:26 JONHM File Added: Screenshot from 2019-01-31 13-25-49.png
2019-01-31 13:26 JONHM Regression date => 2019-02-07
2019-01-31 13:26 JONHM Triggers an Emergency Pack => No
2019-01-31 13:31 JONHM Regression introduced in release => RR18Q1.3
2019-01-31 13:44 JONHM Summary In remote mode, the search on advance BP selector do not clear the filters => In remote mode, the search on advance BP selector does not clear the filters
2019-01-31 13:44 JONHM Description Updated View Revisions
2019-01-31 13:51 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-01-31 13:51 ranjith_qualiantech_com Status new => scheduled
2019-02-01 08:13 ranjith_qualiantech_com File Added: issue 40086 mobilecore fix.patch
2019-02-01 08:28 ranjith_qualiantech_com Relationship added related to 0040097
2019-02-02 07:34 hgbot Checkin
2019-02-02 07:34 hgbot Note Added: 0109442
2019-02-02 07:34 hgbot Status scheduled => resolved
2019-02-02 07:34 hgbot Resolution open => fixed
2019-02-02 07:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/53ec61cbfb0b44dd0dbc25765e15fa210765d28c [^]
2019-02-04 17:47 jorge-garcia Note Added: 0109539
2019-02-04 17:47 jorge-garcia Status resolved => new
2019-02-04 17:47 jorge-garcia Resolution fixed => open
2019-02-04 17:48 jorge-garcia Status new => scheduled
2019-02-04 17:48 jorge-garcia Status scheduled => resolved
2019-02-04 17:48 jorge-garcia Fixed in Version => RR19Q2
2019-02-04 17:48 jorge-garcia Resolution open => fixed
2019-02-04 17:50 jorge-garcia Review Assigned To => jorge-garcia
2019-02-05 06:19 ranjith_qualiantech_com Regression level => Packaging and release
2019-02-05 06:19 ranjith_qualiantech_com Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/b249c950e647 [^]
2019-02-05 15:40 jorge-garcia Note Added: 0109589
2019-02-05 15:40 jorge-garcia Status resolved => new
2019-02-05 15:40 jorge-garcia Resolution fixed => open
2019-02-05 15:40 jorge-garcia Fixed in Version RR19Q2 =>
2019-02-05 15:40 jorge-garcia Status new => scheduled
2019-02-06 15:11 hgbot Checkin
2019-02-06 15:11 hgbot Note Added: 0109639
2019-02-06 15:14 hgbot Checkin
2019-02-06 15:14 hgbot Note Added: 0109641
2019-02-06 15:14 hgbot Status scheduled => resolved
2019-02-06 15:14 hgbot Resolution open => fixed
2019-02-06 15:14 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/53ec61cbfb0b44dd0dbc25765e15fa210765d28c [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/bd0f19e74267b83ce40eb33ed6465e0022533990 [^]
2019-02-06 15:14 hgbot Checkin
2019-02-06 15:14 hgbot Note Added: 0109642
2019-02-07 09:56 ranjith_qualiantech_com Note Deleted: 0109639
2019-02-11 02:31 ranjith_qualiantech_com Note Added: 0109658
2019-02-11 02:31 ranjith_qualiantech_com Status resolved => new
2019-02-11 02:31 ranjith_qualiantech_com Resolution fixed => open
2019-02-11 02:31 ranjith_qualiantech_com Status new => scheduled
2019-02-11 13:06 hgbot Checkin
2019-02-11 13:06 hgbot Note Added: 0109664
2019-02-11 13:06 hgbot Checkin
2019-02-11 13:06 hgbot Note Added: 0109665
2019-02-11 13:06 ranjith_qualiantech_com Status scheduled => resolved
2019-02-11 13:06 ranjith_qualiantech_com Resolution open => fixed
2019-02-12 15:25 jorge-garcia Note Added: 0109734
2019-02-12 15:25 jorge-garcia Status resolved => closed
2019-02-12 15:25 jorge-garcia Fixed in Version => RR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker