Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040126
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajoralways2019-01-31 13:262019-02-20 17:30
ReporterJONHMView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionf2fbe79a6f6b
ProjectionnoneETAnoneTarget VersionRR19Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojorge-garcia
Regression level
Regression date2019-02-07
Regression introduced in releaseRR18Q1.3
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040126: In remote mode, the search on advance BP selector does not clear the filters

DescriptionIn remote mode, the search on advance BP selector does not clear the filters.
When filtering by City we got an error because the filter is not allowed, then we search for the Name and we still are getting the same error as before.
Also, if we open the Advance Filters, we can check that the filters are not deleted, and when pressing the 'Clear All' button is not working.
Probably those two errors are related.
Steps To ReproduceIn the backend, set the Preference "Enable Remote for Customer" with value 'Y' for "The White Valley Group" client.

In the WebPos, open the BP selector, select 'City' on the drop-down and enter some value. We got an error because filtering is not allowed for that property.

Then, select 'Full Name' on the drop-down and enter some value. We get the same error as before.

Notice that if we click on 'Advanced Filters' we are getting both values, and if we click on 'Clear All' button, nothing happens.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040086 closedranjith_qualiantech_com In remote mode, the search on advance BP selector does not clear the filters 

-  Notes
(0109796)
hgbot (developer)
2019-02-13 11:19

Repository: retail/backports/3.0RR19Q1/org.openbravo.mobile.core
Changeset: f2fbe79a6f6bfa9a6d1786bdc4c07d7291514758
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Feb 13 15:48:44 2019 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.mobile.core/rev/f2fbe79a6f6bfa9a6d1786bdc4c07d7291514758 [^]

Fixed issue 40126 : Refactored Advanced Filter Modal to use model filter conditions

* Filters properties is defined in parent of advanced filter selector popup
* When clear method is called for FilterSelector Modal, all fields should be cleared even it is disabled
* For disabled fields, setPresetValue function will be undefined.
  Refactored clearAll method to support setPresetValue is present or not

---
M web/org.openbravo.mobile.core/source/component/dialog/ob-advancedfilterselector.js
M web/org.openbravo.mobile.core/source/component/dialog/ob-modaladvancedfilters.js
M web/org.openbravo.mobile.core/source/data/ob-model.js
---
(0109801)
hgbot (developer)
2019-02-13 11:20

Repository: retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal
Changeset: 7f0f05ee6d7a5c60162beed7566363c9efd2e99d
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Feb 13 15:47:21 2019 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal/rev/7f0f05ee6d7a5c60162beed7566363c9efd2e99d [^]

Related to issue 40126 : Refactored Advanced Filter Modal to use FilterProperties With SelectorPreference

* filterModel is moved to parent component of FilterSelectorTableHeader to support/modify the filters based on configuration
  for eg. Business Partner Advanced Filter will be updated by Temrinal's "Show Business Partner Category"
* filters has been initialized before component rendering, since Filter Combo is rendered based on Filter Properties

---
M web/org.openbravo.retail.posterminal/js/components/businesspartner_selector.js
M web/org.openbravo.retail.posterminal/js/components/modal-pay-open-tickets.js
M web/org.openbravo.retail.posterminal/js/components/modalassociatetickets.js
M web/org.openbravo.retail.posterminal/js/components/modalorderselector.js
M web/org.openbravo.retail.posterminal/js/model/bpartnerfilter.js
---
(0109967)
jorge-garcia (developer)
2019-02-20 17:30

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-02-04 17:48 jorge-garcia Type defect => backport
2019-02-04 17:48 jorge-garcia Target Version => RR19Q1
2019-02-13 11:19 hgbot Checkin
2019-02-13 11:19 hgbot Note Added: 0109796
2019-02-13 11:19 hgbot Status scheduled => resolved
2019-02-13 11:19 hgbot Resolution open => fixed
2019-02-13 11:19 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/53ec61cbfb0b44dd0dbc25765e15fa210765d28c [^] => http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.mobile.core/rev/f2fbe79a6f6bfa9a6d1786bdc4c07d7291514758 [^]
2019-02-13 11:20 hgbot Checkin
2019-02-13 11:20 hgbot Note Added: 0109801
2019-02-20 17:30 jorge-garcia Review Assigned To => jorge-garcia
2019-02-20 17:30 jorge-garcia Note Added: 0109967
2019-02-20 17:30 jorge-garcia Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker