Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039963
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Copy Retail Storemajorhave not tried2019-01-16 13:372019-02-11 11:54
ReporterjavietxeView Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revision0ceaf0f32238
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039963: SERQA 5043: Copy stores from excel still is very sensitive to blank characters in some fields

DescriptionNot all cases have been solved in the solution of the issue https://issues.openbravo.com/view.php?id=39701. [^]

For example, if the roles in the tab user-roles have a blank character after the name, the excel file gives an error.
Steps To ReproduceCreate a file for doing a copy stores with spaces after the name of the roles in the tab "User Roles" (or if you want take the excel file attached)

Do a copy stores with the excel file created in the previous step.

See that the role is not found because of the white character.
Proposed SolutionDo the trim in the API when reading the Excel cell in copy stores.
TagsNo tags attached.
Attached Filesxlsx file icon FileCopyStoreWithNewTab888.xlsx [^] (18,368 bytes) 2019-01-16 13:37

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0039701 closedrqueralta SERQA 4931 The Copy stores with Excel file is sensitive to white characters after and before the value. 

-  Notes
(0109023)
hgbot (developer)
2019-01-19 18:31

Repository: erp/pmods/org.openbravo.retail.copystore.excel
Changeset: 0ceaf0f32238b27830a3925089e86adcf50bcde0
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Sat Jan 19 12:30:17 2019 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.copystore.excel/rev/0ceaf0f32238b27830a3925089e86adcf50bcde0 [^]

Fixed issue 39963: SERQA 5043: Copy stores from excel still is very sensitive
to blank characters in some fields

- Removed blank characters of cell value.

---
M src/org/openbravo/retail/copystore/excel/ExcelCopyStoreField.java
---

- Issue History
Date Modified Username Field Change
2019-01-16 13:37 javietxe New Issue
2019-01-16 13:37 javietxe Assigned To => Retail
2019-01-16 13:37 javietxe File Added: FileCopyStoreWithNewTab888.xlsx
2019-01-16 13:37 javietxe Triggers an Emergency Pack => No
2019-01-16 13:38 javietxe Relationship added related to 0039701
2019-01-16 23:43 rqueralta Assigned To Retail => rqueralta
2019-01-16 23:44 rqueralta Status new => scheduled
2019-01-19 18:31 hgbot Checkin
2019-01-19 18:31 hgbot Note Added: 0109023
2019-01-19 18:31 hgbot Status scheduled => resolved
2019-01-19 18:31 hgbot Resolution open => fixed
2019-01-19 18:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.copystore.excel/rev/0ceaf0f32238b27830a3925089e86adcf50bcde0 [^]
2019-02-11 11:54 marvintm Review Assigned To => marvintm
2019-02-11 11:54 marvintm Status resolved => closed
2019-02-11 11:54 marvintm Fixed in Version => RR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker