Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039956
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Copy Retail Storemajoralways2019-01-15 14:052019-02-14 16:23
Reporterjoniturralde93View Statuspublic 
Assigned Torqueralta 
PriorityurgentResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisiondc0800a966f1
ProjectionnoneETAnoneTarget Versionpi
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039956: Under specific circumstances (payment type/method), copy terminal fails [financial account + leave as credit]

DescriptionIf you select no financial account for a payment type, and its payment method has leave as credit checked, copy terminal process fails.
Steps To Reproduce1. VBS-1 -> Payment type voucher
2. Manage to select no financial account and have payment method with leave as credit.
3. Copy terminal.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0108979)
hgbot (developer)
2019-01-16 13:00

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e62ce91d8ee7a774f77a11478a05afe41d10c8cf
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Mon Jan 14 15:38:45 2019 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e62ce91d8ee7a774f77a11478a05afe41d10c8cf [^]

Fixed issue 39956: Under specific circumstances (payment type/method), copy
terminal fails [financial account + leave as credit]

- Verifies if the financial account is null to avoid the event handler execution

---
M src/org/openbravo/retail/posterminal/event/AppPaymentEventHandler.java
---
(0109662)
marvintm (developer)
2019-02-11 12:00

The idea of the fix is good, but the implementation does not work. The changed code will crash with a NullPointerException when you define the payment method manually, because the condition which is being checked is incorrect. Instead of this:

    if (appPayment.getFinancialAccount().getId() != null) {


It should be like this:

    if (appPayment.getFinancialAccount() != null) {

The problem can be reproduced simply by creating a payment method in the touchpoint type with "leave as credit" checked, and then trying to create the corresponding payment method in the touchpoint window.
(0109680)
hgbot (developer)
2019-02-11 19:39

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: dc0800a966f1f6920cc5a6ba7de53b3de5e4fc78
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Mon Feb 11 10:30:02 2019 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dc0800a966f1f6920cc5a6ba7de53b3de5e4fc78 [^]

Fixed issue 39956: Under specific circumstances (payment type/method), copy
terminal fails [financial account + leave as credit]

- Fixed nullpointer caused by the previous solution

---
M src/org/openbravo/retail/posterminal/event/AppPaymentEventHandler.java
---

- Issue History
Date Modified Username Field Change
2019-01-15 14:05 joniturralde93 New Issue
2019-01-15 14:05 joniturralde93 Assigned To => rqueralta
2019-01-15 14:05 joniturralde93 Triggers an Emergency Pack => No
2019-01-16 09:20 jfrances Issue Monitored: jfrances
2019-01-16 13:00 hgbot Checkin
2019-01-16 13:00 hgbot Note Added: 0108979
2019-01-16 13:00 hgbot Status new => resolved
2019-01-16 13:00 hgbot Resolution open => fixed
2019-01-16 13:00 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e62ce91d8ee7a774f77a11478a05afe41d10c8cf [^]
2019-02-11 12:00 marvintm Note Added: 0109662
2019-02-11 12:00 marvintm Status resolved => new
2019-02-11 12:00 marvintm Resolution fixed => open
2019-02-11 19:39 hgbot Checkin
2019-02-11 19:39 hgbot Note Added: 0109680
2019-02-11 19:39 hgbot Status new => resolved
2019-02-11 19:39 hgbot Resolution open => fixed
2019-02-11 19:39 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e62ce91d8ee7a774f77a11478a05afe41d10c8cf [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dc0800a966f1f6920cc5a6ba7de53b3de5e4fc78 [^]
2019-02-14 16:23 marvintm Review Assigned To => marvintm
2019-02-14 16:23 marvintm Status resolved => closed
2019-02-14 16:23 marvintm Fixed in Version => RR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker