Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039885
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionaryminorhave not tried2019-01-08 18:572019-03-28 14:55
ReporteregoitzView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision0c885bc2fcec
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-03-01
Regression introduced in release3.0PR18Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/6d6a3a710fd21bbc60de46c5778b212c64ec300c [^]
Triggers an Emergency PackNo
Summary

0039885: The link to a concrete document of Openbravo is not followed if there is not session on the browser

DescriptionWhen using the link to navigate to a concrete document it works properly when you are logged in Openbravo.
If there is not a session you are requested to do the login and after the login
you are not redirected to the document.

It was working in previous releases.
Steps To Reproduce-Access to Openbravo
-go to sales order window
-clear the filter and open order in form view
-click on the toolbar button to get the link
-Copy the link
-Logout
-Use the link on a browser
-The login is required
*then you are not redirected to the document specified on the link.

Example:
https://livebuilds.openbravo.com/erp_pi_pgsql/?tabId=186&recordId=05C426107193402BBD8379EF92A63E96 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00399043.0PR19Q1 closedcaristu The link to a concrete document of Openbravo is not followed if there is not session on the browser 
depends on backport 00399053.0PR18Q4.2 closedcaristu The link to a concrete document of Openbravo is not followed if there is not session on the browser 
depends on backport 00399063.0PR18Q3.5 closedcaristu The link to a concrete document of Openbravo is not followed if there is not session on the browser 
caused by defect 0038079 closedalostale row created in ad_session opening openbravo base url 
related to defect 0039938 closedcaristu It is not needed to keep the URL target query string in session 

-  Notes
(0108936)
hgbot (developer)
2019-01-14 11:01

Repository: erp/devel/pi
Changeset: 0c885bc2fceca9a874c7b75e9efb7d27f2483aed
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 14 10:37:29 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0c885bc2fceca9a874c7b75e9efb7d27f2483aed [^]

fixes bug 39885: link to a document isn't followed properly after login

  Before[1] the URL query string used to specify the link to a concrete document was being stored in session. After that changeset the code to save that value in session was no longer being executed, so it was not possible to recover the document link information.

  To solve this problem now we keep the query string with the link information in the URL, and we retrieve it from there when needed.


  [1] https://code.openbravo.com/erp/devel/pi/rev/6d6a3a710fd21bbc60de46c5778b212c64ec300c [^]

---
M src/index.jsp
M src/org/openbravo/base/secureApp/LoginHandler.java
M src/org/openbravo/erpCommon/security/Login.html
M web/js/login.js
M web/js/utils.js
---
(0108939)
hgbot (developer)
2019-01-14 13:23

Repository: erp/devel/pi
Changeset: 76e291866ae6346fa03caa10937df42bf20a3490
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 14 13:23:02 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/76e291866ae6346fa03caa10937df42bf20a3490 [^]

related to issue 39885: make it work also when redirecting to Menu.html

  This flow happens when some kind of license restriction is detected during the login process

---
M src/org/openbravo/base/secureApp/LoginHandler.java
M src/org/openbravo/erpCommon/security/Menu.java
---
(0108952)
caristu (developer)
2019-01-14 16:07
edited on: 2019-01-14 16:07

TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-11123 [^]

(0108970)
hgbot (developer)
2019-01-16 09:39

Repository: erp/devel/pi
Changeset: 3277f851fae894cdde4f678a9591510cc71ff571
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Jan 16 09:37:56 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3277f851fae894cdde4f678a9591510cc71ff571 [^]

related to issue 39885: add test case

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
A src-test/src/org/openbravo/test/datasource/OpenRecordAfterLogin.java
---
(0109000)
alostale (developer)
2019-01-18 09:15

Reviewed + tested
(0110720)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110721)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110730)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-01-08 18:57 egoitz New Issue
2019-01-08 18:57 egoitz Assigned To => platform
2019-01-08 18:57 egoitz Modules => Core
2019-01-08 18:57 egoitz Regression level => Production - Confirmed Stable
2019-01-08 18:57 egoitz Triggers an Emergency Pack => No
2019-01-09 08:05 alostale Priority high => immediate
2019-01-09 11:00 caristu Assigned To platform => caristu
2019-01-09 17:53 caristu Relationship added caused by 0038079
2019-01-09 17:53 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/6d6a3a710fd21bbc60de46c5778b212c64ec300c [^]
2019-01-09 17:54 caristu Regression date => 2018-03-01
2019-01-09 17:54 caristu Regression introduced in release => 3.0PR18Q2
2019-01-09 18:01 caristu Status new => scheduled
2019-01-14 11:01 hgbot Checkin
2019-01-14 11:01 hgbot Note Added: 0108936
2019-01-14 11:01 hgbot Status scheduled => resolved
2019-01-14 11:01 hgbot Resolution open => fixed
2019-01-14 11:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0c885bc2fceca9a874c7b75e9efb7d27f2483aed [^]
2019-01-14 11:02 caristu Note Added: 0108937
2019-01-14 11:05 caristu Review Assigned To => alostale
2019-01-14 11:15 caristu Relationship added related to 0039938
2019-01-14 13:23 hgbot Checkin
2019-01-14 13:23 hgbot Note Added: 0108939
2019-01-14 16:07 caristu Note Deleted: 0108937
2019-01-14 16:07 caristu Note Added: 0108952
2019-01-14 16:07 caristu Note Edited: 0108952 View Revisions
2019-01-16 09:39 hgbot Checkin
2019-01-16 09:39 hgbot Note Added: 0108970
2019-01-18 09:15 alostale Note Added: 0109000
2019-01-18 09:15 alostale Status resolved => closed
2019-01-18 09:15 alostale Fixed in Version => 3.0PR19Q2
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110720
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110721
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110730


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker